Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Frame Relay Issues, plus some misc. questions.

First, let me say thanks to anyone who is going to help.

Alright, to the nitty-gritty, I have two 56k routers w/56 CSU/DSU cards in them connected back to back with a rollover cable. I don't believe the rollover plays a roll in this problem, becuase I have CD lights on both the routers.

I am new to dealing with routers, but the goal I'm trying to achieve is to link two stores with frame. I believe most of my configuration is correct, but I cannot get the line protocols to come up on the frame. Below should be most or all of the information you need. One last thing -- as I said, I'm new so if you guys see something that may not necessarily be applicable to my problem, I'd appreciate it if you brought it to my attention.

SHOW CONFIGURATION

------------------

Using 1063 out of 7506 bytes

!

version 12.0

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Kittanning

!

ip subnet-zero

!

!

!

interface Ethernet0

ip address 172.16.96.101 255.255.255.0

no ip directed-broadcast

no cdp enable

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

!

interface Serial1

no ip address

no ip directed-broadcast

encapsulation frame-relay

logging event subif-link-status

logging event dlci-status-change

service-module 56k clock source internal

!

interface Serial1.1 point-to-point

ip address 10.0.1.2 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 17

!

router eigrp 202

network 192.163.123.0

!

ip classless

SHOW FRAME PVC

--------------

PVC Statistics for interface Serial0 (Frame Relay DTE)

PVC Statistics for interface Serial1 (Frame Relay DTE)

DLCI = 17, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial1.1

input pkts 3 output pkts 0 in bytes 1824

out bytes 0 dropped pkts 3 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 0 out bcast bytes 0

pvc create time 00:28:12, last time pvc status changed 00:27:33

SHOW INT S1

-----------

Serial1 is up, line protocol is down

Hardware is QUICC Serial (with 56k 4-wire CSU/DSU WIC)

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 254/255, load 1/255

Encapsulation FRAME-RELAY, loopback not set, keepalive set (10 sec)

LMI enq sent 181, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down

LMI enq recvd 269, LMI stat sent 0, LMI upd sent 0

LMI DLCI 1023 LMI type is CISCO frame relay DTE

Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0

Last input 00:00:02, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

275 packets input, 5399 bytes, 0 no buffer

Received 1 broadcasts, 0 runts, 0 giants, 0 throttles

47 input errors, 0 CRC, 43 frame, 0 overrun, 0 ignored, 4 abort

272 packets output, 3575 bytes, 0 underruns

0 output errors, 0 collisions, 61 interface resets

0 output buffer failures, 0 output buffers swapped out

125 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

MY OTHER QUESTIONS

------------------

What is causing these annoying errors and how can I fix them?

%Error opening tftp://255.255.255.255/cisconet.cfg (Timed out)

%Error opening tftp://255.255.255.255/kittanning-confg (Timed out)

%Error opening tftp://255.255.255.255/kittanni.cfg (Timed out)

Also, the address I supply to the Frame sub interface is just for connection between the two routers, correct? And the same thing for the DLCI, I don't understand why I need another IP address for that.

The routing I'm trying to set up is just one network address. 192.163.123.0. Can both stores be on the same network address? Or do I need something like this: Store 1 - 192.163.123.xxx, Store 2 - 192.163.124.xxx.

Well thanks again for the help, I know it's alot of questions, I just hope someone can help me some =)

--Mike

2 REPLIES
New Member

Re: Frame Relay Issues, plus some misc. questions.

First: "no service config" will stop the errors.

2nd: I think you'll have a tough time with frame-relay back to back over 56K internal CSU/DSUs. The key is to enable "frame-relay switching" in global config on the router that is supplying clocking, and then "frame-relay intf-type dce" on the main serial interface (not the sub-if).

The problem is, I don't know if a WIC 56K CSU/DSU will accept that last command, but give it a shot.

3rd: You'll have to set up both stores on seperate IP addresses unless you plan on bridging rather than routing. I suggest stronly that you route.

The IP addresses for the sub-ifs can be "ip unnumbered ethernet0" to save IP space.

Mick.

New Member

Re: Frame Relay Issues, plus some misc. questions.

What he said and, Frame switching requires at least a plus level IOS.

96
Views
0
Helpful
2
Replies
CreatePlease to create content