Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Frame relay line won't come up

Here is my situation. I have a very simple set up between our corporate HQ and remote shops. A 2611XM at corporate and 1602 out in the field. I have 56k lines wit 16k PVCs at each site and a 768k line at corporate. I have a new site that I cannot get the circuit to come up. AT&T insists it is a CPE problem. I have replaced the router at the remote site 3 times already and changed out all the cables. I even had Bell South replace the dmarc/smart jack. I have no extended dmarc at the site. The 1602 router gives me a up/down on the serial port. I have verified lmi-type and DLCI with AT&T. Below are the configs from the 2 routers. Any help would be great...this one is killing me!

2611XM Corporate

service timestamps debug datetime show-timezone

service timestamps log datetime show-timezone

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname Natick

!

enable secret

enable password

!

ip subnet-zero

no ip source-route

!

!

!

call rsvp-sync

!

!

!

!

!

! !

!

interface FastEthernet0/0

ip address 10.10.2.1 255.255.255.0

speed 100

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 192 native

ip address 192.168.2.1 255.255.255.0

!

interface Serial0/0

bandwidth 768

no ip address

encapsulation frame-relay

service-module t1 timeslots 1-12

frame-relay lmi-type ansi

!

interface Serial0/0.73 point-to-point

description Frame-Relay PVC To Marietta, GA

ip address 10.10.73.254 255.255.255.0

frame-relay interface-dlci 490

!

interface FastEthernet0/1

no ip address

speed 100

full-duplex

!

interface FastEthernet0/1.1

encapsulation dot1Q 10

ip address 10.0.2.1 255.255.255.0

ip helper-address 192.168.2.25

!

interface Serial1/0

bandwidth 384

no ip address

encapsulation frame-relay

no fair-queue

service-module t1 timeslots 1-6

frame-relay lmi-type ansi

!

interface Serial1/0.1 point-to-point

description Frame-Relay PVC To Westchester Mirror

ip address 10.10.3.254 255.255.255.0

frame-relay interface-dlci 475

!

router eigrp 1

network 10.0.0.0

network 172.0.0.0

network 192.168.2.0

network 192.168.254.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

-----------------------------------------------------

1602 Remote

service timestamps debug datetime show-timezone

service timestamps log datetime show-timezone

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname Marietta

!

enable secret

enable password

!

ip subnet-zero

!

!

!

interface Ethernet0

description Marietta Ethernet Network

ip address 10.0.73.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation frame-relay

no fair-queue

service-module 56k clock source line

service-module 56k network-type dds

frame-relay lmi-type ansi

!

interface Serial0.1 point-to-point

description Frame Relay PVC to Natick

ip address 10.10.73.253 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 875

!

router eigrp 1

passive-interface Ethernet0

network 10.0.0.0

network 192.168.254.0

no ip classless

!

ip route 0.0.0.0 0.0.0.0 10.10.73.254

!

line con 0

session-timeout 25

exec-timeout 25 0

password

login

transport input none

flowcontrol hardware

line vty 0 4

session-timeout 25

exec-timeout 25 0

password

login

!

end

12 REPLIES
New Member

Re: Frame relay line won't come up

Just to add. AT&T can loop the smartjack, but not my CSU.

Cisco Employee

Re: Frame relay line won't come up

Hello,

What is the status on your HQ router ?

You should try your frame relay encap and frame-relay interfacedlci commands with the ietf keyword at the end.

If that does not do it, you might want to debug the lmi and check the lmi exchange between your remote router and the AT&T switch.

Regards

New Member

Re: Frame relay line won't come up

The status on the router at corporate is up/down

I will try the ietf keyword

Thanks!

Silver

Re: Frame relay line won't come up

The serivice provider will not be able to loop you without the command 'service-module T1 FDL both' configured .

Can you paste in a sh int serial x from both sides and a sh frame-relay pvc

Bronze

Re: Frame relay line won't come up

are you getting link on the local loops? (sho int) do see the pvcs? (sho fram pvc) Is there any LMI communication/ (sh fra lmi)

New Member

Re: Frame relay line won't come up

Below is a sho int s0/0 and for the sub interface s0/0.73 for the HQ router (2611)

Serial0/0 is up, line protocol is up

Hardware is PQUICC with Fractional T1 CSU/DSU

MTU 1500 bytes, BW 768 Kbit, DLY 20000 usec,

reliability 255/255, txload 53/255, rxload 28/255

Encapsulation FRAME-RELAY, loopback not set

Keepalive set (10 sec)

LMI enq sent 66664, LMI stat recvd 66663, LMI upd recvd 0, DTE LMI up

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE

Broadcast queue 0/64, broadcasts sent/dropped 8945250/230426, interface broadc

asts 8108277

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 1w0d

Input queue: 0/75/1/0 (size/max/drops/flushes); Total output drops: 6276

Queueing strategy: weighted fair

Output queue: 0/1000/64/6170 (size/max total/threshold/drops)

Conversations 0/101/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 576 kilobits/sec

5 minute input rate 87000 bits/sec, 65 packets/sec

5 minute output rate 161000 bits/sec, 66 packets/sec

46369878 packets input, 443908465 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

49358856 packets output, 831865153 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

2 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Serial0/0.73 is down, line protocol is down

Hardware is PQUICC with Fractional T1 CSU/DSU

Description: Frame-Relay PVC To Marietta, GA

Internet address is 10.10.73.254/24

MTU 1500 bytes, BW 768 Kbit, DLY 20000 usec,

reliability 255/255, txload 54/255, rxload 28/255

Encapsulation FRAME-RELAY

=======================================

This is the sh int s0 for the remote site router (1602)

Serial0 is up, line protocol is down

Hardware is QUICC Serial (with onboard CSU/DSU)

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 155/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY, loopback not set, keepalive set (10 sec)

LMI enq sent 6669, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 0 LMI type is ANSI Annex D frame relay DTE

Broadcast queue 0/64, broadcasts sent/dropped 7/0, interface broadcasts 6

Last input never, output 00:00:07, output hang never

Last clearing of "show interface" counters never

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 106 giants, 0 throttles

22163767 input errors, 4017951 CRC, 10090593 frame, 0 overrun, 0 ignored, 8

055223 abort

6676 packets output, 94043 bytes, 0 underruns

0 output errors, 0 collisions, 2215 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

New Member

Re: Frame relay line won't come up

Here is the sho frame pvc for the remote site router

PVC Statistics for interface Serial0 (Frame Relay DTE)

DLCI = 875, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial0.1

input pkts 0 output pkts 7 in bytes 0

out bytes 669 dropped pkts 0 in FECN pkts 0

in BECN pkts 0 out FECN pkts 0 out BECN pkts 0

in DE pkts 0 out DE pkts 0

out bcast pkts 7 out bcast bytes 669

pvc create time 18:32:38, last time pvc status changed 18:32:04

Silver

Re: Frame relay line won't come up

Why do you have these commands configured ?

service-module 56k clock source line

service-module 56k network-type dds

were they specified by the service provider ?

New Member

Re: Frame relay line won't come up

Yes, they were specified by the service provider. I inhereted all of this a short time ago and it's one of those things that was specified at one time before I came along and since all of our 55 or so sites are exactly the same type of connection, it has always been in there.

Silver

Re: Frame relay line won't come up

Ok

Is there an extended demarc ?

If there is you need to plug your router in to the demarc. If the circuit comes up up then you have a problem on the extended demarc. If it does not then make a loopback plug ,

http://www.juniper.net/techpubs/software/nog/nog-interfaces/html/fe-ge-loopback25.html

if you can not make a plug or have no one at the site then do this

then change the encap on your serial interface to hdlc and assing it an ip address(does not matter what the ip address is you are just using it for testing , this will allow you to see loops by the provider. Have the provider go to the closest DAX and give you a loop , your interface should go up up (looped),if it does not then there is a provider problem. If it does come up up (looped) and you can ping yourself have the provider move back one test point and do the same , keep repeating this test until you can not ping yourself , when this happens , this is where the problem lies .

New Member

Re: Frame relay line won't come up

Ok, cool I'll try that. Thanks!

BTW, there is no extended demarc

Bronze

Re: Frame relay line won't come up

assuming you have the 56k csu/dsu the command to allow loopback is "service-module 56k remote-loopback" but your problems look like they will prevent that from working anyway.

Have you verified the speed with the carrier? Try 64k or auto with the command "service-module 56k clock rate [64|auto]"

244
Views
0
Helpful
12
Replies