Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Frame-Relay load balancing question

On a remote site I have a serial connection & one Ethernet connection (256K - Cisco 1720 router) with point-to-point PVC's back to the corporate office.

I need to create two separate LANS & load balance the connections. My question is, can I upgrade the router to support two Ethernet connections & load balance the serial connection.

6 REPLIES
New Member

Re: Frame-Relay load balancing question

You mentioned "PVC's"...is there more than 1 ? How many ? Are they costed the same (i.e. a routing protocol would see them as equal cost paths to the corporate HQs) ?

If you need to support 2 LANs you may be able to just put a secodary IP on the single Ethernet. This will depend on your Layer 2 design (how many switches) and how many users (don't want to overload the LAN with broadcasts).

Michael J. Morris

me@michael-j-morris.com

CCIE #11733, MCSE

New Member

Re: Frame-Relay load balancing question

I have two PVC's back to the corporate office ( two different provider T's back at the corporate office, the second PVC at the remote office is not being used, only used if the first PVC goes down).

I have a political war going on at the remote office. Half of the office are corporate employees, half are non-employees. Each group complaining about bandwidth usage. I want to bump up the bandwidth and not have to go through the process of ordering a second circuit for that office.

I hope that answers your questions.

New Member

Re: Frame-Relay load balancing question

On the primary PVC....what is the CIR ? Is it a full T-1 PVC....i.e CIR = 1544k = T-1 ?

New Member

Re: Frame-Relay load balancing question

The CIR is 256, see remote & Frame router config below. I also have another idea. Can I upgrade the router so that I can support two Ethernet connections and have each ethernet port use different timeslots.

REMOTE CONFIG

interface Serial0

bandwidth 256

no ip address

no ip redirects

no ip unreachables

encapsulation frame-relay

priority-group 2

service-module t1 timeslots 1-4

frame-relay lmi-type ansi

FRAME ROUTER CONFIG

map-class frame-relay 256

frame-relay cir 256000

frame-relay bc 32000

frame-relay be 0

frame-relay mincir 256000

New Member

Re: Frame-Relay load balancing question

No, you don't have a mutli-channel controller in this router, so you wont be able to break up the channels.

You can have another PVC put in and then make routing changes to ensure employee traffic from the head-end goes over PVC1 and non-employee traffic from the head-end goes over PVC2. That can depend a lot on your routing protocol (EIGRP is good at this).

Another problem will be determining the source of the traffic when it comes in the Ethernet. Here you'll have to do policy routing. If traffic is from employees, policy-route on PVC1...if traffic is from non-employees, policy route on PVC2.

In actuality, I think the easist way is to apply some QoS...find out what traffic is most important and make that the priority. However, you have a 256k circuit...if your using almost all of that, you need a BW upgrade, not QoS.

Good luck.

New Member

Re: Frame-Relay load balancing question

Just an idea

Remote Router

int FastEthernet0

ip address 172.16.0.1 255.255.255.128

ip address 172.16.0.129 255.255.255.128 secondary

!

int Serial0

encapsulation frame-relay

...

!

interface s0.1 point-to-point

ip address 172.16.1.254 255.255.255.252

fram-relay interface-dlci 100

!

!

interface s0.1 point-to-point

ip address 172.16.1.2 255.255.255.252

fram-relay interface-dlci 200

!

access-list 1 permit ip 172.16.0.0 0.0.0.126

access-list 2 permit ip 172.16.0.128 0.0.0.126

Then

!

interface FastEthernet0

ip policy route-map employ-policy

!

route-map employ-policy permit 10

match ip address 1

set ip next-hop 172.16.1.253

!

route-map employ-policy permit 20

match ip address 2

set ip next-hop 172.16.1.1

!

110
Views
0
Helpful
6
Replies
CreatePlease to create content