Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Frame-Relay Performance

We recently changed from a Leased Line circuit between our two offices to Frame-Relay. The LL was 256k.

The new FR circuit is 256K Access Speed with a CIR of 256K.

With our LL circuit I was getting transfer rates of about 26-30Kbytes/s doing a normal ftp. Now I can't get a maximum of 16Kbps transfer rate.

I have included the configs. Both routers are 3640's with 12.1(5) IOS.

At the first end we have ......

!

interface Serial0/0

no ip address

encapsulation frame-relay

load-interval 30

no fair-queue

frame-relay traffic-shaping

frame-relay lmi-type q933a

frame-relay ip tcp header-compression

frame-relay ip rtp header-compression

ip rsvp bandwidth 1536 1536

ip rtp priority 16384 16383 48

!

interface Serial0/0.17 point-to-point

ip address 192.168.254.253 255.255.255.252

ip nat inside

no cdp enable

frame-relay class fr_cha_pir

frame-relay interface-dlci 17

frame-relay ip tcp header-compression

frame-relay ip rtp header-compression

ip rsvp bandwidth 24 24

!

!

map-class frame-relay fr_cha_pir

frame-relay adaptive-shaping becn

frame-relay cir 256000

frame-relay mincir 256000

frame-relay ip rtp priority 16384 16383 48

And at the other end....

!

interface Serial3/2

bandwidth 512

no ip address

encapsulation frame-relay

no fair-queue

frame-relay traffic-shaping

frame-relay lmi-type q933a

!

interface Serial3/2.17 point-to-point

ip address 192.168.254.254 255.255.255.252

ip nat inside

no cdp enable

frame-relay class fr_pir_cha

frame-relay interface-dlci 17

frame-relay ip tcp header-compression

frame-relay ip rtp header-compression

ip rsvp bandwidth 24 24

!

!

map-class frame-relay fr_pir_cha

frame-relay adaptive-shaping becn

frame-relay cir 256000

frame-relay mincir 256000

frame-relay ip rtp priority 16384 16383 48

I can't see where my config is wrong, any help would be appreciated.

Regards

Nik Mihelioudakis

1 REPLY
Silver

Re: Frame-Relay Performance

There is probably nothing wrong with your router configuration. The switch to frame relay bumped your typical round trip packet delay from a few milliseconds to a few 10s of ms. If you increase the window size used for your file transfer, you should see the full bandwidth available. You can confirm this with a protocol analyser, where you will see the data flow stop while the sender waits for an acknowledgement to arrive.

Good luck and have fun!

Vincent C Jones

www.networkingunlimited.com

79
Views
0
Helpful
1
Replies
CreatePlease to create content