cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
362
Views
0
Helpful
4
Replies

Frame-Relay question

gviera
Level 1
Level 1

Hi,

I got the following problem...

I got a Frame Relay link with a carrier from a nearby country for

terminating VoIP calls.

The configuration of my router is like the one I put below.

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname myRouter

!

enable secret 5 xxx

!

!

class-map voz

match ip precedence 5

!

!

policy-map voice128

class voz

priority 128

class class-default

fair-queue

!

ip subnet-zero

!

frame-relay switching

!

interface Ethernet0

ip address 192.168.1.4 255.255.255.0

!

interface Serial0

no ip address

encapsulation frame-relay

no ip mroute-cache

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0.2 point-to-point

ip address 10.20.1.1 255.255.255.252

no ip mroute-cache

frame-relay interface-dlci 112

class qos128

frame-relay ip rtp header-compression

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 172.16.0.0 255.255.0.0 10.20.1.2

no ip http server

!

!

map-class frame-relay qos128

frame-relay cir 128000

frame-relay bc 1280

frame-relay mincir 128000

no frame-relay adaptive-shaping

service-policy output voice128

frame-relay fragment 160

!

line con 0

transport input none

line vty 0 4

password xxx

login

!

end

now.. we have set up a new link with a nearby city which will not be in a

frame relay network, it's just a point to point link, between our office and

the node on the other city, which will be used for VoIP too.

At this moment the link is set up using ppp encapsulation, which is very

simple..

My boss wants to set up this link with Frame Relay using the same

configuration as above, arguing that it will improve quality, and that as

packets are encapsulated it's better,etc

So.. first of all... does it have sense to set up a frame relay for that

link, or a ppp encapsulation will be better, since the benefits of frame

relay apply only on a frame relay network and not in a simple link between 2

points??

second.. if it is better to set it up as frame relay.. then, what would be

the differences in the configuration of one router and the other.. obviously

the ip address in serial0.2 will be different for each one, both of the same

network. But what about dlci and stuff like that? Do I have to use the same

dlci on both sides?? The DTU's are dce, so the routers will have to be

dte... is this ok, or is any problem with that?

I searched for info about this at the Cisco website, but everything I found

was for frame relay networks, and couldn't find anything about setting up a

simple point to point link using frame relay..

Thanks in advance,

4 Replies 4

thisisshanky
Level 11
Level 11

There wont be any advantage using frame-relay encap on the leased line. Still if your Boss insists, on doing it, you can do that. Frame relay back to back configuration does work. What do you need is set encapsulation to frame-relay at each end, and set the same DLCI number on each end.

frame-relay interface-dlci 100 (say) on each end. You can use any value, since its a private network.

Also you should set no keepalive on each end.

You can refer to following link.

Again there is no advantage of doing so in a P-P link. PPP would run just fine.

http://www.cisco.com/en/US/tech/tk713/tk237/technologies_configuration_example09186a0080094a3b.shtml

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Thank you for your quick reply :)

I've just talked with the one from the other country who gave us that FR configuration, and I asked him why were we using that configuration, if it was for the priorization for VoIP packets and rtp compression..

he sayed that with ppp you can also do it, but that when he configured the link he read some docs, and it sayed that with the FR the router had less work to do, and that for some other reasons he did not remember well it was better..

yesterday I tried what you said, I put the same config on both routers, except for ip address, etc, and the same dlci..

the only difference is that I did not set the "no keepalive" and the clock, so I guess that it was because of this that it did not work, am I right?

I'll try to configure ot again..

if I have problems and can not get it to work, so I have to use ppp.. do you know of any link that shows how to do the rtp compression and VoIP packets priorizing with ppp?

thanks again

Here is a link to enable RTP header compression on ppp links

http://www.cisco.com/en/US/products/sw/iosswrel/ps1833/products_feature_guide09186a008009f525.html#19960

Here is another good link for QoS for VOIP packets on ppp leased lines.

http://www.cisco.com/en/US/tech/tk652/tk701/technologies_tech_note09186a0080094660.shtml

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

btews
Level 1
Level 1

Im not sure if using frame relay will give you much improvment but using HDLC should being that it is Cisco's proprietary protocol and uses less ovehead.