Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Frame-relay related question.... EIGRP

Thanks to all who read this forum- you people are truly the reason networks network!

Ok... long story short I have two 1700 series routers needing setup for 56k frame-relay. Got em both config'ed to see the frame-relay, but now having trouble actually routing. Here is my configuration up to this point:

======================================

Current configuration : 828 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxxxxxx

!

enable password *****

!

ip subnet-zero

!

!

!

!

interface FastEthernet0

ip address 192.168.x.x 255.255.255.0

speed auto

!

interface Serial0

bandwidth 1544

ip address 192.168.y.y 255.255.255.0

encapsulation frame-relay

service-module 56k clock source internal

frame-relay lmi-type ansi

!

interface Serial0.1 point-to-point

ip address 192.168.z.z 255.255.255.0

snapshot server 5

frame-relay interface-dlci xx

!

router eigrp 1

network 192.168.x.0

network 192.168.y.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip http server

!

!

!

line con 0

exec-timeout 5 0

line aux 0

line vty 0 4

no exec

exec-timeout 0 1

password xxxxx

login

transport input none

!

end

=================================

The remote router is set up basically the same with the exception of "snapshot client 5 60" and "clock source line". Also, the LMI comes up as Cisco, not ANSI... thought this might be important, or at least interesting.

I have the routers in place. I can ping both local interfaces (f0 and s0.1) from the local router, and s0.1 on the remote router, again from the local machine. Any idea why I cannot ping anything but local f0 from the local network? I'm thinking it has to do with my eigrp settings. Also, is the ip address for s0 necessary when s0.1 has it's own ip?

Incidentally, both local networks (on both sides of the frame-relay) are set up statically... I could probably set this up for dhcp if necessary, but I'm not sure if the 1700 supports it. I'm already deep enough in this I could grab a simple linksys router tho =) Thanks for any help you could give!

4 REPLIES

Re: Frame-relay related question.... EIGRP

1. remove physical ip 192.168.y.0 from serial interface (only sub interface ip 192.168.z.0 is required)

2. remove 192.168.y.0 network statement from eigrp

3. add 192.168.z.0 network statement under eigrp.

Hope that helps!

New Member

Re: Frame-relay related question.... EIGRP

Thanks hank!

Question at this point (you're answer makes complete sense now that you point it out ;): After enabling the proper network statements will I be able to ping the point-to-point interfaces from the LAN, or only the remote LAN ips? Basically, I'm looking for a way to prove via ping that the entire network is now accessible.... man I wish this had been a simple dsl installation with VPN =) Also, are the static IPs going to be a problem?

Re: Frame-relay related question.... EIGRP

The above change should not affect pinging of sub interface ip address from the lan. You will infact be able to ping the remote lan as well as serial ip addresses. The static IPs are not at all a problem

New Member

Re: Frame-relay related question.... EIGRP

Excellent! I really appreciate your help, Hank. In fact, I appreciate everybody's help... took me from writing code to programming a cisco router in less than a week... you guys rock!

122
Views
5
Helpful
4
Replies
CreatePlease to create content