Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Frame relay, ser0 up line proto up but can't ping its serial int

I have a T1 service terminated into Cisco 3640 using frame relay encapsulation.

Here is the output of the sh int ser0/0:

router#sh int ser 0/0

Serial0/0 is up, line protocol is up

Hardware is DSCC4 with integrated T1 CSU/DSU

MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF, loopback not set

Keepalive not set

LMI DLCI 1023 LMI type is CISCO frame relay DTE

FR SVC disabled, LAPF state down

Broadcast queue 0/64, broadcasts sent/dropped 53/0, interface broadcasts 0

Last input 00:00:00, output 00:00:55, output hang never

Last clearing of "show interface" counters 00:53:07

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1152 kilobits/sec

5 minute input rate 0 bits/sec, 2 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

6374 packets input, 331448 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

53 packets output, 16589 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

router#sh int ser 0/0.16

Serial0/0.16 is up, line protocol is up

Hardware is DSCC4 with integrated T1 CSU/DSU

Internet address is 192.168.70.14/30

MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF

Last clearing of "show interface" counters never

router#

Does anybody know why I couldn't ping my own serial interface 192.168.70.14 ?

THanks.

-bhw-

10 REPLIES
VIP Purple

Re: Frame relay, ser0 up line proto up but can't ping its serial

Hello,

on anything other than point-to-point (sub)interfaces, you have to map the IP address of the local interface to a local DLCI in order to be able to ping the local interface. In your case, add the following to the configuration of the subinterface (in this example I assume that you are using DLCI 17, it might in reality be a different number):

frame-relay map ip 192.168.70.14 17

HTH,

Georg

New Member

Re: Frame relay, ser0 up line proto up but can't ping its serial

Thanks George.

I added that command frame-relay map ip 192.168.70.14 16 but I still cannot ping to my own serial interface.

Regards,

-bhw-

Cisco Employee

Re: Frame relay, ser0 up line proto up but can't ping its serial

You should start by pinging the remote interface address. If you can't succeed with that first step you will not be able to ping the local interface address since the second is actually sending icmp packets to the remote router, which in turn sends them back.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Re: Frame relay, ser0 up line proto up but can't ping its serial

To ping your own interface you need to map your local IP to your dlci. If this mapping is not present, you will see in a debug packet that the result is encapsulation failure.

New Member

Re: Frame relay, ser0 up line proto up but can't ping its serial

If you can't ping across the link as well, it's possible the LEC's switch is falsly reporting the circuit as up. Or, it's possible there is a LMI mis-match between you, telco or your provider.

New Member

Re: Frame relay, ser0 up line proto up but can't ping its serial

The keepalive on the serial interface is not set. Please configure keepalive on the serial interface and then verify that the circuit is up/up. If it is then please ensure that the DLCIs are configured correctly. You should then be able to ping across the link

New Member

Re: Frame relay, ser0 up line proto up but can't ping its serial

The T1 ISP told me to disable LMI, use dlci 16, frame relay ietf, and use bridge encapsulation (BVI interface).

If I enable keepalive then my show interface serial0/0 becomes up line proto down. And if I use debug frame lmi, then i saw "yourseen 0, DTE down" --> i don't get a reply (lmi) from DCE (FR switch).

I order to disable the LMI I think I have to disable the keepalive otherwise the router will use LMI-type cisco as its default and try to query to the FR switch.

Is it correct or did I misconfigure the router?

Thanks.

-bhw-

New Member

Re: Frame relay, ser0 up line proto up but can't ping its serial

It might help to post the relatant portion of your vonfig, not just the show interface command.

Joe

New Member

Re: Frame relay, ser0 up line proto up but can't ping its serial

Thanks Joe.

I changed my configuration and I am no longer using serial0/0.16 point-to-point.

192.168.70.13 = ISP gateway

192.168.70.14 = my serial IP.

Here is my show run.

Building configuration...

!

Current configuration : 3827 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

bridge irb

!

interface Serial0/0

ip address 192.168.70.14 255.255.255.252

encapsulation frame-relay IETF

no keepalive

no fair-queue

service-module t1 timeslots 1-24

service-module t1 remote-alarm-enable

frame-relay map ip 192.168.70.13 16 IETF

frame-relay map ip 192.168.70.14 16 IETF

frame-relay interface-dlci 16

no frame-relay inverse-arp NOVELL 16

no frame-relay inverse-arp APPLETALK 16

no frame-relay inverse-arp DECNET 16

frame-relay local-dlci 16

bridge-group 1

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

ip route 0.0.0.0 0.0.0.0 192.168.70.13

!

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

line aux 0

line vty 0 3

login

line vty 4

login

!

!

!

end

If I put "no keepalive" command then my serial 0/0 is up, line protocol is up.

But if I put "keepalive" command then it says serial 0/0 is up, line protocol is down.

Thanks.

-bhw-

New Member

Re: Frame relay, ser0 up line proto up but can't ping its serial

If with keepalives, the line is up/ down...this means its either the CSU/ DSU channel group assignment problem, encapsulation problem (layer 2) or some PTT issue. But the keepalive has to be there all the time.

433
Views
0
Helpful
10
Replies