Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

frame relay with ISDN backup only ISDN doesn't work

Hi,

Currently I am working on project for school. In this project I have create a frame relay network with ISDN as backup with a 1700 (server) and a 2500 (client) router. I have frame relay up and running but the ISDN doesn't work.

If I disconnect the frame relay the ISDN kicks in. The routers say that they are connected to each other but there is no data transfer what so ever over ISDN. And pinging doesn't work. This is also my first time I worked with a Cisco router. So I would really apriciate any help from someone. I'll post the configs of the routers.

Server (1700):

Building configuration...

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname kleinerouter

!

!

username groterouter password 0 isdn

!

!

!

!

memory-size iomem 25

ip subnet-zero

!

isdn switch-type basic-ni

!

interface 172.19.0.0 255..255.255.0

!

!

interface Serial0

backup delay 10 30

backup interface Dialer1

no ip address

encapsulation frame-relay

no keepalive

shutdown

no fair-queue

!

interface Serial0.100 point-to-point

ip address 192.0.0.6 255.255.255.0

frame-relay interface-dlci 100

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 10

no ip route-cache

load-interval 30

no keepalive

shutdown

isdn switch-type basic-ni

ppp authentication chap

!

interface FastEthernet0

ip address 124.0.0.6 255.255.255.252

shutdown

speed auto

!

interface Dialer1

ip address 142.0.0.6 255.255.0.0

encapsulation ppp

dialer remote-name groterouter

dialer pool 10

dialer idle-timeout 900

dialer string 3099596

dialer max-call 4096

dialer-group 1

ppp authentication chap

!

router ospf 10

log-adjacency-changes

network 172.19.0.0 0.0.0.255 area 0

network 124.0.0.0 0.0.0.255 area 0

network 142.0.0.0 0.0.0.255 area 0

network 192.0.0.0 0.0.0.255 area 0

!

router rip

network 124.0.0.0

network 142.0.0.0

network 192.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 124.0.0.1

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 0 0

privilege level 15

transport input none

line aux 0

transport input all

line vty 0 4

exec-timeout 0 0

login

!

end

Client (2500):

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname groterouter

!

!

username kleinerouter password 0 isdn

!

!

ip subnet-zero

!

isdn switch-type basic-ni

!

!

process-max-time 200

!

interface Loopback0

ip address 10.8.8.1 255.255.255.0

!

interface Ethernet0

ip address 110.0.0.5 255.255.255.252

no ip directed-broadcast

shutdown

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation frame-relay

no ip mroute-cache

no keepalive

shutdown

no fair-queue

clockrate 148000

cdp enable

!

interface Serial0.100 point-to-point

ip address 192.0.0.5 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 100

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool 20

shutdown

dialer-group 1

isdn switch-type basic-ni

ppp authentication chap

!

interface Dialer1

ip address 142.0.0.5 255.255.0.0

no ip directed-broadcast

encapsulation ppp

dialer remote-name kleinerouter

dialer pool 20

dialer idle-timeout 900

dialer max-call 4096

dialer-group 1

ppp authentication chap

!

router ospf 10

network 10.8.8.0 0.0.0.255 area 0

network 110.0.0.0 0.0.0.255 area 0

network 142.0.0.0 0.0.0.255 area 0

network 192.0.0.0 0.0.0.255 area 0

!

router rip

network 110.0.0.0

network 142.0.0.0

network 192.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.200.17.1

no ip http server

!

dialer-list 1 protocol ip permit

!

!

line con 0

exec-timeout 0 0

transport input none

line aux 0

line vty 0 4

login

!

end

4 REPLIES
Cisco Employee

Re: frame relay with ISDN backup only ISDN doesn't work

On a client 2500 router named "groterouter" have a config mistake.

1)Bri0 interface is in shutdown mode..which may not be a issue as you might be testing it.

2)Bri0 should have "dialer pool-member 20" command instead of "dialer pool 20".

3)ISDN SPIDs are not configured on any router.

pl. correct that.

Here is the url which has "isdn backup using dialer profiles" explained in detail with sample config and troubleshooting.

http://www.cisco.com/warp/public/129/bri-back-dp.html

So if it still dosen't work, we need following debug on server router kleinerouter when isdn line receives the call.

debug dialer

debug ppp nego

debug ppp auth

debug isdn q931

Community Member

Re: frame relay with ISDN backup only ISDN doesn't work

Thx it is working now. But now the problem is that when ISDN backup is up it should disconect if it is idle or there is no datatransfer but now it stays connected.

Configs:

server (1700):

Building configuration...

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname kleinerouter

!

!

username groterouter password 0 isdn

!

!

!

!

memory-size iomem 25

ip subnet-zero

!

isdn switch-type basic-ni

!

interface 172.19.0.0 255..255.255.0

!

!

interface Serial0

backup delay 10 30

backup interface Dialer1

no ip address

encapsulation frame-relay

no keepalive

no fair-queue

!

interface Serial0.100 point-to-point

ip address 192.0.0.6 255.255.255.0

frame-relay interface-dlci 100

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 10

no ip route-cache

load-interval 30

no keepalive

isdn switch-type basic-ni

ppp authentication chap

!

interface FastEthernet0

ip address 124.0.0.6 255.255.255.252

speed auto

!

interface Dialer1

ip address 142.0.0.6 255.255.0.0

encapsulation ppp

dialer remote-name groterouter

dialer pool 10

dialer idle-timeout 900

dialer string 3099596

dialer max-call 4096

dialer-group 1

ppp authentication chap

!

router ospf 10

log-adjacency-changes

network 172.19.0.0 0.0.0.255 area 0

network 124.0.0.0 0.0.0.255 area 0

network 142.0.0.0 0.0.0.255 area 0

network 192.0.0.0 0.0.0.255 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 124.0.0.1

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

exec-timeout 0 0

privilege level 15

transport input none

line aux 0

transport input all

line vty 0 4

exec-timeout 0 0

login

!

end

Client (2500):

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname groterouter

!

!

username kleinerouter password 0 isdn

!

!

ip subnet-zero

!

isdn switch-type basic-ni

!

!

process-max-time 200

!

interface Loopback0

ip address 10.8.8.1 255.255.255.0

!

interface Ethernet0

ip address 110.0.0.5 255.255.255.252

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation frame-relay

no ip mroute-cache

no keepalive

no fair-queue

clockrate 148000

cdp enable

!

interface Serial0.100 point-to-point

ip address 192.0.0.5 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 100

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 20

dialer-group 1

isdn switch-type basic-ni

ppp authentication chap

!

interface Dialer1

ip address 142.0.0.5 255.255.0.0

no ip directed-broadcast

encapsulation ppp

dialer remote-name kleinerouter

dialer pool 20

dialer idle-timeout 900

dialer max-call 4096

dialer-group 1

ppp authentication chap

!

router ospf 10

network 10.8.8.0 0.0.0.255 area 0

network 110.0.0.0 0.0.0.255 area 0

network 142.0.0.0 0.0.0.255 area 0

network 192.0.0.0 0.0.0.255 area 0

default-information originate

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.200.17.1

no ip http server

!

dialer-list 1 protocol ip permit

!

!

line con 0

exec-timeout 0 0

transport input none

line aux 0

line vty 0 4

login

!

end

Bronze

Re: frame relay with ISDN backup only ISDN doesn't work

You are running OSPF on the ISDN line. That will produce a hello packet every 10 seconds, and your idle timeout is 900 seconds. Your dialer list permits all IP packets, including OSPF, so the line stays up.

Mark

Cisco Employee

Re: frame relay with ISDN backup only ISDN doesn't work

Since you have "backup delay 10 30" configured, the backup isdn line should be disconnected (dialer 1 interface) after 30 secs once the primary line come up. So you need to wait till 30 secs to have dialer 1 interface go back to standby mode. Pl. verify that how loag the dialer interface stay connected after primary line comes up.

94
Views
0
Helpful
4
Replies
CreatePlease to create content