Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

FTP is issue

Hi,

We have ftp server were client can upload and download logs if they are having issue.But the biggest problem is due to that our T1 get max out and people are experiencing problem with our internet and this also effects our HTTP server from outside.have tried QOS on eternal router by

queue-list 1 protocol ip 1 tcp www

queue-list 1 protocol ip 2 udp domain

queue-list 1 default 3

queue-list 1 queue 1 byte-count 7500

queue-list 1 queue 2 byte-count 500

queue-list 1 queue 3 byte-count 2000

and applied to the serial interface

custom-queue-list 1

But the issue is still there what is the best way to do and how ?

Thanks and Regards

Bhavin

2 REPLIES

Re: FTP is issue

Can you tell where this custom-queue is configured? To me it should be located on the serial side of the router which is connected to your servers on the LAN side.

Also probably your MTU on this WAN link is about 1500 bytes and you'd better write your byte-count numbers as multiples of 1500 (because you say 2000 and after the first 1500 byte packet is removed from the queue there's a capacity for 500 bytes and if the second packet in the queue is greater than 500 bytes - say 1500 interface doesn't fragment this packet, eventually you reserve 3000 bytes capacity for this queue.)

Another more easily configured and controllable QoS solution will be CBWFQ but ALL these are solutions supposing that you experience congestion during short periods of times. If thw WAN link is constntly congested I think you've nothing to do other than increasing the bandwidth.

Regards.

VIP Purple

Re: FTP is issue

Hello Bhavin,

I would use class-based weighted fair queueing and prioritze all other traffic over the FTP traffic, the configuration would look like this:

Router#conf t

Router(config)#class-map match-all ANYTRAFFIC

Router(config-cmap)#match access-group 101

Router(config-cmap)#exit

Router(config)#class-map match-all FTP

Router(config-cmap)#match access-group 102

Router(config-cmap)#exit

Router(config)#access-list 101 deny tcp any any eq ftp

Router(config)#access-list 101 deny tcp any any eq ftp-data

Router(config)#access-list 101 permit ip any any

Router(config)#access-list 102 permit tcp any any eq ftp

Router(config)#access-list 102 permit tcp any any eq ftp-data

Router(config)#access-list 102 deny ip any any

Router(config)#policy-map PRIORITY

Router(config-pmap)#class ANYTRAFFIC

Router(config-pmap-c)#set precedence 5

Router(config-pmap-c)#exit

Router(config-pmap)#class FTP

Router(config-pmap-c)#set precedence 4

Router(config-pmap-c)#end

Router#conf t

Router(config)#interface FastEthernet0

Router(config-if)#service-policy output PRIORITY

I am assuming that your interface is a FastEthernet, if it is another one it doesn´t matter, just apply the service policy to the interface that your hosts connect to.

With this configuration, all other traffic is prioritized over FTP traffic.

Use the command:

show policy-map interface FastEthernet0

to check that FTP packets get another (lower) priority than all other traffic.

Let me know if that is not 100% clear...:)

Regards,

Georg

187
Views
0
Helpful
2
Replies