Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Giant frames on 6500 ios

Hi

Since we installed the new network we have on our 6500 Giant Frames on the Trunkports(dot1q)and rapid spanning tree to the access-switches. All Accessswitches are running without problems and errors. Also on the Etherchannel between the 2 6500 i have Giant frames. Has anyone an idea? I tried to set the MTU size on the Etherchannel (2 tengigabit) to 9216

on the accesswitches i have MTU 1500

Here is a sh int from a gig port

GigabitEthernet2/7 is up, line protocol is up (connected)

Hardware is C6k 1000Mb 802.3, address is 0015.6251.70de (bia 0015.6251.70de)

Description: to lwnsw150102

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Full-duplex, 1000Mb/s, media type is LH

input flow-control is off, output flow-control is off

Clock mode is auto

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:27, output 00:00:04, output hang never

Last clearing of "show interface" counters 1d20h

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 88000 bits/sec, 26 packets/sec

5 minute output rate 347000 bits/sec, 71 packets/sec

8775949 packets input, 3527532905 bytes, 0 no buffer

Received 22299 broadcasts, 0 runts, 1188766 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

14590096 packets output, 10194273662 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Bernhard

8 REPLIES

Re: Giant frames on 6500 ios

Hi Bernhard,

giants are frames that are discarded because they are larger than 1518 Bytes. You interface has a mtu of 1500 Byte so 1518 is the max ethernet frame it will handle.

Do you have a "mtu 9216" also on this interface? That should fix it.

The second question would be where the giants are caused. Without interface config this is hard to tell.

Martin

New Member

Re: Giant frames on 6500 ios

Hi Martin

This is the Config of the Portchannel of the Tengig interfaces

interface Port-channel1

mtu 9216

bandwidth 10000000

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface TenGigabitEthernet1/1

mtu 9216

bandwidth 10000000

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

!

interface TenGigabitEthernet1/2

mtu 9216

bandwidth 10000000

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

And on the Accessswitches i have this configs

interface GigabitEthernet2/4

description to xxx

no ip address

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

Should i configure mtu 9216 or mtu 1518 on the gigabit trunk interfaces to the accessswitches?

Bernhard

VIP Purple

Re: Giant frames on 6500 ios

Hello Bernhard,

I think your giants are caused by 802.1Q frames, which use an additional 4 bytes, making the total 1522 bytes. These are called baby-giant frames. I would think setting the MTU to 1504 (which then would total 1522) should be sufficient...

HTH,

GP

New Member

Re: Giant frames on 6500 ios

Hello GP

Should I set the MTU 1504 on the access or the coreswitch Interfaces?

Bernhard

VIP Purple

Re: Giant frames on 6500 ios

Hello Bernhard,

you need to set the MTU to 1504 on all trunking ports on both the access and the core switches, that is, all ports configured with 802.1Q.

Regards,

GP

Cisco Employee

Re: Giant frames on 6500 ios

What kind of module is this and what version of IOS are you running? Also, take a look at the following cosmetic bug if it is a 6724 or 6748 card.

http://www.cisco.com/cgi-bin/bugtool/onebug.pl?bugid=CSCef87392

New Member

Re: Giant frames on 6500 ios

Its the WS-X6748-SFP module and i run the IOS Version 12.2(17d)SXB9 on the switches. Would u recommend us to update the IOS to a newer version, and what version u would choose?

Cisco Employee

Re: Giant frames on 6500 ios

This bug was fixed in 12.2(17d)SXB11. So I would stick with this unless you need features of newer releases. Do read the release notes for known issues before you decide on which release you want to upgrade to

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/122sx/ol_4164.htm

962
Views
0
Helpful
8
Replies
CreatePlease login to create content