Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

GRE/EIGRP working/not working

I have a customer with 3 locations, 3661 routers (12.2.xT IOS), HSSI interfaces toward a carrier IP backbone with 3 Mbps ports. My customer has also a Frame Relay T1 PVC for back up.

I configured GRE tunnels and EIGRP between all the locations. The GRE tunnels were created between loopback interfaces in each router. GRE tunnels are UP, EIGRP updates, everything looks OK.

Sometimes strange things happen with one or all the tunnels. After 2/3 weeks, or few days, or same day, the GRE tunnels show Up, but no EIGRP updates. I am trying to ping the GRE interface at the other end and it is not successful. I am trying to ping the serial over the carrier IP backbone and it goes fine, very good reply time as usual. (60 ms). After a shut down for the tunnel interface and a no shut the GRE tunnels start to pass traffic again. The carrier or my customer did not do any changes.

The MTU on the HSSI is 1400 and I adjusted the Delay/BW on the HSSI also so the EIGRP route over the GRE tunnel to be preferred against the Frame Relay T1 path. What's wrong?

4 REPLIES

Re: GRE/EIGRP working/not working

Try to set the GRE tunnel interface MTU to less than 1400 (1376).

When it fails, do you have a route to the other loopback?

Also try:

debug ip eigrp

debug ip eigrp packet

debug ip eigrp neighbor

Let us know.

Steve

New Member

Re: GRE/EIGRP working/not working

Steve,

Thanks for your reply.

I will try the lower MTU. Yes I still know how to reach the other loopback interface. I have a static route at each end (next hop the carrier serial interface IP add) to help find the other end of the tunnel.

I just found this bug on the GRE bug list: CSCdr39666

My customer has 12.2.7(a) which is having the problem.

Do you think that this coud be the reason?

Gabi

Re: GRE/EIGRP working/not working

Sorry, I couldn't find that bug. But there are lots of GRE bugs out there. What were the details of that bug?

Steve

New Member

Re: GRE/EIGRP working/not working

Steve,

CSCdr39666

Bug Details gre tunnel shows protocol up when it is not

Product all Severity 3 First Found-in Version 12.0(7)T, 12.1(1.1) A

closed

Thanks,

Gabi

229
Views
4
Helpful
4
Replies