Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

GRE Tunnel need event when DOWN

We use GRE tunnels to transport frame relay traffic between two Lucent frame relay switches. Tunnel traffic is routed over the public Internet. Looking for a method to let the router create an event when the tunnel isn't complete. For example, when one tunnel destination becomes unavailable, no events are generated into the log.

I also am searching for some tool that would monitor for packet loss between the tunnel destination IP's and possbly put the tunnel out of service until the packet loss returns to normal.

Below is an example of our configuration:

=Router 1=

interface Tunnel0

description TUNNEL to Router 2

ip address 10.0.0.1 255.255.255.0

tunnel source Serial2/0

tunnel destination 200.x.x.125

interface Serial2/0

description IP Tunnel to Router 2

bandwidth 4096

ip address 216.x.x.221 255.255.255.252

encapsulation frame-relay IETF

serial restart_delay 0

frame-relay lmi-type q933a

frame-relay intf-type dce

frame-relay route 900 interface Tunnel0 900

=Router 2=

interface Tunnel0

description TUNNEL to Router 1

ip address 10.0.0.2 255.255.255.0

tunnel source Serial1/0

tunnel destination 216.x.x.221

interface Serial1/0

description IP Tunnel to Router 1

bandwidth 4096

ip address 200.x.x.125 255.255.255.252

encapsulation frame-relay IETF

serial restart_delay 0

frame-relay lmi-type q933a

frame-relay intf-type dce

frame-relay route 900 interface Tunnel0 900

Thanks, for any suggestions

1 REPLY
Bronze

Re: GRE Tunnel need event when DOWN

The GRE Keepalive feature will take a GRE interface down if the tunnel goes down: http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087cec.html

The second thing that you asked about sounds like something a homemade script would have to solve. I'm not aware of any native functionality that would let you do something like this on a Cisco device. SAA may be able to help but I don't know if it can automatically shut down an interface in response to packet loss. See http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087b0a.html

99
Views
0
Helpful
1
Replies