Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

GRE Tunnel question

During GRE configuration a tunnel source and destination must be configured. Questions…

1. Are the tunnel source and destination used in the new IP GRE header?

2. If so would the routers require routes for the GRE endpoint destination addresses?

3. Can multiple tunnels be configured with the same tunnel source?

Here is my example config.

Router_A_OSPF>show run

interface Tunnel1

ip address 1.1.1.2 255.255.255.252

tunnel source VLAN 4

tunnel destination 3.3.1.1

interface Tunnel2

ip address 1.1.1.5 255.255.255.252

tunnel source VLAN 4

tunnel destination 2.2.1.1

interface Tunnel1

ip address 1.1.1.21 255.255.255.252

tunnel source VLAN 4

tunnel destination 5.5.1.1

interface VLAN 4

ip address 4.4.1.1 255.255.255.0

no ip directed-broadcast

ip route 3.3.1.1 255.255.255.255 4.4.1.2

ip route 2.2.1.1 255.255.255.255 4.4.1.2

ip route 5.5.1.1 255.255.255.255 4.4.1.2

router ospf 1

network 0.0.0.0 255.255.255.255 area 1.1.1.2

Router_Tunnel1>show run

interface Tunnel1

ip address 1.1.1.1 255.255.255.252

tunnel source VLAN 3

tunnel destination 4.4.1.1

Interface VLAN 3

ip address 3.3.1.1 255.255.255.0

no ip directed-broadcast

ip route 4.4.1.1 255.255.255.255 3.3.1.2

router ospf 1

network 0.0.0.0 255.255.255.255 area 2.2.2.2

Router_Tunnel12>show run

interface Tunnel2

ip address 1.1.1.5 255.255.255.252

tunnel source VLAN 2

tunnel destination 4.4.1.1

Interface VLAN 2

ip address 2.2.1.1 255.255.255.0

no ip directed-broadcast

ip route 4.4.1.1 255.255.255.255 2.2.1.2

router ospf 1

network 0.0.0.0 255.255.255.255 area 2.2.2.2

This is not configured or hasn’t been tested. Thoughts?

TIA,

Ryan

2 REPLIES
Purple

Re: GRE Tunnel question

Hi Ryan,

Answers to your questions:

1. Yes. The packet will have a new IP header with the tunnel source and destination as the source and destination IPs.

2. Yes. You need a route to get to the tunnel destination and a route back from it too.

3. Yes.

Your config should work okay.

Hope that helps - pls rate posts that help.

Regards,

Paresh

Re: GRE Tunnel question

1. Are the tunnel source and destination used in the new IP GRE header?

These adresses are used to transport the data over an IP cloud. GRE has no concept of ports, so you cannot use NAT in the path between source and dest.

2. If so would the routers require routes for the GRE endpoint destination addresses?

All routers in the path need to have a route to both tunnel endpoints, either explicit or as a default route.

3. Can multiple tunnels be configured with the same tunnel source?

Yes this is possible. You cannot configure two tunnels with the same source and destination. This will cause recursive routing.

Regards,

Leo

997
Views
8
Helpful
2
Replies