Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Hardware resources for distributed QoS

Hi there,

We have been implementing distributed QOS in a 7507 with RSP4 and 128 MB of RAM. The VIPs are VIP2-40 with 32 MB of RAM.

The QOS has been implemented in subinterfaces of a HSSI. Encapsulation is frame relay and the CIR is 64Kb.

We have observed that putting even just one of the subinterfaces under heavy load, routing updates send throught it are lost and thus communication. Further investigation showed that VIP's CPU usage was 100% since heavy load started with QOS on place but was negligible without it.

Has anyone had problems like this? Does anyone have an idea of suggested HW requirements for distributed QOS?

Thank you very much in advance.

Pablo Izquierdo

2 REPLIES
Cisco Employee

Re: Hardware resources for distributed QoS

Pablo,

Are you doing Distributed FRTS ? What type of queueing are you doing - CBWFQ ?

Take a look at this link to be sure you are doing Distributed FRTS:

http://www.cisco.com/warp/public/105/distribfrts.html

Can you post your policy-map and hssi interface and subinteface portion of your config. Also, a 'show ip route sum' and a 'show policy-map interface' for the hssi subinterface would be helpful.

The vip2-40 is the minimum suggested vip to run if you are doing Distributed QoS. And, 32 meg on the VIP may not be enough memory to download the entire CEF table and do Distributed QoS efficiently.

thanks,

Patrick

New Member

Re: Hardware resources for distributed QoS

Hi Patrick,

Here is an extract of the configuration regarding QoS.

ip cef distributed

!

class-map match-any intranet

match access-group 150

match access-group 160

class-map match-any transac

match access-group 120

match access-group 140

!

policy-map cbwfq

class transac

priority percent 82

class intranet

bandwidth percent 6

policy-map oficinas

class class-default

shape average 64000 64000 0

service-policy cbwfq

!

interface Hssi0/1/0

no ip address

encapsulation frame-relay IETF

no ip mroute-cache

carrier-delay 20

serial restart_delay 0

frame-relay lmi-type q933a

interface Hssi0/1/0.777 point-to-point

ip address X.X.X.X 255.255.255.248

ip access-group 101 in

ip access-group 110 out

ip accounting access-violations

no ip mroute-cache

service-policy output oficinas

frame-relay interface-dlci 777

Here is also the output of the commands you asked for

* show ip route sum

IP routing table name is Default-IP-Routing-Table(0)

Route Source Networks Subnets Overhead Memory (bytes)

connected 3 155 15592 36012

static 184 12 33400 28224

ospf 109 6 335 21888 49104

Intra-area: 2 Inter-area: 0 External-1: 0 External-2: 339

NSSA External-1: 0 NSSA External-2: 0

rip 1 297 31584 42912

internal 70 81480

Total 264 799 102464 237732

* show policy-map interface hssi 0/1/0.777

Hssi0/1/0.777

Service-policy output: oficinas

queue stats for all priority classes:

queue size 0, queue limit 13

packets output 4904, packet drops 0

tail/random drops 0, no buffer drops 0, other drops 0

Class-map: class-default (match-any)

35014 packets, 3425360 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

queue size 0, queue limit 1

packets output 37498, packet drops 10

tail/random drops 10, no buffer drops 0, other drops 0

Shape: cir 64000, Bc 64000, Be 0

lower bound cir 0, adapt to fecn 0

output bytes 3915710, shape rate 0 bps

Service-policy : cbwfq

Class-map: transac (match-any)

4904 packets, 306880 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 120

224 packets, 51736 bytes

5 minute rate 0 bps

Match: access-group 140

4680 packets, 255144 bytes

5 minute rate 0 bps

Priority: 82% (52 kbps), burst bytes 4470, b/w exceed drops: 0

Class-map: intranet (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 150

0 packets, 0 bytes

5 minute rate 0 bps

Match: access-group 160

0 packets, 0 bytes

5 minute rate 0 bps

queue size 0, queue limit 2

packets output 0, packet drops 0

tail/random drops 0, no buffer drops 0, other drops 0

Bandwidth: 6%, kbps 3

Class-map: class-default (match-any)

30110 packets, 3118480 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

queue size 0, queue limit 2

packets output 32594, packet drops 10

tail/random drops 10, no buffer drops 0, other drops 0

I have asked some other people, and with a flow of 8 Mbps of voice packets, a VIP4-80's CPU rises to 100% utilization, but that flow is much bigger that our 64 kbps.

Do you think this is a HW issue or a SW, bug related, issue

Best regards and thank you very much.

Pablo

95
Views
0
Helpful
2
Replies
CreatePlease to create content