Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Silver

Hayes Modem and AUX port

I am trying to connect a Hayes modem to the 3600 AUX port and make it accept incoming calls which I want to use for router management. But for some reason its not working, when I dialin I can reach the modem, but donot get the router exec access. Here's my configuration. Please let me know if there's anything I am missing.

modemcap entry MyHayes:MSC=&FS0=1&Q9&C1&D3&K3

line aux 0

exec-timeout 0 0

password cisco

login

modem InOut

modem autoconfigure type MyHayes

transport input all

speed 115200

stopbits 1

flowcontrol hardware

This is what I get when I dialin:-

ATDT91XXXXXXXXXX

CONNECT 26400/ARQ/V34/LAPM/V42BIS

I tried different speeds, no stopbits, nothing seems to work. I tried two modems both Hayes Accura model 4703US, both doesn't work. Any help greatly appreciated.

Thanks,

Partha !

3 REPLIES
Silver

Re: Hayes Modem and AUX port

Can you reverse telnet into the modem off the aux port? Ensure the cable is a rollover cable.

telnet <2000+line number>

telnet 1.1.1.1 2129 (example) & type AT, this should return an OK.

where x.x.x.x is the ip address of any UP interface on the router & show line will indicate the line # of the aux port.

Remain in the modem thru the reverse telnet & now dialing into this modem (on the aux port)...after connecting should be able to type any characters that will show up on the other end.

Also try "modem autoconfigure discovery" under line aux 0.

http://www.cisco.com/warp/public/471/mod-aux-exec.html

Thanks, Mak.

Silver

Re: Hayes Modem and AUX port

Thanks for your response!

I can reverse telnet into the modem, but cannot play any AT commands. The modem doesnot respond to any AT commands at all.

Also, I did try "modem autoconfigure discovery" but with that configuration I am not able to even get into the modem when I dial the modem number. I then configured the "modemcap entry Myhayes:MSC=&FS0=1&Q9&C1&D3&K3 " and used it to configure the modem, and then I am atleast able to dial-in into the modem, but not getting the router exec prompt.

Silver

Re: Hayes Modem and AUX port

After reverse telnetting into the modem, type ATE1Q0 (or AT&F), this should return an OK.

OR connect the modem to a PC comm port (use the same cable) & on PC using hyperterm enter the string.

Once the modem response try the previous test suggested.

Under the line just keep the following, modem inout / transport in all.

Thanks, Mak.

378
Views
0
Helpful
3
Replies
CreatePlease login to create content