Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
dan
Community Member

Help! GRE tunnel between two routers

Using GRE tunnel between two routers. I have CPE on the

Serial Interface of each router. Routers are connected

to the public Internet by FastEthernet0. Serial and FE0

both have public IP addresses. Using the config below,

the tunnels work perfectly.

However, now I am faced with a problem of doing this

config again, except on one router all I am going to

receive is ONE public IP address.

Question: Is there any way to accomplish the tunneling

between the routers, when one end only has 1 public IP?

Working Config

--------------

==Router 1:==

interface Tunnel0

ip address 10.0.0.2 255.255.255.0

tunnel source Serial0/0

tunnel destination 216.xxx.161.225

!

interface FastEthernet0/0

ip address 216.xxx.140.29 255.255.255.192

ip directed-broadcast

speed auto

half-duplex

!

interface Serial0/0

ip address 209.xxx.xxx.238 255.255.255.252

encapsulation frame-relay IETF

no fair-queue

frame-relay lmi-type q933a

frame-relay intf-type dce

frame-relay route 900 interface Tunnel0 900

!

ip route 216.xxx.161.225 255.255.255.255 216.xxx.140.15

==Router2:==

interface Tunnel0

ip address 10.0.0.1 255.255.255.0

tunnel source Serial1/0

tunnel destination 209.xxx.xxx.238

!

interface FastEthernet0/0

description Local ethernet

ip address 216.xxx.140.15 255.255.255.192

no ip route-cache

no ip mroute-cache

no keepalive

duplex half

!

interface Serial1/0

ip address 216.xxx.161.225 255.255.255.252

encapsulation frame-relay IETF

serial restart_delay 0

frame-relay lmi-type q933a

frame-relay intf-type dce

frame-relay route 900 interface Tunnel0 900

!

ip route 209.xxx.153.238 255.255.255.255 216.xxx.140.29

1 REPLY

Re: Help! GRE tunnel between two routers

All you need on either side is one public adress to terminate the tunnel.

With these two IPs, your tunnel-traffic will be routed over the Internet.

Remember that the tunnel's payload is not processed by any router on the path between the tunnel endpoints. So, there should be no need to use another public adress on the routers LAN-interfaces.

209
Views
0
Helpful
1
Replies
CreatePlease to create content