Cisco Support Community
Community Member

Help me configure NAT on a Cisco1601 Router

I have a 1601 router that we want to use to connect our cyber cafe.

We use private IPs on the hosts in the cafe- to range.

What I want is a simple step-by-step configuration that when entered into the router would have it up and runnning.

I only have two public IP addresses for use on the router.

Help me soon as possible.

Yours sincerely,


Cisco Employee

Re: Help me configure NAT on a Cisco1601 Router

1/ define a nat pool

ip nat pool MYPOOL x.x.x.x1 x.x.x.x2

2/ define nat translation

ip nat inside source list pool MYPOOL overload


ip nat inside source list interface serial 0 overload

3/ define nat interfaces

interface ethernet 0

ip nat inside

interface serial 0

ip nat outside

4/ check translation with

'sh ip nat trans'

Some sample config available at:

Community Member

Re: Help me configure NAT on a Cisco1601 Router

Hello Mr Dufuor,

I have seen the respnse, and thank you for it. But could you please just send me a sample configration? I would be most grateful if you would help me as soon as in desperate need of help. Here is the the current configuration of the router:

no service password-encryption

no service udp-small-servers

no service tcp-small-servers


hostname ispAfricelcus


enable secret 5 $1$T.Mi$N3nwU5fNZzeahHFdoaEc51


ip subnet-zero

ip domain-name

ip name-server

ip name-server


interface Ethernet0

description To Africel Hub

ip address

no ip directed-broadcast

media-type 10BaseT

no cdp enable


interface Serial0

description To Serekunda Router

ip address

no ip directed-broadcast

bandwidth 64


ip route

ip classless

access-list 12 permit

snmp-server community INTggMB RW 12

snmp-server community public RO 12

snmp-server host INTggMB config snmp


line con 0

line vty 0 4

access-class 12 in

login local



Please help me as soon as possible Mr Dufuor...i am in desperate need of it.

You could also please send the NAT-corrected configuration to my e-mail address( and i would be more than happy to have your e-mail address). My e-mail address is

Meanwhile, I remain:

Yours sincerely,

Buba Jallow.

CreatePlease to create content