Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

help me: why isdn backup line doesn't work

hi, please help me.

the backup line between our company and branch office doesn't work. the following is debug result:

11w1d: Channel ID i = 0x89

11w1d: ISDN BR0/0: received HOST_PROCEEDING call_id 0x8462

11w1d: ISDN BR0/0: RX <- DISCONNECT pd = 8 callref = 0xEA

11w1d: Cause i = 0x8492 - No user responding

11w1d: ISDN BR0/0: received HOST_DISCONNECT call_id 0x8462

11w1d: ISDN BR0/0: Event: Call to 38490132 was hung up.

11w1d: ISDN BR0/0: process_disc_ack(): call id 0x8462, ces 1, call type DATA

11w1d: BRI0/0: wait for isdn carrier timeout, call id=0x8462

11w1d: ISDN BR0/0: TX -> RELEASE pd = 8 callref = 0x6A

11w1d: Cause i = 0x8092 - No user responding

11w1d: ISDN BR0/0: RX <- RELEASE_COMP pd = 8 callref = 0xEA

11w1d: ISDN BR0/0: received HOST_DISCONNECT_ACK call_id 0x8462

11w1d: ISDN BR0/0: HOST_DISCONNECT_ACK: call type is DATA

11w1d: BRI0/0 DDR: Dialing cause ip (s=192.168.20.241, d=192.168.25.95)

11w1d: BRI0/0 DDR: Attempting to dial 38490132

11w1d: ISDN BR0/0: Outgoing call id = 0x8463, dsl 0

11w1d: ISDN BR0/0: Event: Call to 38490132 at 64 Kb/s

11w1d: ISDN BR0/0: process_bri_call(): call id 0x8463, called_number 38490132, s

peed 64, call type DATA

11w1d: CC_CHAN_GetIdleChanbri: dsl 0

11w1d: Found idle channel B1

11w1d: ISDN BR0/0: TX -> SETUP pd = 8 callref = 0x6B

11w1d: Bearer Capability i = 0x8890

11w1d: Channel ID i = 0x83

11w1d: Called Party Number i = 0x80, '38490132'

11w1d: ISDN BR0/0: RX <- CALL_PROC pd = 8 callref = 0xEB

11w1d: Channel ID i = 0x89

11w1d: ISDN BR0/0: received HOST_PROCEEDING call_id 0x8463

11w1d: ISDN BR0/0: RX <- DISCONNECT pd = 8 callref = 0xEB

11w1d: Cause i = 0x8492 - No user responding

11w1d: ISDN BR0/0: received HOST_DISCONNECT call_id 0x8463

11w1d: ISDN BR0/0: Event: Call to 38490132 was hung up.

11w1d: ISDN BR0/0: process_disc_ack(): call id 0x8463, ces 1, call type DATA

11w1d: BRI0/0: wait for isdn carrier timeout, call id=0x8463

11w1d: ISDN BR0/0: TX -> RELEASE pd = 8 callref = 0x6B

11w1d: Cause i = 0x8092 - No user responding

11w1d: ISDN BR0/0: RX <- RELEASE_COMP pd = 8 callref = 0xEB

11w1d: ISDN BR0/0: received HOST_DISCONNECT_ACK call_id 0x8463

11w1d: ISDN BR0/0: HOST_DISCONNECT_ACK: call type is DATA

11w1d: BRI0/0 DDR: Dialing cause ip (s=192.168.20.243, d=192.168.25.73)

11w1d: BRI0/0 DDR: Attempting to dial 38490132

11w1d: ISDN BR0/0: Outgoing call id = 0x8464, dsl 0

11w1d: ISDN BR0/0: Event: Call to 38490132 at 64 Kb/s

11w1d: ISDN BR0/0: process_bri_call(): call id 0x8464, called_number 38490132, s

peed 64, call type DATA

11w1d: CC_CHAN_GetIdleChanbri: dsl 0

11w1d: Found idle channel B1

11w1d: ISDN BR0/0: TX -> SETUP pd = 8 callref = 0x6C

11w1d: Bearer Capability i = 0x8890

11w1d: Channel ID i = 0x83

11w1d: Called Party Number i = 0x80, '38490132'

11w1d: ISDN BR0/0: RX <- CALL_PROC pd = 8 callref = 0xEC

11w1d: Channel ID i = 0x89

11w1d: ISDN BR0/0: received HOST_PROCEEDING call_id 0x8464

11w1d: ISDN BR0/0: RX <- DISCONNECT pd = 8 callref = 0xEC

11w1d: Cause i = 0x8492 - No user responding

11w1d: ISDN BR0/0: received HOST_DISCONNECT call_id 0x8464

11w1d: ISDN BR0/0: Event: Call to 38490132 was hung up.

11w1d: ISDN BR0/0: process_disc_ack(): call id 0x8464, ces 1, call type DATA

11w1d: BRI0/0: wait for isdn carrier timeout, call id=0x8464

11w1d: ISDN BR0/0: TX -> RELEASE pd = 8 callref = 0x6C

11w1d: Cause i = 0x8092 - No user responding

11w1d: ISDN BR0/0: RX <- RELEASE_COMP pd = 8 callref = 0xEC

11w1d: ISDN BR0/0: received HOST_DISCONNECT_ACK call_id 0x8464

11w1d: ISDN BR0/0: HOST_DISCONNECT_ACK: call type is DATA

11w1d: BRI0/0 DDR: Dialing cause ip (s=192.168.20.241, d=192.168.25.92)

11w1d: BRI0/0 DDR: Attempting to dial 38490132

11w1d: ISDN BR0/0: Outgoing call id = 0x8465, dsl 0

11w1d: ISDN BR0/0: Event: Call to 38490132 at 64 Kb/s

11w1d: ISDN BR0/0: process_bri_call(): call id 0x8465, called_number 38490132, s

peed 64, call type DATA

11w1d: CC_CHAN_GetIdleChanbri: dsl 0

11w1d: Found idle channel B1

11w1d: ISDN BR0/0: TX -> SETUP pd = 8 callref = 0x6D

11w1d: Bearer Capability i = 0x8890

11w1d: Channel ID i = 0x83

11w1d: Called Party Number i = 0x80, '38490132'

11w1d: ISDN BR0/0: RX <- CALL_PROC pd = 8 callref = 0xED

11w1d: Channel ID i = 0x89

11w1d: ISDN BR0/0: received HOST_PROCEEDING call_id 0x8465

11w1d: ISDN BR0/0: RX <- DISCONNECT pd = 8 callref = 0xED

11w1d: Cause i = 0x8492 - No user responding

11w1d: ISDN BR0/0: received HOST_DISCONNECT call_id 0x8465

11w1d: ISDN BR0/0: Event: Call to 38490132 was hung up.

11w1d: ISDN BR0/0: process_disc_ack(): call id 0x8465, ces 1, call type DATA

11w1d: BRI0/0: wait for isdn carrier timeout, call id=0x8465

11w1d: ISDN BR0/0: TX -> RELEASE pd = 8 callref = 0x6D

11w1d: Cause i = 0x8092 - No user responding

11w1d: ISDN BR0/0: RX <- RELEASE_COMP pd = 8 callref = 0xED

11w1d: ISDN BR0/0: received HOST_DISCONNECT_ACK call_id 0x8465

11w1d: ISDN BR0/0: HOST_DISCONNECT_ACK: call type is DATA

11w1d: BRI0/0 DDR: Dialing cause ip (s=192.168.20.5, d=192.168.25.126)

11w1d: BRI0/0 DDR: Attempting to dial 38490132

11w1d: ISDN BR0/0: Outgoing call id = 0x8466, dsl 0

11w1d: ISDN BR0/0: Event: Call to 38490132 at 64 Kb/s

11w1d: ISDN BR0/0: process_bri_call(): call id 0x8466, called_number 38490132, s

peed 64, call type DATA

11w1d: CC_CHAN_GetIdleChanbri: dsl 0

11w1d: Found idle channel B1

11w1d: ISDN BR0/0: TX -> SETUP pd = 8 callref = 0x6E

11w1d: Bearer Capability i = 0x8890

11w1d: Channel ID i = 0x83

11w1d: Called Party Number i = 0x80, '38490132'

11w1d: ISDN BR0/0: RX <- CALL_PROC pd = 8 callref = 0xEE

11w1d: Channel ID i = 0x89

11w1d: ISDN BR0/0: received HOST_PROCEEDING call_id 0x8466

11w1d: ISDN BR0/0: RX <- DISCONNECT pd = 8 callref = 0xEE

11w1d: Cause i = 0x8492 - No user responding

11w1d: ISDN BR0/0: received HOST_DISCONNECT call_id 0x8466

11w1d: ISDN BR0/0: Event: Call to 38490132 was hung up.

11w1d: ISDN BR0/0: process_disc_ack(): call id 0x8466, ces 1, call type DATA

11w1d: BRI0/0: wait for isdn carrier timeout, call id=0x8466

11w1d: ISDN BR0/0: TX -> RELEASE pd = 8 callref = 0x6E

11w1d: Cause i = 0x8092 - No user responding

11w1d: ISDN BR0/0: RX <- RELEASE_COMP pd = 8 callref = 0xEE

11w1d: ISDN BR0/0: received HOST_DISCONNECT_ACK call_id 0x8466

11w1d: ISDN BR0/0: HOST_DISCONNECT_ACK: call type is DATA

sh2620#

our company router's config is:

User Access Verification

Password:

sh2620>en

Password:

sh2620#show run

Building configuration...

Current configuration:

!

version 12.0

!

hostname sh2620

!

enable secret level 14 5 $1$DHqe$itwTTozgu9KV4rXp5jAN70

enable secret 5 $1$jExL$0NKOWKGq3xl7uyZVsDJGN/

!

username sha_intl_express password 7 0509070C2A595E05100B12

username shanghai-pd-airport1720 password 7 070C285F4D06

!

ip subnet-zero

!

isdn switch-type basic-dms100

isdn voice-call-failure 0

!

interface FastEthernet0/0

ip address 192.168.20.253 255.255.255.0

no ip directed-broadcast

duplex auto

speed auto

!

interface BRI0/0

description ISDN local backup line 32160597

ip address 192.168.23.130 255.255.255.192

no ip directed-broadcast

encapsulation ppp

ip ospf demand-circuit

load-interval 30

dialer idle-timeout 30

dialer map ip 192.168.23.132 name sha_intl_express 32160075

dialer map ip 192.168.23.131 name shanghai-pd-airport1720 38490132

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

....

router ospf 100

redistribute connected

redistribute static

network 192.168.20.0 0.0.0.255 area 0

network 192.168.23.0 0.0.0.255 area 4

network 192.169.23.0 0.0.0.255 area 4

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.20.254

ip route 192.168.21.0 255.255.255.0 192.168.23.132 200

ip route 192.168.25.64 255.255.255.192 192.168.23.131 200

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

line aux 0

line vty 0 4

exec-timeout 0 0

password 7 01070706570E5708

login

!

no scheduler allocate

end

our branch office router config is:

shanghai-pd-airport1720#show run

Building configuration...

Current configuration:

!

version 12.0

hostname shanghai-pd-airport1720

!

enable secret 5 $1$vAkw$gqxcUBTWP/3aXnplgxz9E.

enable password 7 091D1C5A4D50

!

username sh2620 password 7 01100F175804

!

memory-size iomem 25

ip subnet-zero

!

isdn switch-type basic-net3

!

process-max-time 200

.....

interface BRI0

description backup line 38490132 to SH H.Q

ip address 192.168.23.131 255.255.255.192

no ip directed-broadcast

encapsulation ppp

ip ospf demand-circuit

load-interval 30

dialer idle-timeout 30

dialer string 32160597

dialer hold-queue 75

dialer load-threshold 5 either

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

!

interface FastEthernet0

ip address 192.168.25.65 255.255.255.192

no ip directed-broadcast

!

router ospf 100

redistribute connected

redistribute static

network 192.168.25.0 0.0.0.255 area 4

network 192.168.204.0 0.0.0.255 area 4

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.204.1

ip route 0.0.0.0 0.0.0.0 192.168.23.130 200

ip route 192.168.23.128 255.255.255.192 BRI0

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

password 7 1446405858

login

transport input none

line aux 0

line vty 0 4

exec-timeout 0 0

password 7 111D18071B17

login

!

no scheduler allocate

end

6 REPLIES
New Member

Re: help me: why isdn backup line doesn't work

how do you test it? shutdown the primary link? if it is, the isdn would not work.

New Member

Re: help me: why isdn backup line doesn't work

i use floating route, do it is not necessary to shutdown the primary link. the other isdn backup line with the same config can work well. you can see the config in our company router config.

Silver

Re: help me: why isdn backup line doesn't work

We see the remote end switch disconnect the call stating:

11w1d: ISDN BR0/0: RX <- DISCONNECT pd = 8 callref = 0xED

11w1d: Cause i = 0x8492 - No user responding

84 - From the public network near the remote user (remote telco switch).

Ensure the ISDN status is fine at the remote end.

ISDN disconnect code:

http://cisco.com/en/US/tech/tk801/tk379/technologies_tech_note09186a008012e95f.shtml

Thanks,Mak.

New Member

Re: help me: why isdn backup line doesn't work

thanks for your help!

can you make a detail description for something that i need to check.

i have changed a new modem and i have use telephone to call to center with normal result. what else should i do?

i can not ping successfully from center to remote office, but if i ping from remote office to our center with a extended ping of a long time, the connection can be established successfully. after the long time ping is over, the connection is down and i cannot ping from center to remote.

can you lead me to solve it? thank you!

New Member

Re: help me: why isdn backup line doesn't work

Hi,

as mark already told you, the branch router doesn´t respond to the isdn call.

Maybe its the wrong number, so it is ringing somewhere but not on the isdn port of the router.

If you dial from the branch-router to the central-site you can do a "debug isdn q931" on the central-router and look at the "calling-number".

This should be the same as the number you have to dial except some preceding digits for dialing out or long-distance calls or whatever the ...

good luck

Horst

New Member

Re: help me: why isdn backup line doesn't work

thank you very much! i will have a check.

429
Views
0
Helpful
6
Replies
CreatePlease to create content