Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help needed with ddr isdn backup with rotary groups

Hi There,

I'm trying to backup several remote sites' wan connection with isdn to a central site ( a hub and spoke topology for ddr backup). I want the remote sites to call the central site when the wan link goes down but not the other way round. The central site has a pri E1 connection to a 3640 router. I have configured dialer watch at the remote site and it works ok when the central site is configured with a dialer group command and dialer remote name. I wanted to use rotary groups so that i can add more remote sites to the dialer profile config at the central site ( i was going to add more dialer map statements to the dialer interface as shown in my enclosed config).

With the rotary group and dialer map statement configured on the central site I am unable to get ip connectivity between the central and remote site. The remote router shows an isdn connection to the central site when i do 'show dialer' but pings don't show connectivity. This is the central site config:

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname trr004x

!

enable password 7 xxxxxxxxxx

!

username master password 7 xxxxxxxxx

username MRR001X password 7 xxxxxxxx

username CCR001X password 7 xxxxxxxxx

ip subnet-zero

no ip domain-lookup

ip host mrr001x 10.1.16.2

isdn switch-type primary-net5

clock timezone gmt 0

clock summer-time bst recurring last Sun Mar 2:00 last Sun Oct 2:00

!

!

controller E1 2/0

pri-group timeslots 1-31

!

!

interface Ethernet0/0

description link to trf0021 mod 2 port 5

ip address 10.2.44.4 255.255.252.0

no ip directed-broadcast

!

interface Ethernet0/1

no ip address

no ip directed-broadcast

shutdown

!

interface Serial2/0:15

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 1

isdn switch-type primary-net5

!

interface Dialer0

ip address 10.2.176.1 255.255.255.0

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer map ip 10.2.176.10 name MRR001X

dialer-group 1

ppp authentication chap

ppp multilink

!

interface Dialer1

no ip address

no ip directed-broadcast

encapsulation ppp

pulse-time 0

!

router eigrp 1

network 10.0.0.0

network 144.98.0.0

no auto-summary

!

ip classless

!

!

map-class dialer remote

dialer wait-for-carrier-time 60

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

line con 0

transport input none

line aux 0

line vty 0 4

password 7 xxxxxxxxxxxx

login

!

end

Here is the configuration of the remote router:

Building configuration...

Current configuration : 4095 bytes

!

! Last configuration change at 13:00:30 bst Wed Aug 7 2002 by master

! NVRAM config last updated at 12:24:29 bst Wed Aug 7 2002 by master

!

version 12.1

service timestamps debug datetime

service timestamps log datetime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname MRR001X

!

boot system flash

aaa new-model

aaa authentication login default group tacacs+ local

aaa authentication ppp default local

aaa authorization exec default group tacacs+

aaa accounting exec default start-stop group tacacs+

aaa accounting network default start-stop group tacacs+

enable secret 5 xxxxxxxxxxxxxxxxxxxx

enable password xxxxxxxxxxxxxxxxxxxxx

!

username trr004x password 7 08324D5D0A49

!

!

!

!

clock timezone gmt 0

clock summer-time bst recurring last Sun Mar 2:00 last Sun Oct 2:00

ip subnet-zero

!

isdn switch-type basic-net3

isdn voice-call-failure 0

isdn tei-negotiation first-call

!

!

!

interface Ethernet0

ip address 10.28.0.1 255.255.252.0

ip helper-address 10.2.44.200

no ip route-cache

no ip mroute-cache

keepalive 4

!

interface Serial0

description Frame-Relay Link from MRR001X to TRR001X

bandwidth 64

ip address 10.1.16.2 255.255.255.252

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

no fair-queue

frame-relay map ip 10.1.16.1 100 broadcast

frame-relay lmi-type ansi

!

interface Serial1

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

interface BRI0

description dial backup link to trr004x

bandwidth 56

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

no keepalive

dialer pool-member 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

!

interface Dialer0

ip address 10.2.176.10 255.255.255.0

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer remote-name trr004x

dialer idle-timeout 90

dialer string 01xxxxxxxxx

dialer watch-group 8

dialer-group 1

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

router eigrp 1

network 10.0.0.0

network 144.98.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip forward-protocol udp tftp

no ip forward-protocol udp nameserver

no ip forward-protocol udp domain

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

no ip http server

!

logging trap debugging

access-list 101 deny ip any any

dialer watch-list 8 ip 10.1.16.0 255.255.255.252

dialer-list 1 protocol decnet deny

dialer-list 1 protocol ip list 101

tacacs-server host 10.2.44.208

tacacs-server host 10.2.44.206

tacacs-server timeout 1000

tacacs-server key cisco

snmp-server engineID local 00000009020000E01E3E7080

snmp-server community public xxxx

line con 0

line aux 0

password cisc0

no activation-character

modem InOut

transport input all

stopbits 1

flowcontrol hardware

line vty 0 4

password xxxxxx

!

ntp clock-period 17179828

ntp server 144.98.31.172

end

Hope you can help me show where I have gone wrong, rgds Martin

3 REPLIES
Cisco Employee

Re: Help needed with ddr isdn backup with rotary groups

Instead of using dialer map under dialer interface, Try using it under physical interface (under interface serial 2/0:15) without "dialer rotary-group 1" command..You can use as many dialer map you want under that serial 2/0:15 interface..So just configure that serial interface for ip address and dialer map for remote sites..(like dialer interface)

OR

Since all the remote sites are coming up with a static ip address, you don't even need a dialer map statements..Let the central site make a dynamic dialer map after ppp negotiation.

Try aboce config and see if you can get success

New Member

Re: Help needed with ddr isdn backup with rotary groups

i'll give that a go and let you know, thanks for the advice.

New Member

Re: Help needed with ddr isdn backup with rotary groups

Taking out the dialer map statement from the dialer profile has got it working, thanks for the advice. Just another 28 remote sites to set-up and test now that the first is is working! Ho-hum.

84
Views
0
Helpful
3
Replies
CreatePlease login to create content