Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help please with NAT on two private networks

Ok.. I admit it.. I am clueless.. Maybe that cisco cert would have come in handy right about now.. but I gave it the old try and now my brain is getting crispy trying to figure this out....What I have is two different LAN's that I need to join.. one is the 10.2.0.0 network the other is the 10.20.240.0 network.. both 24 bit subnets. Anyhow if you need to know why here is the situation.. the 10.2.0.0 network is mine.. the 10.20.240 network is a vendors that I want to get to from my 10.2.0.0 network.. so ... this enough babbling.. this is what I got, alot of it is the default stuff... I'm not concerned about security just yet, as both networks are pretty secure.. I just want all traffic to flow from one to the other and vice versa.

Critical info:

1) I can, from the LAN side ping both the lan and the wan port from my PC

2) From the router I can ping both ports, and I can ping anything on either side.

3) From my PC I cannot ping anything on the WAN side(cept the WAN port of the router).

4) When I issue "show ip nat translation" I get a blank line and thats it.

5) most important.. how do I remove lines from this thing.. all I can do is add lines :->

Cicso 802 router

Running like this:

ip subnet-zero

!

!

!

!

interface Ethernet0

ip address 10.2.0.9 255.255.255.0

ip nat inside

hold-queue 100 out

interface Ethernet0

ip address 10.2.0.9 255.255.255.0

ip nat inside

hold-queue 100 out

!

interface Ethernet1

ip address 10.20.240.100 255.255.255.0

ip nat outside

!

ip nat pool wannat 10.20.240.101 10.20.240.101 netmask 255.255.255.0

ip classless

no ip http server

!

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

I'm assuming it's my ACL I made, or maybe some default ACL thats running, but the manual that came with the router(I know.. cisco cert would be a good idea) but it's in greek or something. Sooo, if you can please help.. my code is below..

Thanks for your time

Josh

jmartin@motorwerks.com

Hey.. at least I managed to turn the thing on!!!

1 REPLY
Cisco Employee

Re: Help please with NAT on two private networks

you're missing one line.

'ip nat inside source list 101 pool wannat overload'

Without this line, you can't have translation.

86
Views
0
Helpful
1
Replies
CreatePlease login to create content