Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

help!!! "boot cannot load flash"

please candid help on this, i'm actually using a 1720 router for practice and have to erase the flash for another practice. but unfirtunately he bring an error message that

Load prog: bad file magic number 0X0.

boot: cannot load flash.

he keep on going to rommon prompt. ive tried all i could but no way.

help!!!!

4 REPLIES
Bronze

Re: help!!! "boot cannot load flash"

The quickest way to recover is from the rommon prompt enter these commands:

IP_ADDRESS=

IP_SUBNET_MASK=

DEFAULT_GATEWAY=

TFTP_SERVER=

TFTP_FILE=

For the IP_ADDRESS variable, enter in a temporary IP for the router

For the IP_SUBNET_MASK variable, enter in a temporary subnet mask for the router

For the DEFAULT_GATEWAY variable, enter in a temporary default gateway for the router (if needed)

For the TFTP_FILE variable, enter in the ios image name on your tftp server for this router

e.g.

IP_ADDRESS=192.168.10.5

IP_SUBNET_MASK=255.255.255.0

DEFAULT_GATEWAY=192.168.10.1

TFTP_SERVER=192.168.10.100

TFTP_FILE=ios_image.bin

Then type in

tftpdnld

-HTH

New Member

Re: help!!! "boot cannot load flash"

Hi.I am also getting the same error when I am booting up my layer3 switch.

From the ROM Mode I tried the feature but it is giving the error.

Even if I used the Xmodem feature on the hyperterminal, it is giving me the error "No response from the remote system"

Can you pls help me out to get my switch up and running with the new IOS.

Bronze

Re: help!!! "boot cannot load flash"

New Member

Re: help!!! "boot cannot load flash"

I am using Catalyst 4840G switch.

I have tried installing IOS in the switch from the hyperterminal using Xmodem but it is giving an error.

The error displayed "Remote system Not response"

If I use Xmodem from Rommode it is still unable to copy the IOS.Is it the problem with the Flash card.

339
Views
0
Helpful
4
Replies