Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Help with a WAN routing problem...

Below is a captured TELNET session. From the main network "PHC"-10.1.1.0 I can ping workstations on "DME" 192.168.132.0. From 192.168.132.0 I can ping as far as the E0 (10.1.1.37) but no IPs beyond that. The first sh run is for PHC the second is DME. Any help is greatly appreciated.

Dennis

sh run

Building configuration...

Current configuration : 946 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname phcdme

!

enable secret xxxxxxx

enable password

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip domain-lookup

!

!

!

--More--

interface Serial0

description ckt flzc83709mb to dme

bandwidth 256

ip address 192.168.100.1 255.255.255.0

no keepalive

no fair-queue

service-module t1 timeslots 1-4

!

interface FastEthernet0

ip address 10.1.1.37 255.255.255.0

speed 10

half-duplex

!

router rip

redistribute connected

network 10.0.0.0

network 192.168.100.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0

ip route 192.168.132.0 255.255.255.0 192.168.100.2

no ip http server

--More--

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

banner motd ^CAccess to this router is restricted^C

!

line con 0

password

login

line aux 0

line vty 0 4

password

login

!

end

phcdme#ping 192.168.132.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.132.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms

phcdme#telnet 192.168.132.41

Trying 192.168.132.41 ... Open

User Access Verification

Password:

dmephc>en

Password:

dmephc#sh run

Building configuration...

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname dmephc

!

enable secret xxxxxx

enable password

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip domain-lookup

!

!

!

--More--

interface Serial0

description ckt flzc83709mb to phc

bandwidth 256

ip address 192.168.100.2 255.255.255.0

no keepalive

no fair-queue

service-module t1 timeslots 1-4

!

interface FastEthernet0

ip address 192.168.132.41 255.255.255.0

speed 10

half-duplex

!

router rip

redistribute connected

network 10.0.0.0

network 192.168.100.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0

ip route 10.0.0.0 255.255.255.0 192.168.100.1

ip route 10.1.1.0 255.255.255.0 192.168.100.1

--More--

no ip http server

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

line con 0

transport input none

line aux 0

line vty 0 4

password

login

!

no scheduler allocate

end

dmephc#ping 10.1.1.37

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.37, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/20 ms

dmephc#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

dmephc#

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Help with a WAN routing problem...

You need to check the gateway address and mask of the pc 10.1.1.1. Can you ping it from PHC using extended ping and the IP of the serial link?

8 REPLIES
Bronze

Re: Help with a WAN routing problem...

You need to check the gateway address and mask of the pc 10.1.1.1. Can you ping it from PHC using extended ping and the IP of the serial link?

New Member

Re: Help with a WAN routing problem...

Hello,

I have made the gateway of my pc (on the 10.1.1.0) 10.1.1.37. From my workstation I can ping 10.1.1.37 but not 192.168.100.1. That makes no sense. I can ping everything from the router PHC and the router DME (except workstations on 10.1.1.0. The problem is between E0 and S0 on PHC. Line is up, Protocol is up all, Ints are up and running.

Dennis

New Member

Re: Help with a WAN routing problem...

I have now made the gateway on my workstation (10.1.1.51) 10.1.1.37 and 192.168.100.1 (which I shouldn't have to do) and it works. I can ping from my workstation to PHC, over to DME and IP 192.168.132.2 on the remote network.

I do the same on a server on the network, add to it's gateways: 10.1.1.37 and 192.168.100.1 and I cannot ping 192.168.100.1 from this server. What the heck is going on?

Dennis

New Member

Re: Help with a WAN routing problem...

Hey rjackson,

Thanks for the help today. One thing I don't understand is; why would I have make the S0 a gateway? Should I not just have to make the E0 a gateway? Why is it now working because I've made both the E0 and S0 a gateway?

Dennis

Re: Help with a WAN routing problem...

Hi,

First of all regarding your configuration, it needs some clean up. You dont need those static routes , if you are running RIP already. For ex, on PHC, the route statement (ip route 192.168.132.0 255.255.255.0 192.168.100.2) is not needed. The network 192.168.132.0 is the lan interface address of DME and this route will be advertised through RIP. Similarly you dont need the static route about 10.1.1.0 network on DME.

You also do not need the redistribute connected command configured under RIP on either routers.

On DME you also dont need a network 10.0.0.0 command under RIP, because there is no interface on that router falling under that network.

A sample configuration on either routers should look like

PHC

router rip

network 10.0.0.0

network 192.168.100.0

ip route 0.0.0.0 0.0.0.0 fastethernet0 (this is needed if you have a internet gateway)

DME

router rip

network 192.168.100.0

network 192.168.132.0

ip route 0.0.0.0 0.0.0.0 fastethernet0 (this is needed if you have a internet gateway)

Also the gateways on the PCs on the lan of PHC router should be pointed to 10.1.1.37. You dont need to point them to s0. and the gateways on the PCs on the lan of DME router, needs to be pointed to 192.168.132.41

Try the above configuration and let us know if it works.

New Member

Re: Help with a WAN routing problem...

Thanks for the help.

From the PHC router I can ping 192.168.132.2

From the DME router I can ping 10.1.1.37 (EO on PHC) but not any IPs on the 10.1.1.0 network. Any ideas?

Dennis

New Member

Re: Help with a WAN routing problem...

The only way I get a successful ping from DME (192.168.132.41) pinging 10.1.1.51 (my pc on the 10.1.1.0) is to add 192.168.100.1 as the default gateway. Why in the world is that? Should not 10.1.1.37 be a gateway?

Dennis

New Member

Re: Help with a WAN routing problem...

How does the routing table looks like on your PC ?

"route print" for windows OR "netstat -rn" for unix

Have you tried to ping any other PC on 10.1.1.0 subnet ?

Regards \\ Naman

107
Views
0
Helpful
8
Replies