Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Hall of Fame Super Silver

Help with EIGRP and overlapping address

What can I do here since my client has overlaping IP address in

different buildings. The main building connects to building 1 and to

building 2, building 3 connects to building 2.

main building-----------------------------building 1

|

|

building 2----------------------------------building 3

I didn't configure this, but we added the backup to all the buildings.

Now I get overlaping address when I try to do a no shut on the

interfaces. In the network x.x.x.x, should I only specify what

network that are assigned and specific interface address.

Each building is almost it's own....

10.1.0.0

10.2.0.0

10.3.0.0

10.4.0.0

All the buildings have a network 10.0.0.0.......

The problem is with the 10.10.0.0 address configured... one building

will have an interface configured with 10.10.1.2 & 10.10.1.4. The

other building will have 10.10.1.3 & 10.10.1.5. How can I work around

this so I can still have my backup links failover.

Thanks!

Here is some of the config:

Main Building:

interface FastEthernet46

description Backup 11Mbps WAN to Building 1

ip address 10.10.2.3 255.255.255.0

no ip directed-broadcast

shutdown

ipx network AA1 encapsulation SAP

bridge-group 1

!

interface FastEthernet47

description Backup 11Mbps WAN to Building 2

ip address 10.10.4.3 255.255.255.0

no ip directed-broadcast

shutdown

ipx network AA3 encapsulation SAP

bridge-group 1

!

interface FastEthernet48

description Primary 100Mbps WAN to Building 1

ip address 10.10.2.1 255.255.255.0

no ip directed-broadcast

ipx network AAA1 encapsulation SAP

bridge-group 1

!

interface GigabitEthernet49

description Primary Gig WAN to Building 2

ip address 10.10.4.1 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

bridge-group 1

!

interface GigabitEthernet50

description Connection to internal LAN

ip address 10.4.0.2 255.255.255.0

no ip directed-broadcast

ipx network A0 encapsulation SAP

bridge-group 1

!

router eigrp 1

network 10.0.0.0

!

router rip

redistribute eigrp 1

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.4.0.3

Building 1

interface FastEthernet0/0

description Connection to internal LAN

ip address 10.1.0.1 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

ipx network 230F encapsulation SAP

no mop enabled

bridge-group 1

!

interface FastEthernet0/1

description FE WAN to Main Building

ip address 10.10.2.2 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

ipx network AAA1 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

interface Ethernet1/0

description Backup 11Mbps WAN to Main Building

ip address 10.10.2.4 255.255.255.0

shutdown

half-duplex

ipx network AA1 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

router eigrp 1

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.2.1

no ip http server

Building 2

interface FastEthernet45

description Backup 11Mbps WAN to Main Building

ip address 10.10.4.4 255.255.255.0

no ip directed-broadcast

shutdown

ipx network AA3 encapsulation SAP

bridge-group 1

!

interface FastEthernet46

description Backup 11Mbps WAN to Building 3

ip address 10.10.1.5 255.255.255.0

no ip directed-broadcast

shutdown

ipx network AA2 encapsulation SAP

bridge-group 1

!

interface FastEthernet47

description connection to internal LAN

ip address 10.2.0.1 255.255.255.0

no ip directed-broadcast

ipx network 230C encapsulation SAP

bridge-group 1

!

interface FastEthernet48

description Primary 100Mpbs WAN to Building 3

ip address 10.10.1.3 255.255.255.0

no ip directed-broadcast

ipx network AAA2 encapsulation SAP

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet50

description Primary Gig WAN to Main Building

ip address 10.10.4.2 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

router eigrp 1

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.4.1

Building 3

interface FastEthernet0/0

description Connection to internal LAN

ip address 10.3.0.1 255.255.255.0

duplex auto

speed auto

ipx network 230A encapsulation SAP

no mop enabled

bridge-group 1

!

interface FastEthernet0/1

description Primary 100Mbps WAN to Building 2

ip address 10.10.1.2 255.255.255.0

speed 100

full-duplex

ipx network AAA2 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

interface Ethernet1/0

description Backup 11Mbps WAN to Building 2

ip address 10.10.1.4 255.255.255.0

shutdown

half-duplex

ipx network AA2 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

router eigrp 1

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.1.3

no ip http server

-Scott
*** Please rate helpful posts ***
10 REPLIES
Silver

Re: Help with EIGRP and overlapping address

the main building & building 1 do not have 'no auto-summary' configured under Router eigrp 1. Try this

Re: Help with EIGRP and overlapping address

Usually I see two options when overlapping:

1) renumber so the IPs don't overlap (let eigrp routing do the work, easy to do)

2) Use nat so that you can have overlapping addresses: http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a0080093f30.shtml

But in your case you want on building3 f0/1 and f1/0 to be on the same subnet. Again I see 2 options:

1) renumber the backup interface and let routing do the backup/failover for you (preferred and easy - why do they need the same subnet?).

2) use a bvi interface and put the IP on it, place the interfaces you want in the bvi group. Force one interface to be active. Depending on your needs it may or may not work.

By the way, you should add a default-metric command for redistributing eigrp 1 into rip (on the main building). Also add no auto-sum on all eigrps.

Hope it helps.

Steve

Hall of Fame Super Silver

Re: Help with EIGRP and overlapping address

Well.... I think I will use a 10.10.3.X, 10.10.6.X, and a 10.10.7.X for the backup.

How should I add a default-metric command for redistributing eigrp 1 into rip (on the main building).

Thanks!

-Scott
*** Please rate helpful posts ***

Re: Help with EIGRP and overlapping address

You can be specific to eigrp (eg redistribute eigrp metric 2 - assigns the eigrp-derived routes a RIP metric of 2) or general to all protocols being redistributed into rip, eg:

!

router rip

redistribute eigrp 1

default-metric 2 (all redistributed routes, eigrp and ospf for example if it were present, a metric of 2)

network 10.0.0.0

!

A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever metrics do not convert, using a default metric provides a reasonable substitute and enables the redistribution to proceed.

Rip understands hops, eigrp understands bandwidth and delay.

Steve

Hall of Fame Super Silver

Re: Help with EIGRP and overlapping address

I did configure the default metric and EIGRP lost all it's routes. I had to remove the command and issue a reload. Is this a normal thing?

-Scott
*** Please rate helpful posts ***

Re: Help with EIGRP and overlapping address

You only entered :

router rip

redistribute eigrp 1

default-metric 2

network 10.0.0.0

on the main building router and it lost it's eigrp routes? That is not normal, eigrp should be unaffected. You aren't redistributing rip into eigrp as well are you (if you were to you would need filters to prevent potential routing loops)? Were the RIP routes still there? Is the no auto-sum on the eigrp process?

As a side note do you even need RIP and/or redistrib eigrp into it?

Steve

Hall of Fame Super Silver

Re: Help with EIGRP and overlapping address

Yes... I entered:

router rip

redistribute eigrp 1

default-metric 2

network 10.0.0.0

The next thing I knew I lost connection to all the other buildings. I did a show Ip route and all there was, was the directly connected routes. Here is part of the new config.

Main Building:

interface FastEthernet46

description Backup 11Mbps WAN to Building 2

ip address 10.10.20.3 255.255.255.0

no ip directed-broadcast

ipx network AA1 encapsulation SAP

bridge-group 1

!

interface FastEthernet47

description Backup 11Mbps WAN to Building 1

ip address 10.10.40.1 255.255.255.0

no ip directed-broadcast

ipx network AA3 encapsulation SAP

bridge-group 1

!

interface FastEthernet48

description Primary 100Mbps WAN to Building 2

ip address 10.10.2.1 255.255.255.0

no ip directed-broadcast

ipx network AAA1 encapsulation SAP

bridge-group 1

!

interface GigabitEthernet49

description Primary Gig WAN to Building 1

ip address 10.10.4.1 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

bridge-group 1

!

interface GigabitEthernet50

description Connection to internal LAN

ip address 10.4.0.2 255.255.255.0

no ip directed-broadcast

ipx network A0 encapsulation SAP

bridge-group 1

!

router eigrp 1

network 10.0.0.0

no auto-summary

!

router rip

redistribute eigrp 1

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.4.0.3

Building 2

interface FastEthernet0/0

description Connection to internal LAN

ip address 10.1.0.1 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

ipx network 230F encapsulation SAP

no mop enabled

bridge-group 1

!

interface FastEthernet0/1

description FE WAN to Main Building

ip address 10.10.2.2 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

ipx network AAA1 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

interface Ethernet1/0

description Backup 11Mbps WAN to Main Building

ip address 10.10.20.2 255.255.255.0

full-duplex

ipx network AA1 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

router eigrp 1

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.2.1

no ip http server

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: Help with EIGRP and overlapping address

EIGRP works sort of well, but the issue is that only if the ethernet side goes down will EIGRP failover to the backup link. When we shut the radio side of the wireless bridge down, the ethernet port was still up on the bridge. EIGRP did not fail over to the backup link. What can I do to make sure that the failover workes in this situation. Is there a way to track the other side.

Thanks!

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: Help with EIGRP and overlapping address

Would just creating static routes to the primary interface on the other side help sove my issues?

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: Help with EIGRP and overlapping address

What will this do..... I will configure it though. Thanks!

-Scott
*** Please rate helpful posts ***
334
Views
0
Helpful
10
Replies
CreatePlease to create content