Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help with Multiple VLANS and IP Phone Setup.

Although i have a 3com, I have a cisco IP Phone. I have the IP Phone connected to the 3com swithport using a hybrid port. It's a tagged member of vlan3 (voice net) and an untagged member of vlan1(native data)

The ip phone gets the right DHCP address for vlan3 ( 10.x.x.x ) but the laptop connected to the ip phone gets the IP for vlan 3 as well.

I want the laptop to get the IP of the native vlan ( 192.168.x.x)

what would the port setup need to be ? does it need to be a trunk ? i have the PVID of the port set to vlan3, this allows the IP phone to get its vlan3 DHCP address.

any help would be greatly appreciated.

The 3com OS is very similar to the latest of CISCO IOS'.

so explain wtih syntax and i'm sure the 3com can relate.

5 REPLIES

Re: Help with Multiple VLANS and IP Phone Setup.

Cisco IP Phones use CDP to discover the Voice VLAN (the VLAN Tag they should use to transmit packets). Other Vendors use DHCP Vendor Options in the UnTagged VLAN (access VLAN) to discover the Voice VLAN. I don't think Cisco IP Phones can discover the Voice VLAN any other way than CDP (or manually configured), so unless your 3Com switches support CDP you won't be able to automatically tell the Cisco IP Phones what the Voice VLAN is.

Andy

New Member

Re: Help with Multiple VLANS and IP Phone Setup.

Thanks for the great response andrew.

Question: what is the ideal or proper switchport configuration that will accomplish this ?

Again, the configuration i have set is the port is set as a Hybrid port and is a tagged memeber of vlan 3(voice) and an untagged member of vlan 1(native-data) The default pvid of the port is set to 3.

I want the phone to get the ip from vlan 3's dedicated DHCP scope ( 10.x.x.x)

And i want the laptop/pc connected to the phones' switchport to get the ip from vlan 1's DHCP scope ( 192.168.x.x.)

Both scopes reside on the same DHCP sever that is a untagged member of vlan 1 only.

From experience, would you know what exact DHCP server option other IP Phone vendors would require ?

FYI - 3com's defition of Hybrid Port vs Trunk Port is as follows:

A hybrid port allows the packets from multiple VLANs to be without tags, but a trunk port only allows the packets from the default VLAN to be sent without tags.

Should i make the port a trunk port instead ?

Thanks.

Re: Help with Multiple VLANS and IP Phone Setup.

Based on your description of a 'Hybrid Port' this sounds like Cisco's 'Multi-VLAN Port' that was a feature of the 2900XL/3500XL series switches. This feature has however long since gone......

With a Cisco switch an access port supporting an Access VLAN & a Voice VLAN is effectively a Trunk with only one Tagged VLAN and the Native VLAN:

interface FastEthernet0/1

switchport mode access

switchport access vlan 10

switchport voice vlan 100

!

This results in the same configuration as:

interface FastEthernet0/1

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 100

!

With the exception of CDP packets being sent advertising the Voice VLAN.

With regards to other IP Phone vendors and DHCP Vendor Options - the answer is it depends....

Nortel use Vendor Option 144 to inform the IP Phone of the Voice VLAN and Option 128 for the Server (PBX) to use. Ericsson uses Vendor Option 43 that can be configured to tell the IP Phone the VLAN and the Web server to read the config file from.

I don't think you will get this working automatically with your 3Com switches, you can however manually configure the VLAN on the Cisco IP Phones.

HTH

Andy

New Member

Re: Help with Multiple VLANS and IP Phone Setup.

So for testing purposes i would try:

switching the port to a trunk port and make the default pvid set to 1(native) and allow and tag vlan 3 ?

Any idea what option AVAYA ip phones use ?

These 3com switches have a voice vlan as well i can configure auto and manual mode.

I believe that i can add the port as an access port for the native vlan 1 and set that as a pvid and setup the port as belonging to the voice vlan 3, as you described above.

Your response has helped think about multiple options.

BTW - The switches i'm using are 3com 5500G-EI - the latest high-grade switches are are pretty similar to the cisco 3800 series, i believe.

Bronze

Re: Help with Multiple VLANS and IP Phone Setup.

avaya phones use option 176 or option 242 and now support LLDP

1189
Views
0
Helpful
5
Replies
CreatePlease login to create content