Cisco Support Community
Community Member

Help with NTP

I cannot get any of my Cisco switches to sync with an NTP server. I have configured a Windows Server to be the NTP server for all of my network equipment but it will not work. Here is the config:

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption


hostname xxxxxxxx




no aaa new-model

ip subnet-zero

ip domain-name XXXXXXXXX



mls qos



no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id


vlan internal allocation policy ascending


class-map match-any 3megIN_OUT

match ip dscp default

class-map match-any 7.5megIN_OUT

match ip dscp default

class-map match-any 15megIN_OUT

match ip dscp default



policy-map 3megIN_OUT

class 3megIN_OUT

police 3000000 375000 exceed-action policed-dscp-transmit

policy-map 7.5megIN_OUT

class 7.5megIN_OUT

police 7496000 937500 exceed-action policed-dscp-transmit

policy-map 15megIN_OUT

class 15megIN_OUT

police 15000000 1000000 exceed-action policed-dscp-transmit


interface Vlan1

no ip address



interface Vlan37

ip address

no ip route-cache


ip default-gateway

ip classless

ip http server





banner motd ^CYou are about to access xxxxxxxxxxxxxxxxxxxx.

All access is controlled. Unauthorized access is a violation

of Federal and State law and company policy.

Information systems, data and information are xx assets for

xx business use only.^C


line con 0

password xxxxxxxx


line vty 0 4

password xxxxxxxx


line vty 5 15

password xxxxxxxx

no login


ntp server



xxxxxxxxxx#sho ntp status

Clock is unsynchronized, stratum 16, no reference clock

nominal freq is 119.2092 Hz, actual freq is 119.2092 Hz, precision is 2**17

reference time is 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)

clock offset is 0.0000 msec, root delay is 0.00 msec

root dispersion is 0.00 msec, peer dispersion is 0.00 msec

xxxxxxxxxx#sho ntp ass

address ref clock st when poll reach delay offset disp 3 7 64 3 0.9 -84160 7879.3

* master (synced), # master (unsynced), + selected, - candidate, ~ configured


Re: Help with NTP


wouldn´t you need additionally something like:

clock timezone gmt

ntp source Loopback0

ntp update-calendar

ntp server

Do you use authentication on your NTP server?

The use on the Switch:

ntp authentication-key 10 md5 MyNTPpassword

ntp authenticate

ntp trusted-key 10



VIP Purple

Re: Help with NTP


I might be off course here, but I seem to remotely remember having a similar problem, eventually I configured SNTP instead of NTP:

sntp server

I think for Windows to work as an NTP server, you have to install a package like this:

PresenTense Time Server



Hall of Fame Super Gold

Re: Help with NTP


You are quite on course. The implementation of time service in Windows is based on SNTP. And Cisco devices running NTP will not sync with an SNTP server. So running SNTP on Cisco is an option.

Martin's suggestion about specifying time zone is nice but not necessary to being able to sync. And his suggestions about doing things like authentication of NTP are good practice, assuming that you are using the NTP service rather than the SNTP.



Re: Help with NTP


That is useful information. Thanks. One question: will it do it OK the other way. That is, if I have set my router as NTP master (not SNTP), can I get the Windows domain to synchronise from it?

Kevin Dorrell


Community Member

Re: Help with NTP

Yes. We use our Internet-facing router to acquire stratum 1 time, then our core switch acquires time from the router, and the rest of the network gets it from the core switch. Bottom line -- Cisco devices can play NTP among themselves with no problems.

CreatePlease to create content