Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help with one legged routing

I'm not sure what I'm doing wrong but I can't get my vlan routing to work with my subinterfaces on a 3550 switch. the port on the switch is configured like this:

interface FastEthernet0/21

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

the Router is set up like this from memory since I had to remove it and do it on to physical interfaces:

interface ethernet 0/1.2

ip address 192.168.1.254 255.255.255.0

encapsulation dot1q vlan 1

interface ethernet 0/1.1

ip address 10.17.1.254 255.255.0.0

encapsulation dot1q vlan 75

The PCs are also conntecting to ports that are configured as trunks because they're hanging off IP Phones. I'm going crazy with this so help would be really appreciated.

1 REPLY

Re: Help with one legged routing

Can you identify your dot1q native vlan on 3550? (sh int fa0/21 switchport) If it's 1 (by default) you don't need "encapsulation dot1q vlan 1" under e0/1.1 because dot1q doesn't encapsulate frames belonging to the native vlan. Instead you can delete subif e0/1.1 and write this ip address under physical interface e0/1 OR write "encapsulation dot1q 1 native" under e0/1.1 if your router IOS is 12.1(3)T or newer. Document below explains these issues:

http://www.cisco.com/en/US/tech/tk389/tk390/technologies_configuration_example09186a00800949fd.shtml

Regards.

109
Views
0
Helpful
1
Replies
CreatePlease login to create content