Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Help With PPP T1 lines and load-sharing and/or CEF

I have a 2620 router with 64MB of ram. We have 2 serial connections to 2- t1'swith ppp encapsulation. When thy set this up, they used equal cost routes like this:

0.0.0.0 0.0.0.0 serail0/0

0.0.0.0 0.0.0.0 serial0/1

----------------------------------

The problem: This gives us less bandwidth than even a T1. I tested this time and time again. When downloading the same file from the same server, it starts off at 300 + kb/s, but then rapidly declines to under 80 kb/s within a few seconds.

I tested the config by setting np encapsulation ppp, which effectively shut downb one of the lines, and sure enough, the download of the same file stuck at 177-181 kb/s the whole download (about right for a T1)

Its when 2 lines are on that this happens. XO, the provider says its our network. This is not true since these tests were made with a laptop directly into the router (crossover). So that totally eliminates the network being the culprit. Rather, i think the tech at XO who set up this router last yea had no idea wha he was doing.

We wish to hae a 3MB pipe down, and whatever we can uploaded (1.5-3MB)

Here is their config:

interface FastEthernet0/0

ip address 67.104.201.65 255.255.255.224

no ip directed-broadcast

no ip mroute-cache

speed 100

full-duplex

!

interface Serial0/0

ip address 67.104.201.18 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

!

interface Serial0/1

ip address 67.104.201.22 255.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0

ip route 0.0.0.0 0.0.0.0 Serial0/1

------------------------------------------------------

Is there a better way to do this? I am sure I have seen different way to acomplish this. They say they did everything right and honeslty will not even give me one of their standard configs. (I recomend never doing business with this company, XO)

If someone can please show me a better config, it would be greatly appreciated...

Thanks.

6 REPLIES

Re: Help With PPP T1 lines and load-sharing and/or CEF

Hi,

If these 2 t1s are going to same provider, try using this,

ip cef - global command

int s0/0

ip load-sharing per-packet

int s0/1

ip load-sharing per-packet.

New Member

Re: Help With PPP T1 lines and load-sharing and/or CEF

I tried this:

ip cef (global)

and ip load-sharing per-packet on each serial interface...

Same thing. No change. My download speeds are at 55 kb/s per second. With one line up, they are 178 kb/s per second.

Any other ideas? I am sure my router can handle 2 lines. It has 64MB of ram, and is only a year old.

Thanks

Re: Help With PPP T1 lines and load-sharing and/or CEF

In stead of checking with a single file transfer, can you test, the same scen, with multiple file transfers and check the throughput.

New Member

Re: Help With PPP T1 lines and load-sharing and/or CEF

It is the same thing...No difference. No matter how many files and where it is downloaded from. I try to use only servers that I know give me high speed downloads on the DSL or T1 out of the office (at a friends place).

I have tested this on and on. I try downloading. Measure throughput, and then turn off as line, and do the same with a matter of minutes. I even documented all of this to try and get XO communications to help me.

One question. Can I use a multilink ppp bundle? or bgp? It seems to me that CEF is not making a difference on this router.

If my lines are ppp encapsulated, then there should be no problem with the bundling, correct? Also, XO would need BGP on their end for me to use that, correct?

Its just so frustrating that XO will not even aknowledge my support tickets...I just opened another on Sunday.

Thanks for all your help!

Re: Help With PPP T1 lines and load-sharing and/or CEF

You can use ppp multilink on your links. BGP is not needed for this.

New Member

Re: Help With PPP T1 lines and load-sharing and/or CEF

If the other side supports PPP multilink then this is the way to go.

router#: config t

router(config): int multilink 1

router(config): ppp multilink

router(config): multilink group 1

router(config): ip address x.x.x.x x.x.x.x

Then on the serial interfaces:

router#: config t

router(config): int s0

router(config): ppp multilink

router(config): multilink group 1

router#: config t

router(config): int s1

router(config): ppp multilink

router(config): multilink group 1

Then:

router#: Config t

router(config): ip route 0.0.0.0 0.0.0.0 multilink1

This will put the two serial interfaces into a multilink group and send all traffic out this one virtual interface. Maybe the ISP is having problems getting the packets back in order on the other side.

Your ISP will need to support this because now the multilink will use only one IP address. The packets will need to be reordered on the other side as well.

Good luck! Sounds like you will need it.

102
Views
0
Helpful
6
Replies
CreatePlease to create content