Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Help with routing and DHCP

My problem is i can not for the life of me get my pc on the 2950 to grab a DHCP addy from the server. 2950 is on port gig0/1 on the 3550 adn is routed to 192.168.1.1 the dhcp server is a win2k box on the 5.0 net with addy 192.168.5.1. included is my configs. ANy help would be much appreciated.

2950

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Cat2950.1

!

enable secret 5 $1$o7qu$sLdauKCrn/lpyRICYgyit.

enable password xxxxx

!

ip subnet-zero

ip domain-name xxxxx.com

ip name-server 192.168.5.9

ip dhcp-server 192.168.5.1

!

spanning-tree extend system-id

!

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no ip address

!

interface FastEthernet0/3

no ip address

!

interface FastEthernet0/4

no ip address

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

no ip address

!

interface FastEthernet0/25

no ip address

!

interface FastEthernet0/26

no ip address

!

interface FastEthernet0/27

no ip address

!

interface FastEthernet0/28

no ip address

!

interface FastEthernet0/29

no ip address

!

interface FastEthernet0/30

no ip address

!

interface FastEthernet0/31

no ip address

!

interface FastEthernet0/32

no ip address

!

interface FastEthernet0/33

no ip address

!

interface FastEthernet0/34

no ip address

!

interface FastEthernet0/35

no ip address

!

interface FastEthernet0/36

no ip address

!

interface FastEthernet0/37

no ip address

!

interface FastEthernet0/38

no ip address

!

interface FastEthernet0/39

no ip address

!

interface FastEthernet0/40

no ip address

!

interface FastEthernet0/41

no ip address

!

interface FastEthernet0/42

no ip address

!

interface FastEthernet0/43

no ip address

!

interface FastEthernet0/44

no ip address

!

interface FastEthernet0/45

no ip address

!

interface FastEthernet0/46

no ip address

!

interface FastEthernet0/47

no ip address

!

interface FastEthernet0/48

no ip address

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address 192.168.1.22 255.255.255.0

ip helper-address 192.168.5.1

no ip route-cache

!

ip default-gateway 192.168.1.1

ip http server

!

!

line con 0

line vty 0 4

password xxxxxxx

login

line vty 5 15

password xxxxxxx

login

!

end

3550

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cat3550.1

!

aaa new-model

aaa authentication password-prompt Password:

aaa authentication username-prompt Username:

enable secret 5 $1$zIuX$yz1VwnKcfNVnIM7EUherP/

enable password 7 050C09062F4B5A0611001B1E

!

username root password 7 022E054D0E2721284F4B2D181C

ip subnet-zero

ip routing

ip domain-name sssnt.com

ip name-server 192.168.5.9

ip dhcp relay information option

!

ip dhcp-server 192.168.5.1

cluster enable Cisco 0

!

spanning-tree extend system-id

!

!

!

interface GigabitEthernet0/1

no switchport

ip address 192.168.1.1 255.255.255.0

ip helper-address 192.168.5.1

!

interface GigabitEthernet0/2

no ip address

!

interface GigabitEthernet0/3

no ip address

!

interface GigabitEthernet0/4

no ip address

!

interface GigabitEthernet0/5

no ip address

!

interface GigabitEthernet0/6

no ip address

!

interface GigabitEthernet0/7

no ip address

!

interface GigabitEthernet0/8

no ip address

!

interface GigabitEthernet0/9

no ip address

!

interface GigabitEthernet0/10

no ip address

!

interface GigabitEthernet0/11

no ip address

!

interface GigabitEthernet0/12

no ip address

!

interface Vlan1

ip address 192.168.5.22 255.255.255.0

ip helper-address 192.168.5.1

!

ip classless

ip default-network 192.168.5.0

ip default-network 0.0.0.0

ip http server

!

ip access-list extended CMP-NAT-ACL

dynamic Cluster-HSRP deny ip any any

dynamic Cluster-NAT permit ip any any

!

!

tftp-server flash

tftp-server flash c3550-i5q3l2-mz.121-11.EA1.bin

tftp-server system 1

!

line con 0

line vty 0 4

password 7 0118130F4E00070C2959

transport input ssh

line vty 5 15

password 7 030F4E001304204F461C

!

end

3 REPLIES
Community Member

Re: Help with routing and DHCP

I assume you've verified connectivity from the 2950 to the 3550?

Try configuring Spanning Tree PortFast on the end user ports on the 2950.

Otherwise your PC'll be looking for that DHCP server before the switch has opened the port as it transitions thru' Spanning Tree states.

Use either

spanning-tree portfast

on each FastEthernet interface on the 2950 or use

spanning-tree portfast default

in global config mode.

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat2950/12111ea1/scg/swstpopt.htm

Community Member

Re: Help with routing and DHCP

i have connectivity no problem. with static ip's the net is fine. I have also done a debug and it looks like the 3550 is forwarding to the correct win2k dhcp server. I have verified my dhcp superscope but it seems that the 3550 is either not receiving a response or is ignoring it.

Community Member

Re: Help with routing and DHCP

What is the effect of running ipconfig /renew after your host is up and running. In alot of cases the client has issued to dhcp request prior to the switch port being up and ready to forward (due to spanning tree states 'block, listen, learn). If your client can get an address after doing an ipconfig /renew then try setting the interface that the client is connected to 'spanning-tree portfast'. Do not use portfast setting on non-endstation systems like routers, hub or neighbor switches as this could cause stp loops. For end station interface config it should look like

!

interface FastEthernet0/3

no ip address

spanning-tree portfast

!

Hope this helps.

Regards,

Paul

90
Views
0
Helpful
3
Replies
CreatePlease to create content