Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

c.b
New Member

HELP

I have just had to re configure our 803 router due to changing ISP's. Ive taken the old routing config, changed the relevant ip's and DNS details and uploaded that config into the router. I am now able to ping the SADSL modem which is set as the next hop, however I cant get any furthur. The domain name servers are unreachable. It seems the modem is the only place I can get to.

I have tested the IP etc work by connecting a pc directly to the modem, bypassing the router. Everything seems fine..

Anyone know what Im doing wrong??

4 REPLIES

Re: HELP

You may need to post your config, the problem is likely to be in there somewhere. You stated that you set the ADSL-modem as next hop. This is likely to be wrong. Assign the route either to the interface or to the next-hop router's IP adress.

Goodluck

Leo

c.b
New Member

Re: HELP

Thanks Leo

Here is the config, the next hop is a router/sadsl modem. Ive been told by my ISP that this modem has been setup as the gateway to their side, unfortunatly Ive no control over the modem so dont know how its actually configured. However they tell me it is correct to have it as the next hop.

the config is:-

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

enable secret 5 **

!

!

!

!

!

!

ip subnet-zero

no ip source-route

no ip routing

!

ip name-server 203.134.**.**

ip name-server 203.134.**.**

no ip finger

!

!

!

interface Loopback0

no ip address

no ip proxy-arp

!

interface Loopback1

ip address 172.16.2.99 255.255.255.0

ip nat inside

ip policy route-map nat

!

interface Ethernet0

mac-address 0002.1762.b6ec

ip address 172.16.1.99 255.255.255.0 secondary

ip address 211.26.**.** 255.255.255.240

no ip redirects

no ip unreachables

ip nat outside

no cdp enable

!

interface BRI0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

no cdp enable

!

ip nat inside source list 1 interface Ethernet0 overload

ip nat inside source static tcp 172.16.1.41 80 211.26.**.** 80 extendable

ip nat inside source static tcp 172.16.1.41 25 211.26.**.** 25 extendable

ip nat inside source static tcp 172.16.1.41 53 211.26.**.** 53 extendable

ip nat inside source static udp 172.16.1.41 53 211.26.**.** 53 extendable

ip nat inside source static tcp 172.16.1.202 80 211.26.**.** 80 extendable

ip nat inside source static tcp 172.16.1.202 554 211.26.**.** 554 extendable

ip nat inside source static tcp 172.16.1.202 7070 211.26.**.** 7070 extendable

ip nat inside source static tcp 172.16.1.202 1220 211.26.**.** 1220 extendable

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Loopback1

!

access-list 1 permit 172.16.0.0 0.0.255.255

access-list 2 permit 202.72.**.**

access-list 2 permit 172.16.1.18

access-list 2 permit 172.16.1.14

access-list 2 permit 172.16.1.7

access-list 2 permit 211.26.3**.**

no cdp run

route-map nat permit 10

set ip next-hop 211.26.**.**

!

snmp-server community public RO

snmp-server community Info RO

snmp-server contact connie@core3d.com

snmp-server chassis-id JAD05300J9U

!

line con 0

password 7 **

login

transport input none

stopbits 1

line vty 0 4

access-class 2 in

exec-timeout 0 0

password 7 **

login

!

end

Re: HELP

I think you should apply the route-map "nat" on the inbound interface, ethernet 0 rather than at the loopback interface. Try reconfiguring the policy routing into the ethernet interface.

New Member

Re: HELP

c.b. - What is the make/model of your ADSL "modem/router"? It will have a network interface, which in turn will need to fit your IP address scheme. Did your ISP setup your LAN interface on the ADSL router with your 172.x.x.x? I just wonder if they setup your NAT correctly.

Bruce Davis, CCNA since 2003

102
Views
0
Helpful
4
Replies
CreatePlease to create content