Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

High CPU after start a debugging

Hi Guy`s,

I`ve a problem with a Cat6506. In the network is OSPF configured. There is only 1 area and around 20-25 networks. When I make a show proc cpu, is the utilization by not more as 3%. When I start a debugging, maybe debug ip opsf hellos, then is the utilization in few seconds by over 90%. I can`t see which process is the problem.

I hope anybody can help me

Thanks

Jens

6 REPLIES
Community Member

Re: High CPU after start a debugging

Jens,

Debigging is very CPU intensive. It's also the reason why it's recommended never to leave a debug turned on except while actually debugging.

High CPU utilization while debugging is normal and not a concern.

Hall of Fame Super Gold

Re: High CPU after start a debugging

I would say that debugging can be quite processor intensive but is not always processor intensive. It depends a lot on what you are debugging. And it depends somewhat on how you debug. There are some steps that can be taken to reduce the impact of debug. One possibility is to use debug with an access list to minimize the impact of the debug. For example "debug ip packet" is a debug that is likely to be very processor intensive since it must process and report on every packet that it sees. But "debug ip packet 199" where there is access-list 199 permit ip any host 172.16.1.1 will cause debug to restrict to traffic for that specific host and will make debug much less processor intensive. Other steps that can be taken include making sure that debug output does not go to the console (by default debug output does go to the console and does contribute to the impact of debug). If you eliminate debug output to the console and send debug output to terminal monitor or to logging buffered you will have reduced the impact of running debug.

HTH

Rick

Community Member

Re: High CPU after start a debugging

Hi Rick,

many thanks for the fast responds. I think the debugging "debug ip ospf hellos" is not to much for a Sup720. Under normal circumstance (without debugging) I have a problem with ping`s. I start a ping from my PC to this switch and few pings have a delay. Many replays are under 10ms but some replays have a responds time from 120ms.

thans

Jens

Hall of Fame Super Gold

Re: High CPU after start a debugging

Jens

I would agree that I would not think that debug ip ospf hello would put much stress on the processor, especially for a 720. When you do the ping is there any pattern that you can recognize in response times? (is the ping with longer response time a single packet or when one is slow are there several together that are slow? Does it seem to be every n number of packets or is it irregular?)

There might be several reasons for the variability of ping response times. One possibility is that some ping packets are taking a different (and slower) path through the network than others. My best guess at the cause of the variation is that responding to ping is a very low priority task in the switch operating system. If the switch is busy with some other task then it will delay responding to ping.

HTH

Rick

Community Member

Re: High CPU after start a debugging

Hi Rick,

the ping with a longer response time is a single packet and is irregular. I´ve my PC directly connected to the Sup720 and I have the same problem. The Cat6506 is not busy. Is it a hardware problem or a bug? I don`t no ;-)

thanks

Jens

Hall of Fame Super Gold

Re: High CPU after start a debugging

Jens

If the longer response is a single packet, is irregular, and if it happens for a PC directly connected (so we can rule out any network delay) then I believe that it is not likely to be a hardware problem nor a bug. I suspect that occasionally the switch delays responding to ping because responding is such a low priority task. The 6506 may not be very busy from your perspective, but without knowing how it is configured and what it is running it is hard to know what would cause a brief spike in processor busy. It might bery well be a spanning tree event, processing routing protocol updates, or some other system related task.

If you have an occasional ping packet with longer response time I do not believe that it necessarily indicates a problem on the switch. Remember that frame forwarding is a high priority task and is generally done in hardware while responding to ping is done in software processor and is a low priority task.

HTH

Rick

136
Views
9
Helpful
6
Replies
CreatePlease to create content