Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Host flapping during startup

Hi everybody,

I have a slight problem with host flapping.

First, let me give you an overview of (a part of) the network in question.

I have two 8 ports 2960 switches (C2960PD-8TT-L), both with five terminal client computers attached to them, connected via PoE to two ports of a 4503.

The configuration of the two ports on the 4503 switch is as follows:

Current configuration : 233 bytes
!
interface FastEthernet3/46
description to 2960 Switch1 G0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 88
switchport trunk allowed vlan 88,991
switchport mode trunk
switchport port-security maximum 3
end

!
interface FastEthernet3/47
  description to 2960 Switch2 G0/1
  switchport trunk encapsulation dot1q
  switchport trunk native vlan 88
  switchport trunk allowed vlan 88,991
  switchport mode trunk
  switchport port-security maximum 3
end

The configuration of the 2960 switches is as follows:

interface GigabitEthernet0/1
description to 4503 Switch1 F3/47
switchport trunk native vlan 88
switchport trunk allowed vlan 88,991
switchport mode trunk
end

!
interface FastEthernet0/1
description PC terminal
switchport access vlan 991
switchport mode access
no snmp trap link-status
no mdix auto
end

Rapid spanning-tree is enabled on all switches. There are no loops (the 2960 switches are connected with only 1 uplink to the 4503) anywhere.

=========

now my problem. The terminals connected to the 2960 switches are turned on every morning. Some terminals won't show the startup screen (no connection) but when you refresh, the connection is fine. The log of the 2960's show the following on april 7:

2960 Switch1:

nothing

2960 Switch2:

Apr  7 09:00:04.360 GMT+1: %SW_MATM-4-MACFLAP_NOTIF: Host 00e0.c549.0446 in vlan 991 is flapping between port Gi0/1 and port Fa0/5
Apr  7 09:00:04.628 GMT+1: %SW_MATM-4-MACFLAP_NOTIF: Host 00e0.c549.038b in vlan 991 is flapping between port Gi0/1 and port Fa0/1

4503:

Apr  7 09:00:09.871 GMT+1: %C4K_EBM-4-HOSTFLAPPING: Host 00:E0:C5:49:04:46 in vlan 991 is flapping between port Fa3/46 and port Fa3/47
Apr  7 09:00:11.027 GMT+1: %C4K_EBM-4-HOSTFLAPPING: Host 00:E0:C5:49:03:8B in vlan 991 is flapping between port Fa3/46 and port Fa3/47

-------- April 8--------

2960 Switch1:

Apr  8 09:02:39.168 GMT+1: %SW_MATM-4-MACFLAP_NOTIF: Host 00e0.c549.0431 in vlan 991 is flapping between port Gi0/1 and port Fa0/5

2960 Switch2:

Apr  8 09:02:39.445 GMT+1: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to down
Apr  8 09:02:42.465 GMT+1: %SW_MATM-4-MACFLAP_NOTIF: Host 00e0.c549.0431 in vlan 991 is flapping between port Fa0/5 and port Gi0/1
Apr  8 09:02:42.926 GMT+1: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
Apr  8 09:02:43.530 GMT+1: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up

4503:

Nothing

MAC 00e0.c549.0446 is physically connected to 2960 switch2, Fa 0/5 and the MAC address table on 2960 Switch 1 shows the address on Gi 0/1 (which is correct).

So, can someone explain to me why I see these flapping messages wihtout loops of etherchannels or whatsoever? Just simple access ports over single trunks?

Any help is much appreciated.

Thanks,

Ian

4 REPLIES
New Member

Re: Host flapping during startup

Hi

I had faced same problem with our setup.

What i observed was we are having connectivity of servers to both the switches.

That is server is having two lan cards and from those lan cards cables are connected

to two switches.

Now server team have configured link aggregation from server end which is not same as etherchannel.

We were getting same message of host flapping ( port connected to one switch and through trunk where other switch is connected )

We have asked them to configure lacp for both links and from our end we have configured port-channel on single switch.

They were having two more ports free on server....so we have configured those prots in port channel on other switch

Thus redundancy is also maintained

Hope this works

Vaishali

Re: Host flapping during startup

Hi everybody,

I have a slight problem with host flapping.

First, let me give you an overview of (a part of) the network in question.

I have two 8 ports 2960 switches (C2960PD-8TT-L), both with five terminal client computers attached to them, connected via PoE to two ports of a 4503.

The configuration of the two ports on the 4503 switch is as follows:

Current configuration : 233 bytes
!
interface FastEthernet3/46
description to 2960 Switch1 G0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 88
switchport trunk allowed vlan 88,991
switchport mode trunk
switchport port-security maximum 3
end

!
interface FastEthernet3/47
  description to 2960 Switch2 G0/1
  switchport trunk encapsulation dot1q

Hi Ian,

The problem of Mac flapping between the ports in switches can be due to network switches for misconfigurations that might cause a data-forwarding loop


- It could be a wrong setup
- It could be resolved by disabling unused NIC cards in the servers connected 
  to the switch could fix the problem of MAC address Flapping.
- It could resolve by bad Hardware replacement(switch).


and more specifically check the e server providers to see if the OS and server platform support 'NIC' Teaming (NIC Bonding).

FYI - NIC teaming allows users to group two or more physical NICs into a single logical network device called a bond. Once a logical NIC is configured, the virtual machine is not aware of the underlying physical NICs. Packets sent to the logical NIC are dispatched to one of the physical NICs in the bond and packets arriving at any of the physical NICs are automatically directed to the appropriate logical NIC.


If one of the underlying physical NICs is broken or its cable has been unplugged, server will detect the fault condition and automatically move traffic to another NIC in the bond. This capability eliminates a single point of failure for any one physical NIC and makes the overall network connection fault-tolerant.

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

New Member

Re: Host flapping during startup

Thanks both for you replies.

The thing is: there are no loops in that part of the network. It's just a couple of cascaded switches. The last switch has the two smaller 2960 PoE powered switches attached to them. Attached to those switches are the client PC's. All those PC's are connected with only one NIC to one of the small switches.

Any ideas?

New Member

Re: Host flapping during startup

Certainly I can try to put fiew of my views.

Do you have your observation or thinking besides the output you shared?

With regards,

Shailesh Hardas

1162
Views
8
Helpful
4
Replies
CreatePlease to create content