Cisco Support Community
Community Member

how can i retrieve the status of the priority queue count on cat6500?

Hello everyone.

I have deplolyed qos on cat6500 to classfy with voip and video.

But i can't find command which traffics into priority queue on cat6500.

here is the configuration.

Coulde you please tell me the way how can i see the packets which was sent to priority queue?



class-map match-all voicedata

match access-group name voice


class-map match-all videodata

match access-group name video


class-map match-all multi

match access-group name multicast-1



policy-map voicemark

class voicedata

set dscp ef


policy-map videomark

class videodata

set dscp af41


policy-map multimark

class multi

set dscp af31



interface GigabitEthernet7/1

description << WAN Line >>

no ip address

mls qos trust cos


switchport trunk encapsulation dot1q

switchport mode trunk


int gi 7/1

priority-queue cos-map 1 5



ip access-list extended voice

permit ip host any

ip access-list extended video

permit udp any any range 16384 32767

permit ip host any

ip access-list extended multicast-1

permit ip any host


Re: how can i retrieve the status of the priority queue count on

I dont think there is a specific command for priority queuing alone.But in general ,for any type of queuing, to view the queue type and so on, use the following comnmand.

show queueing interface {{interface interface-number} | {null interface-number} | {vlan vlan-id}}

Syntax Description


Interface type; possible valid values are ethernet, fastethernet, gigabitethernet, tengigabitethernet, pos, atm, and ge-wan.


Module and port number; see the "Usage Guidelines" section for valid values.

null interface-number

Specifies the null interface; the valid value is 0.

vlan vlan-id

Specifies the VLAN ID; valid values are from 1 to 4094.


This command has no default settings.

Command Modes


The pos, atm, and ge-wan keywords are supported on Catalyst 6500 series switches that are configured with a Supervisor Engine 2 only.

The interface-number argument designates the module and port number. Valid values for interface-number depend on the specified interface type and the chassis and module that are used.

The show queueing interface command does not display the absolute values that are programmed in the hardware. Enter the show qm-sp port-data command to verify the values that are programmed in the hardware

CreatePlease to create content