Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How do I add VLANs to switch with native VLAN(not VLAN1)

I am not too sure how to ask this question.

I intend to add some ports of an edge switch to another VLAN, right now the edge switch has only one VLAN(e.g.105) configured as native VLAN.

the edge switch is trunk to the core switch, however, I can see only one native VLAN(e.g.105) allowed on the VTP domain, although the trunk allowed 1-1005 VLANs.

pls see below:

6509-5th-SW1 (enable) sh port trunk 3/2

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

3/2 auto negotiate not-trunking 105

Port Vlans allowed on trunk

-------- ---------------------------------------------------------------------

3/2 1-1005

Port Vlans allowed and active in management domain

-------- ---------------------------------------------------------------------

3/2 105

Port Vlans in spanning tree forwarding state and not pruned

-------- ---------------------------------------------------------------------

3/2

Question: How do I configure other VLANs on the switch and add port to it?

6509-5th-SW1 (enable) sh port trunk 3/4

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

3/4 auto negotiate not-trunking 111

Port Vlans allowed on trunk

-------- ---------------------------------------------------------------------

3/4 1-1005

Port Vlans allowed and active in management domain

-------- ---------------------------------------------------------------------

3/4 111

Port Vlans in spanning tree forwarding state and not pruned

-------- ---------------------------------------------------------------------

3/4

6509-5th-SW1 (enable) sh spantree 3/2

Port Vlan Port-State Cost Priority Portfast Channel_id

------------------------ ---- ------------- ----- -------- ---------- ----------

3/2 105 forwarding 4 2 disabled 0

6509-5th-SW1 (enable) sh spantree 3/4

Port Vlan Port-State Cost Priority Portfast Channel_id

------------------------ ---- ------------- ----- -------- ---------- ----------

3/4 111 forwarding 4 2 disabled 0

CORE SWITCH Configuration:

............

..

begin

!

#version 5.3(1a)CSX

!

set password $1$6VNt$eFbGaZITdcN3n0MO/QpLP1

set enablepass $1$fCG/$3UNDnTY5WMHVMK/SWh2AP.

set prompt 6509-5th-SW1

set length 24 default

set logout 20

set banner motd ^C^C

!

#system

set system baud 9600

set system modem enable

set system name 6509-5th-SW1

set system location 5th Floor ENV Building

set system contact Joe Low

!

#power

set power redundancy enable

!

#frame distribution method

set port channel all distribution ip both

!

#snmp

set snmp community read-only sparrow

set snmp community read-write burung

set snmp community read-write-all secret

set snmp rmon enable

set snmp trap enable module

set snmp trap enable chassis

set snmp trap enable repeater

set snmp trap enable vtp

set snmp trap enable auth

set snmp trap enable ippermit

set snmp trap enable vmps

set snmp trap enable entity

set snmp trap enable config

set snmp trap enable syslog

set snmp trap enable stpx

set snmp trap 10.213.100.133 sparrow

!

#tacacs+

set tacacs attempts 3

set tacacs directedrequest disable

!

#radius

set radius deadtime 0

set radius timeout 5

set radius retransmit 2

!

#authentication

set authentication login tacacs disable console

set authentication login tacacs disable telnet

set authentication enable tacacs disable console

set authentication enable tacacs disable telnet

set authentication login radius disable console

set authentication login radius disable telnet

set authentication enable radius disable console

set authentication enable radius disable telnet

set authentication login local enable console

set authentication login local enable telnet

set authentication enable local enable console

set authentication enable local enable telnet

!

#vtp

set vtp domain MOE

set vtp mode server

set vtp v2 disable

set vtp pruning disable

set vtp pruneeligible 2-1000

clear vtp pruneeligible 1001-1005

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 5 name VLAN0005 type ethernet mtu 1500 said 100005 state active

set vlan 6 name SW3toSW4 type ethernet mtu 1500 said 100006 state active

set vlan 55 name SW1toSW4 type ethernet mtu 1500 said 100055 state active

set vlan 56 name SW2toSW3 type ethernet mtu 1500 said 100056 state active

set vlan 97 name ACE_AS5300 type ethernet mtu 1500 said 100097 state active

set vlan 98 name FTP type ethernet mtu 1500 said 100098 state active

set vlan 99 name AUTO_CAD type ethernet mtu 1500 said 100099 state active

set vlan 103 name VLAN0103 type ethernet mtu 1500 said 100103 state active

set vlan 104 name VLAN0104 type ethernet mtu 1500 said 100104 state active

set vlan 105 name VLAN0105 type ethernet mtu 1500 said 100105 state active

set vlan 106 name VLAN0106 type ethernet mtu 1500 said 100106 state active

set vlan 107 name VLAN0107 type ethernet mtu 1500 said 100107 state active

set vlan 108 name VLAN0108 type ethernet mtu 1500 said 100108 state active

set vlan 109 name VLAN0109 type ethernet mtu 1500 said 100109 state active

set vlan 110 name VLAN0110 type ethernet mtu 1500 said 100110 state active

set vlan 111 name VLAN0111 type ethernet mtu 1500 said 100111 state active

set vlan 112 name VLAN0112 type ethernet mtu 1500 said 100112 state active

set vlan 113 name VLAN0113 type ethernet mtu 1500 said 100113 state active

set vlan 114 name VLAN0114 type ethernet mtu 1500 said 100114 state active

set vlan 115 name VLAN0115 type ethernet mtu 1500 said 100115 state active

set vlan 116 name VLAN0116 type ethernet mtu 1500 said 100116 state active

set vlan 117 name VLAN0117 type ethernet mtu 1500 said 100117 state active

set vlan 118 name VLAN0118 type ethernet mtu 1500 said 100118 state active

set vlan 119 name VLAN0119 type ethernet mtu 1500 said 100119 state active

set vlan 120 name VLAN0120 type ethernet mtu 1500 said 100120 state active

set vlan 121 name VLAN0121 type ethernet mtu 1500 said 100121 state active

set vlan 122 name VLAN0122 type ethernet mtu 1500 said 100122 state active

set vlan 123 name VLAN0123 type ethernet mtu 1500 said 100123 state active

set vlan 124 name VLAN0124 type ethernet mtu 1500 said 100124 state active

set vlan 125 name VLAN0125 type ethernet mtu 1500 said 100125 state active

set vlan 200 name VLAN0200 type ethernet mtu 1500 said 100200 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state activ

e bridge 0x1 stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active br

idge 0x1 stp ibm

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti

ve parent 0 ring 0x0 mode srb aremaxhop 0 stemaxhop 0

!

#ip

set interface sc0 1 10.213.100.6/255.255.255.0 10.213.100.255

set interface sc0 up

set interface sl0 0.0.0.0 0.0.0.0

set interface sl0 up

set arp agingtime 1200

set ip redirect enable

set ip unreachable enable

set ip fragmentation enable

set ip route 0.0.0.0/0.0.0.0 10.213.100.1 1

set ip alias default 0.0.0.0

!

#Command alias

!

#vmps

set vmps server retry 3

set vmps server reconfirminterval 60

!

#dns

set ip dns disable

!

#spantree

#uplinkfast groups

set spantree uplinkfast disable

#backbonefast

set spantree backbonefast disable

#vlan 1

set spantree enable 1

set spantree fwddelay 15 1

set spantree hello 2 1

set spantree maxage 20 1

set spantree priority 8192 1

#vlan 5

set spantree enable 5

set spantree fwddelay 15 5

set spantree hello 2 5

set spantree maxage 20 5

set spantree priority 32768 5

#vlan 6

set spantree enable 6

set spantree fwddelay 15 6

set spantree hello 2 6

set spantree maxage 20 6

set spantree priority 32768 6

#vlan 55

set spantree enable 55

set spantree fwddelay 15 55

set spantree hello 2 55

set spantree maxage 20 55

set spantree priority 32768 55

#vlan 56

set spantree enable 56

set spantree fwddelay 15 56

set spantree hello 2 56

set spantree maxage 20 56

set spantree priority 32768 56

#vlan 97

set spantree enable 97

set spantree fwddelay 15 97

set spantree hello 2 97

set spantree maxage 20 97

set spantree priority 32768 97

#vlan 98

set spantree enable 98

set spantree fwddelay 15 98

set spantree hello 2 98

set spantree maxage 20 98

set spantree priority 32768 98

#vlan 99

set spantree enable 99

set spantree fwddelay 15 99

set spantree hello 2 99

set spantree maxage 20 99

set spantree priority 32768 99

#vlan 103

set spantree enable 103

set spantree fwddelay 15 103

set spantree hello 2 103

set spantree maxage 20 103

set spantree priority 8192 103

#vlan 104

set spantree enable 104

set spantree fwddelay 15 104

set spantree hello 2 104

set spantree maxage 20 104

set spantree priority 8192 104

#vlan 105

set spantree enable 105

set spantree fwddelay 15 105

set spantree hello 2 105

set spantree maxage 20 105

set spantree priority 1 105

#vlan 106

set spantree enable 106

set spantree fwddelay 15 106

set spantree hello 2 106

set spantree maxage 20 106

set spantree priority 8192 106

#vlan 107

set spantree enable 107

set spantree fwddelay 15 107

set spantree hello 2 107

set spantree maxage 20 107

set spantree priority 32768 107

#vlan 108

set spantree enable 108

set spantree fwddelay 15 108

set spantree hello 2 108

set spantree maxage 20 108

set spantree priority 32768 108

#vlan 109

set spantree enable 109

set spantree fwddelay 15 109

set spantree hello 2 109

set spantree maxage 20 109

set spantree priority 32768 109

#vlan 110

set spantree enable 110

set spantree fwddelay 15 110

set spantree hello 2 110

set spantree maxage 20 110

set spantree priority 32768 110

#vlan 111

set spantree enable 111

set spantree fwddelay 15 111

set spantree hello 2 111

set spantree maxage 20 111

set spantree priority 1 111

#vlan 112

set spantree enable 112

set spantree fwddelay 15 112

set spantree hello 2 112

set spantree maxage 20 112

set spantree priority 32768 112

#vlan 113

set spantree enable 113

set spantree fwddelay 15 113

set spantree hello 2 113

set spantree maxage 20 113

set spantree priority 32768 113

#vlan 114

set spantree enable 114

set spantree fwddelay 15 114

set spantree hello 2 114

set spantree maxage 20 114

set spantree priority 32768 114

#vlan 115

set spantree enable 115

set spantree fwddelay 15 115

set spantree hello 2 115

set spantree maxage 20 115

set spantree priority 32768 115

#vlan 116

set spantree enable 116

set spantree fwddelay 15 116

set spantree hello 2 116

set spantree maxage 20 116

set spantree priority 32768 116

#vlan 117

set spantree enable 117

set spantree fwddelay 15 117

set spantree hello 2 117

set spantree maxage 20 117

set spantree priority 32768 117

#vlan 118

set spantree enable 118

set spantree fwddelay 15 118

set spantree hello 2 118

set spantree maxage 20 118

set spantree priority 32768 118

#vlan 119

set spantree enable 119

set spantree fwddelay 15 119

set spantree hello 2 119

set spantree maxage 20 119

set spantree priority 1 119

#vlan 120

set spantree enable 120

set spantree fwddelay 15 120

set spantree hello 2 120

set spantree maxage 20 120

set spantree priority 1 120

#vlan 121

set spantree enable 121

set spantree fwddelay 15 121

set spantree hello 2 121

set spantree maxage 20 121

set spantree priority 1 121

#vlan 122

set spantree enable 122

set spantree fwddelay 15 122

set spantree hello 2 122

set spantree maxage 20 122

set spantree priority 1 122

#vlan 123

set spantree enable 123

set spantree fwddelay 15 123

set spantree hello 2 123

set spantree maxage 20 123

set spantree priority 1 123

#vlan 124

set spantree enable 124

set spantree fwddelay 15 124

set spantree hello 2 124

set spantree maxage 20 124

set spantree priority 1 124

#vlan 125

set spantree enable 125

set spantree fwddelay 15 125

set spantree hello 2 125

set spantree maxage 20 125

set spantree priority 32768 125

#vlan 200

set spantree enable 200

set spantree fwddelay 15 200

set spantree hello 2 200

set spantree maxage 20 200

set spantree priority 32768 200

#vlan 1003

set spantree enable 1003

set spantree fwddelay 15 1003

set spantree hello 2 1003

set spantree maxage 20 1003

set spantree priority 32768 1003

#vlan 1005

set spantree disable 1005

set spantree fwddelay 15 1005

set spantree hello 2 1005

set spantree maxage 20 1005

set spantree priority 32768 1005

!

#syslog

set logging console enable

set logging server enable

set logging server 10.213.100.52

set logging server 10.213.105.52

set logging server 10.213.100.124

set logging level cdp 4 default

set logging level mcast 2 default

set logging level dtp 5 default

set logging level dvlan 2 default

set logging level earl 2 default

set logging level ip 2 default

set logging level pruning 2 default

set logging level snmp 2 default

set logging level spantree 2 default

set logging level sys 5 default

set logging level tac 2 default

set logging level tcp 2 default

set logging level telnet 2 default

set logging level tftp 2 default

set logging level vtp 2 default

set logging level kernel 2 default

set logging level filesys 2 default

set logging level pagp 5 default

set logging level mgmt 5 default

set logging level mls 5 default

set logging level protfilt 2 default

set logging level security 2 default

set logging level radius 2 default

set logging level udld 4 default

set logging level gvrp 2 default

set logging level cops 2 default

set logging level qos 2 default

set logging level acl 2 default

set logging server facility LOCAL7

set logging server severity 7

set logging buffer 500

set logging timestamp enable

!

#ntp

set ntp broadcastclient disable

set ntp broadcastdelay 3000

set ntp client enable

set ntp server 10.213.105.2

clear timezone

set summertime disable

!

#set boot command

set boot config-register 0x2102

set boot system flash bootflash:cat6000-sup.5-3-1a-CSX.bin

!

#permit list

set ip permit disable

!

#igmp

set igmp disable

!

#protocolfilter

set protocolfilter disable

!

#mls

set mls agingtime 256

set mls agingtime fast 0 0

set mls flow destination

set mls nde version 7

set mls nde disable

!

#qos

set qos disable

set qos drop-threshold 1q4t rx queue 1 50 60 80 100

set qos map 2q2t tx 1 1 cos 0

set qos map 2q2t tx 1 1 cos 1

set qos map 2q2t tx 1 2 cos 2

set qos map 2q2t tx 1 2 cos 3

set qos map 2q2t tx 2 1 cos 4

set qos map 2q2t tx 2 1 cos 5

set qos map 2q2t tx 2 2 cos 6

set qos map 2q2t tx 2 2 cos 7

set qos drop-threshold 2q2t tx queue 1 80 100

set qos drop-threshold 2q2t tx queue 2 80 100

set qos wrr 2q2t 5 255

set qos txq-ratio 2q2t 80 20

set qos map 1p1q4t rx 1 1 cos 0

set qos map 1p1q4t rx 1 1 cos 1

set qos map 1p1q4t rx 1 2 cos 2

set qos map 1p1q4t rx 1 2 cos 3

set qos map 1p1q4t rx 1 3 cos 4

set qos map 1p1q4t rx 1 3 cos 5

set qos map 1p1q4t rx 2 1 cos 6

set qos map 1p1q4t rx 1 4 cos 7

set qos drop-threshold 1p1q4t rx queue 1 50 60 80 100

set qos map 1p2q2t tx 1 1 cos 0

set qos map 1p2q2t tx 1 1 cos 1

set qos map 1p2q2t tx 1 2 cos 2

set qos map 1p2q2t tx 1 2 cos 3

set qos map 1p2q2t tx 2 1 cos 4

set qos map 1p2q2t tx 2 1 cos 5

set qos map 1p2q2t tx 3 1 cos 6

set qos map 1p2q2t tx 2 2 cos 7

set qos wred 1p2q2t tx queue 1 80 100

set qos wred 1p2q2t tx queue 2 80 100

set qos wrr 1p2q2t 5 255

set qos txq-ratio 1p2q2t 70 15 15

set qos bridged-microflow-policing disable 1-1000

set qos cos-dscp-map 0 8 16 24 32 40 48 56

set qos ipprec-dscp-map 0 8 16 24 32 40 48 56

set qos dscp-cos-map 0-7:0

set qos dscp-cos-map 8-15:1

set qos dscp-cos-map 16-23:2

set qos dscp-cos-map 24-31:3

set qos dscp-cos-map 32-39:4

set qos dscp-cos-map 40-47:5

set qos dscp-cos-map 48-55:6

set qos dscp-cos-map 56-63:7

set qos policed-dscp-map 0:0

set qos policed-dscp-map 1:1

set qos policed-dscp-map 2:2

set qos policed-dscp-map 3:3

set qos policed-dscp-map 4:4

set qos policed-dscp-map 5:5

set qos policed-dscp-map 6:6

set qos policed-dscp-map 7:7

set qos policed-dscp-map 8:8

set qos policed-dscp-map 9:9

set qos policed-dscp-map 10:10

set qos policed-dscp-map 11:11

set qos policed-dscp-map 12:12

set qos policed-dscp-map 13:13

set qos policed-dscp-map 14:14

set qos policed-dscp-map 15:15

set qos policed-dscp-map 16:16

set qos policed-dscp-map 17:17

set qos policed-dscp-map 18:18

set qos policed-dscp-map 19:19

set qos policed-dscp-map 20:20

set qos policed-dscp-map 21:21

set qos policed-dscp-map 22:22

set qos policed-dscp-map 23:23

set qos policed-dscp-map 24:24

set qos policed-dscp-map 25:25

set qos policed-dscp-map 26:26

set qos policed-dscp-map 27:27

set qos policed-dscp-map 28:28

set qos policed-dscp-map 29:29

set qos policed-dscp-map 30:30

set qos policed-dscp-map 31:31

set qos policed-dscp-map 32:32

set qos policed-dscp-map 33:33

set qos policed-dscp-map 34:34

set qos policed-dscp-map 35:35

set qos policed-dscp-map 36:36

set qos policed-dscp-map 37:37

set qos policed-dscp-map 38:38

set qos policed-dscp-map 39:39

set qos policed-dscp-map 40:40

set qos policed-dscp-map 41:41

set qos policed-dscp-map 42:42

set qos policed-dscp-map 43:43

set qos policed-dscp-map 44:44

set qos policed-dscp-map 45:45

set qos policed-dscp-map 46:46

set qos policed-dscp-map 47:47

set qos policed-dscp-map 48:48

set qos policed-dscp-map 49:49

set qos policed-dscp-map 50:50

set qos policed-dscp-map 51:51

set qos policed-dscp-map 52:52

set qos policed-dscp-map 53:53

set qos policed-dscp-map 54:54

set qos policed-dscp-map 55:55

set qos policed-dscp-map 56:56

set qos policed-dscp-map 57:57

set qos policed-dscp-map 58:58

set qos policed-dscp-map 59:59

set qos policed-dscp-map 60:60

set qos policed-dscp-map 61:61

set qos policed-dscp-map 62:62

set qos policed-dscp-map 63:63

set qos acl default-action ip dscp 0

set qos acl default-action ipx dscp 0

set qos acl default-action mac dscp 0

set qos policy-source local

set cops retry-interval 30 30 300

set qos rsvp disable

set qos rsvp policy-timeout 30

set qos rsvp local-policy forward

!

#vlan mapping

!

#gmrp

set gmrp disable

!

#garp

set garp timer join 200

set garp timer leave 600

set garp timer leaveall 10000

!

#CDP

set cdp interval 60

set cdp holdtime 180

set cdp enable

!

#UDLD

set udld disable

!

#Port Channel

set port channel 2/5-8 74

set port channel 3/1-4 75

set port channel 3/5-8 76

set port channel 4/1-4 77

set port channel 4/5-8 78

set port channel 1/1-2 128

set port channel 2/3-4 130

set port channel 2/1-2 174

!

#Security ACLs

clear security acl all

commit security acl all

!

#Local Director Acceleration

set lda disable

!

#module 1 : 2-port 1000BaseX Supervisor

set module name 1

set vlan 5 1/1-2

set port enable 1/1-2

set port trap 1/1-2 enable

set port name 1/1-2

set port security 1/1-2 disable

set port broadcast 1/1-2 100%

set port membership 1/1-2 static

set port protocol 1/1-2 ip on

set port protocol 1/1-2 ipx auto

set port protocol 1/1-2 group auto

set port negotiation 1/1-2 enable

set port flowcontrol 1/1-2 send desired

set port flowcontrol 1/1-2 receive off

set cdp enable 1/1-2

set udld enable 1/1-2

set trunk 1/1 on dot1q 1-1005

set trunk 1/2 on dot1q 1-1005

set spantree portfast 1/1-2 disable

set spantree portcost 1/1-2 4

set spantree portpri 1/1-2 32

set spantree portvlanpri 1/1 0

set spantree portvlanpri 1/2 0

set spantree portvlancost 1/1 cost 3

set spantree portvlancost 1/2 cost 3

set port qos 1/1-2 cos 0

set port qos 1/1-2 trust untrusted

set port qos 1/1-2 port-based

set port qos 1/1-2 policy-source cops

set port rsvp 1/1-2 dsbm-election disable 128

set port gvrp 1/1-2 disable

set gvrp registration normal 1/1-2

set gvrp applicant normal 1/1-2

set port gmrp 1/1-2 enable

set gmrp registration normal 1/1-2

set gmrp fwdall disable 1/1-2

set port channel 1/1-2 mode on

set port jumbo 1/1 disable

set port jumbo 1/2 disable

!

#module 2 : 8-port 1000BaseX Ethernet

set module name 2

set module enable 2

set vlan 1 2/1-2,2/5-8

set vlan 5 2/3-4

set port enable 2/1-8

set port trap 2/1-8 enable

set port name 2/5 5thFloor 4912 Seg100

set port name 2/6 4912 spare

set port name 2/7 100Seg 3524-1

set port name 2/8 100Seg 3524-2

set port name 2/1-4

set port security 2/1-8 disable

set port broadcast 2/1-8 100%

set port membership 2/1-8 static

set port protocol 2/1-8 ip on

set port protocol 2/1-8 ipx auto

set port protocol 2/1-8 group auto

set port negotiation 2/1-8 enable

set port flowcontrol 2/1-8 send desired

set port flowcontrol 2/1-8 receive off

set cdp enable 2/1-8

set udld enable 2/1-5,2/7-8

set udld disable 2/6

set trunk 2/1 on dot1q 1-1005

set trunk 2/2 on dot1q 1-1005

set trunk 2/3 on dot1q 1-1005

set trunk 2/4 on dot1q 1-1005

set trunk 2/5 auto negotiate 1-1005

set trunk 2/6 auto negotiate 1-1005

set trunk 2/7 auto negotiate 1-1005

set trunk 2/8 auto negotiate 1-1005

set spantree portfast 2/1-8 disable

set spantree portcost 2/1-8 4

set spantree portpri 2/5-8 32

set spantree portpri 2/1-4 60

set spantree portvlanpri 2/1 0

set spantree portvlanpri 2/2 0

set spantree portvlanpri 2/3 0

set spantree portvlanpri 2/4 0

set spantree portvlanpri 2/5 0

set spantree portvlanpri 2/6 0

set spantree portvlanpri 2/7 0

set spantree portvlanpri 2/8 0

set spantree portvlancost 2/1 cost 3

set spantree portvlancost 2/2 cost 3

set spantree portvlancost 2/3 cost 3

set spantree portvlancost 2/4 cost 3

set spantree portvlancost 2/5 cost 3

set spantree portvlancost 2/6 cost 3

set spantree portvlancost 2/7 cost 3

set spantree portvlancost 2/8 cost 3

set port qos 2/1-8 cos 0

set port qos 2/1-8 trust untrusted

set port qos 2/1-8 port-based

set port qos 2/1-8 policy-source cops

set port rsvp 2/1-8 dsbm-election disable 128

set port gvrp 2/1-8 disable

set gvrp registration normal 2/1-8

set gvrp applicant normal 2/1-8

set port gmrp 2/1-8 enable

set gmrp registration normal 2/1-8

set gmrp fwdall disable 2/1-8

set port channel 2/1-4 mode on

set port channel 2/5-8 mode auto silent

set port jumbo 2/1 disable

set port jumbo 2/2 disable

set port jumbo 2/3 disable

set port jumbo 2/4 disable

set port jumbo 2/5 disable

set port jumbo 2/6 disable

set port jumbo 2/7 disable

set port jumbo 2/8 disable

!

#module 3 : 8-port 1000BaseX Ethernet

set module name 3

set module enable 3

set vlan 104 3/1

set vlan 105 3/2

set vlan 106 3/3

set vlan 111 3/4

set vlan 119 3/5

set vlan 120 3/6

set vlan 121 3/7

set vlan 122 3/8

set port enable 3/1-8

set port trap 3/1-8 enable

set port name 3/1 Segment 104

set port name 3/2 5thFloor Segment

set port name 3/3 6thFloor Seg106

set port name 3/4 11thFloor Seg111

set port name 3/5 19thFloor Seg119

set port name 3/6 20thFloor Seg120

set port name 3/7 21thFloor Seg121

set port name 3/8 22ndFloor Seg122

set port security 3/1-8 disable

set port broadcast 3/1-8 100%

set port membership 3/1-8 static

set port protocol 3/1-8 ip on

set port protocol 3/1-8 ipx auto

set port protocol 3/1-8 group auto

set port negotiation 3/1-8 enable

set port flowcontrol 3/1-8 send desired

set port flowcontrol 3/1-8 receive off

set cdp enable 3/1-8

set udld enable 3/1-8

set trunk 3/1 auto negotiate 1-1005

set trunk 3/2 auto negotiate 1-1005

set trunk 3/3 auto negotiate 1-1005

set trunk 3/4 auto negotiate 1-1005

set trunk 3/5 auto negotiate 1-1005

set trunk 3/6 auto negotiate 1-1005

set trunk 3/7 auto negotiate 1-1005

set trunk 3/8 auto negotiate 1-1005

set spantree portfast 3/1-8 disable

set spantree portcost 3/1-8 4

set spantree portpri 3/1-8 2

set spantree portvlanpri 3/1 1

set spantree portvlanpri 3/2 0

set spantree portvlanpri 3/3 0

set spantree portvlanpri 3/4 0

set spantree portvlanpri 3/5 0

set spantree portvlanpri 3/6 0

set spantree portvlanpri 3/7 0

set spantree portvlanpri 3/8 0

set spantree portvlancost 3/1 cost 3

set spantree portvlancost 3/2 cost 3

set spantree portvlancost 3/3 cost 3

set spantree portvlancost 3/4 cost 3

set spantree portvlancost 3/5 cost 3

set spantree portvlancost 3/6 cost 3

set spantree portvlancost 3/7 cost 3

set spantree portvlancost 3/8 cost 3

set port qos 3/1-8 cos 0

set port qos 3/1-8 trust untrusted

set port qos 3/1-8 port-based

set port qos 3/1-8 policy-source cops

set port rsvp 3/1-8 dsbm-election disable 128

set port gvrp 3/1-8 disable

set gvrp registration normal 3/1-8

set gvrp applicant normal 3/1-8

set port gmrp 3/1-8 enable

set gmrp registration normal 3/1-8

set gmrp fwdall disable 3/1-8

set port channel 3/1-8 mode auto silent

set port jumbo 3/1 disable

set port jumbo 3/2 disable

set port jumbo 3/3 disable

set port jumbo 3/4 disable

set port jumbo 3/5 disable

set port jumbo 3/6 disable

set port jumbo 3/7 disable

set port jumbo 3/8 disable

!

#module 4 : 8-port 1000BaseX Ethernet

set module name 4

set module enable 4

set vlan 1 4/4-8

set vlan 103 4/3

set vlan 123 4/1

set vlan 124 4/2

set port enable 4/1-8

set port trap 4/1-8 enable

set port name 4/1 23ndFloor Seg123

set port name 4/2 24thFloor Seg124

set port name 4/3 Annex Seg103

set port name 4/4-8

set port security 4/1-8 disable

set port broadcast 4/1-8 100%

set port membership 4/1-8 static

set port protocol 4/1-8 ip on

set port protocol 4/1-8 ipx auto

set port protocol 4/1-8 group auto

set port negotiation 4/1-8 enable

set port flowcontrol 4/1-8 send desired

set port flowcontrol 4/1-8 receive off

set cdp enable 4/1-8

set udld enable 4/1-3

set udld disable 4/4-8

set trunk 4/1 auto negotiate 1-1005

set trunk 4/2 auto negotiate 1-1005

set trunk 4/3 auto negotiate 1-1005

set trunk 4/4 auto dot1q 1-1005

set trunk 4/5 auto negotiate 1-1005

set trunk 4/6 auto negotiate 1-1005

set trunk 4/7 auto negotiate 1-1005

set trunk 4/8 auto isl 1-1005

set spantree portfast 4/1-8 disable

set spantree portcost 4/1-8 4

set spantree portpri 4/1-8 32

set spantree portvlanpri 4/1 0

set spantree portvlanpri 4/2 0

set spantree portvlanpri 4/3 0

set spantree portvlanpri 4/4 0

set spantree portvlanpri 4/5 0

set spantree portvlanpri 4/6 0

set spantree portvlanpri 4/7 0

set spantree portvlanpri 4/8 0

set spantree portvlancost 4/1 cost 3

set spantree portvlancost 4/2 cost 3

set spantree portvlancost 4/3 cost 3

set spantree portvlancost 4/4 cost 3

set spantree portvlancost 4/5 cost 3

set spantree portvlancost 4/6 cost 3

set spantree portvlancost 4/7 cost 3

set spantree portvlancost 4/8 cost 3

set port qos 4/1-8 cos 0

set port qos 4/1-8 trust untrusted

set port qos 4/1-8 port-based

set port qos 4/1-8 policy-source cops

set port rsvp 4/1-8 dsbm-election disable 128

set port gvrp 4/1-8 disable

set gvrp registration normal 4/1-8

set gvrp applicant normal 4/1-8

set port gmrp 4/1-8 enable

set gmrp registration normal 4/1-8

set gmrp fwdall disable 4/1-8

set port channel 4/1-8 mode auto silent

set port jumbo 4/1 disable

set port jumbo 4/2 disable

set port jumbo 4/3 disable

set port jumbo 4/4 disable

set port jumbo 4/5 disable

set port jumbo 4/6 disable

set port jumbo 4/7 disable

set port jumbo 4/8 disable

!

#module 5 empty

!

#module 6 empty

!

#module 7 empty

!

#module 8 empty

!

#module 9 empty

!

#module 15 : 1-port Multilayer Switch Feature Card

set module name 15

set module enable 15

set vlan 1 15/1

set port enable 15/1

set port name 15/1

set cdp enable 15/1

set trunk 15/1 nonegotiate isl 1-1005

set spantree portcost 15/1 4

set spantree portpri 15/1 32

set spantree portvlanpri 15/1 0

set spantree portvlancost 15/1 cost 3

set port rsvp 15/1 dsbm-election disable 128

set port gmrp 15/1 enable

set gmrp registration normal 15/1

set gmrp fwdall disable 15/1

!

#module 16 empty

!

#switch port analyzer

!

#cam

set cam agingtime 1,5-6,55-56,97-99,103-125,200,1003,1005 300

!

#gvrp

set gvrp dynamic-vlan-creation disable

set gvrp disable

end

EDGE SWITCH Configuration:

hostname L5ES4

!

aaa new-model

aaa authentication login default local

enable password 7 <removed>

!

username admin1 password 7 <removed>

username admin2 password 7 <removed>

!

!

!

!

!

ip subnet-zero

!

stackmaker name 5th-floor

!

!

interface FastEthernet0/1

spanning-tree portfast

!

interface FastEthernet0/2

spanning-tree portfast

!

interface FastEthernet0/3

spanning-tree portfast

!

interface FastEthernet0/4

spanning-tree portfast

!

interface FastEthernet0/24

spanning-tree portfast

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface VLAN1

ip address 10.213.105.14 255.255.255.0

no ip directed-broadcast

no ip route-cache

!

logging trap notifications

logging 10.213.100.124

snmp-server engineID local 0000000902000004DD403640

snmp-server community <removed> RO

snmp-server community <removed> RW

snmp-server chassis-id 0x12

!

line con 0

password 7 <removed>

transport input none

stopbits 1

line vty 0 4

password 7 <removed>

line vty 5 15

password 7 <removed>

!

ntp clock-period 11259547

ntp peer 10.213.105.2

end

L5ES4#sh vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4,

Fa0/5, Fa0/6, Fa0/7, Fa0/8,

Fa0/9, Fa0/10, Fa0/11, Fa0/12,

Fa0/13, Fa0/14, Fa0/15, Fa0/16,

Fa0/17, Fa0/18, Fa0/19, Fa0/20,

Fa0/21, Fa0/22, Fa0/23, Fa0/24,

Gi0/1, Gi0/2

99 VLAN0099 active

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 1002 1003

99 enet 100099 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 1 1003

1003 tr 101003 1500 1005 0 - - srb 1 1002

1004 fdnet 101004 1500 - - 1 ibm - 0 0

1005 trnet 101005 1500 - - 1 ibm - 0 0

L5ES4#sh vtp st

VTP Version : 2

Configuration Revision : 1

Maximum VLANs supported locally : 254

Number of existing VLANs : 6

VTP Operating Mode : Server

VTP Domain Name :

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0x9C 0x0A 0x5A 0x3B 0x83 0xC7 0xA6 0xDE

Configuration last modified by 10.213.105.14 at 5-6-02 17:26:18

6 REPLIES
New Member

Re: How do I add VLANs to switch with native VLAN(not VLAN1)

New Member

Re: How do I add VLANs to switch with native VLAN(not VLAN1)

Hi bsivasub,

for each edge switch, only one VLAN is configured. From the core switch, I can see this command:

set vlan 3/2 105

set trunk 3/2 nonegotiate dot1q 1-1005

however, why is it that I can't see the port in trunking mode?

6509-5th-SW1 (enable) sh port trunk 3/2

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

3/2 auto negotiate not-trunking 105

Port Vlans allowed on trunk

-------- ---------------------------------------------------------------------

3/2 1-1005

Port Vlans allowed and active in management domain

-------- ---------------------------------------------------------------------

3/2 105

Port Vlans in spanning tree forwarding state and not pruned

-------- ---------------------------------------------------------------------

3/2

On the edge switch, When I do a show VLAN, I can see the VLAN 105. but the switchport is not configured with :

switchport mode access vlan.....

switchport mode trunk....

Is it because the switch is in native vlan 105, therefore there is no need to configure per port vlan assignment?

I have this problem when I add in another VLAN --- vlan database, vlan...etc, the whole switch hung..

Cisco Employee

Re: How do I add VLANs to switch with native VLAN(not VLAN1)

Paul

The trunk between the 6500 and the XL is not up

http://www.cisco.com/warp/public/473/43.html

The trunking mode on the 6500 is currently auto on 3/2. Change is to nonegotiate

Under the XL gig interface

switchport trunk encapsulation dot1q (if you decide to do ISL, use ISL)

switchport mode trunk

If you use dot1q, make sure the native VLAN matches on both switches

Regards,

-Prashanth

New Member

Re: How do I add VLANs to switch with native VLAN(not VLAN1)

Hi Prashanth,

Thanks for the pointer.

When I set the gig port to trunk, the switch actually hung. Show VTP stat on the XL shows that it is in Server mode. The core switch is also in VTP server mode. would that result in VTP info to propagate back to the core? and causing the switches to hung? Can I, in this case, set the switch to transparent mode, and assign VLANs accordingly?

rgds,

Paul

Highlighted
Cisco Employee

Re: How do I add VLANs to switch with native VLAN(not VLAN1)

Yes. It is always safe to use transparent VTP mode while introducing a new switch. Make sure you create the VLANs locally in the VLAN database

Regards,

-Prashanth

New Member

Re: How do I add VLANs to switch with native VLAN(not VLAN1)

Thanks Prashanth.

287
Views
0
Helpful
6
Replies