Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
Hall of Fame Super Silver

How do I configure failover on a 2948-L3

Need some help here!

Right now I have a Gigabit wireless bridge that connects two sites. These bridges are connected to a L3-2948 switch. I want to implement a backup 802.11 wireless link between the two buildings. The gigabit being the primary and the 11Mbps being the secondary. The primary gigabit is directly connected to a gigabit port on the 2948. I want to connect the 11Mbps wireless bridge to interface FastEthernet47 on both 2948. How can I make this work. Any ideas or configuration help will be appreciated.

Here is the current config.

Building 1:

interface FastEthernet47

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet48

description connection to internal LAN

ip address 10.2.0.1 255.255.255.0

no ip directed-broadcast

ipx network 230C encapsulation SAP

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet50

description Gig WAN to Bldg 2

ip address 10.10.4.2 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

router eigrp 1

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.4.1

!

bridge 1 protocol dec

Building 2:

interface FastEthernet47

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet48

description Connection to internal LAN

ip address 10.4.0.2 255.255.255.0

no ip directed-broadcast

ipx network A0 encapsulation SAP

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet50

description Gig WAN to Bldg 1

ip address 10.10.4.1 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

bridge-group 1

!

router eigrp 1

network 10.0.0.0

network 192.6.0.0

!

router rip

redistribute eigrp 1

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.4.0.3

ip route 10.6.0.0 255.255.255.0 10.4.0.3

ip route 192.6.1.0 255.255.255.0 10.4.0.3

!

bridge 1 protocol dec

-Scott
*** Please rate helpful posts ***
13 REPLIES

Re: How do I configure failover on a 2948-L3

HI,

you can hook the wireless bridges to the 2948s at either ends, to the fastethernet ports. THese interfaces on 2948 would need ip addresses. ENable eigrp on this link. When gigabit (primary) is up, route in the routing table of 2948 would converge through the gigabit link (due to higher bandwidth, lesser cost). When gigabit fails, all routes would converge over the Wireless link, and provide failover.

Also you could additionally use a static route at each 2948, with a higher administrative distance. Note that admin distance for eigrp is 90. So the static route configured should have a higher value than 90.

on building 1 (network A)

ip route fa0/47 91

on building 2 (network B)

ip route fa0/47 91

When gigabit link is down, these static routes would kick in, and provide failover.

Hope it helps!

Hall of Fame Super Silver

Re: How do I configure failover on a 2948-L3

Does this look okay? I changed around the default gateway. Let me know. Does the bridge-group affect this in any way.

Building 1:

interface FastEthernet47

description Backup WAN to Bldg 2

ip address 10.10.4.4 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

interface FastEthernet48

description connection to internal LAN

ip address 10.2.0.1 255.255.255.0

no ip directed-broadcast

ipx network 230C encapsulation SAP

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet50

description Primary Gig WAN to Bldg 2

ip address 10.10.4.2 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

router eigrp 1

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.4.1

ip route 0.0.0.0 0.0.0.0 10.10.4.3 91

!

bridge 1 protocol dec

Building 2:

interface FastEthernet47

description Backup WAN to Bldg 1

ip address 10.10.4.3 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

bridge-group 1

!

interface FastEthernet48

description Connection to internal LAN

ip address 10.4.0.2 255.255.255.0

no ip directed-broadcast

ipx network A0 encapsulation SAP

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet50

description Primary Gig WAN to Bldg 1

ip address 10.10.4.1 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

bridge-group 1

!

router eigrp 1

network 10.0.0.0

network 192.6.0.0

!

router rip

redistribute eigrp 1

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.4.2

ip route 0.0.0.0 0.0.0.0 10.10.4.4 91

ip route 10.6.0.0 255.255.255.0 10.10.4.2

ip route 10.6.0.0 255.255.255.0 10.10.4.4 91

ip route 192.6.1.0 255.255.255.0 10.10.4.2

ip route 192.6.1.0 255.255.255.0 10.10.4.4 91

!

bridge 1 protocol dec

-Scott
*** Please rate helpful posts ***

Re: How do I configure failover on a 2948-L3

The configs looks fine, as far as failover is concerned. The second default route should kick in, once, the gigabit link fails. You might want to test and see if failover works properly. (schedule an outage window)

The internal lan, the fa0/47 port to wireless bridge and the gigabit link, all 3 of them are in the same bridge group. The fa0/47 should be in blocking state, as far as STP is concerned, and should go to forwarding state only, when the gigabit link fails.

Hall of Fame Super Silver

Re: How do I configure failover on a 2948-L3

Thanks!

By the way.... is it possible to configure this with hsrp? Is there a way I can configure the port for a hold time of some sort just in case the link is bouncing?

-Scott
*** Please rate helpful posts ***

Re: How do I configure failover on a 2948-L3

You cannot do HSRP, since you have only one L3 device. HSRP requires a min of 2 devices.

Holding the route pointing to primary, during a link flap is unnecessary, as you are using static routing. As soon as the router detects the link flap, it would switch over to the second default route, and when the link flap is over, and primary gigabit link comes back, it will converge back. Static routes are the fastest of all routing protocols in terms of convergence.

Hall of Fame Super Silver

Re: How do I configure failover on a 2948-L3

Thanks!

I will give it a shot!

-Scott
*** Please rate helpful posts ***
Hall of Fame Super Silver

Re: How do I configure failover on a 2948-L3

Question on the IPX Network command line. The IOS will not let me use the same IPX network number. Can I do ipx network AA2 encapsulation SAP.

-Scott
*** Please rate helpful posts ***

Re: How do I configure failover on a 2948-L3

I didnt understand what you r trying to configure ? Can you specify the interface on which you are trying to configure this ?? Also do u have this AA2 network anywhere else.(on any other interface on the same router you are trying to configure this). On your configs, i do see a AAe and 230c but not AA2.

Hall of Fame Super Silver

Re: How do I configure failover on a 2948-L3

For example... in Building 1 I'am connecting a wireless bridge for backup to Building 2:

Building 1:

interface FastEthernet47

description Backup WAN to Bldg 2

ip address 10.10.4.4 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

I'am not able to use ipx network AAA3 encapsulation SAP because it is already configured. So can I make a change to that...ipx network AA3 encapsulation SAP. And do that also in building 2. So it would look like this

Building 1:

interface FastEthernet47

description Backup WAN to Bldg 2

ip address 10.10.4.4 255.255.255.0

no ip directed-broadcast

ipx network AA3 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

interface FastEthernet48

description connection to internal LAN

ip address 10.2.0.1 255.255.255.0

no ip directed-broadcast

ipx network 230C encapsulation SAP

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet50

description Primary Gig WAN to Bldg 2

ip address 10.10.4.2 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

ipx output-sap-filter 1000

bridge-group 1

!

router eigrp 1

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.4.1

ip route 0.0.0.0 0.0.0.0 10.10.4.3 91

!

bridge 1 protocol dec

Building 2:

interface FastEthernet47

description Backup WAN to Bldg 1

ip address 10.10.4.3 255.255.255.0

no ip directed-broadcast

ipx network AA3 encapsulation SAP

bridge-group 1

!

interface FastEthernet48

description Connection to internal LAN

ip address 10.4.0.2 255.255.255.0

no ip directed-broadcast

ipx network A0 encapsulation SAP

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet50

description Primary Gig WAN to Bldg 1

ip address 10.10.4.1 255.255.255.0

no ip directed-broadcast

ipx network AAA3 encapsulation SAP

bridge-group 1

!

router eigrp 1

network 10.0.0.0

network 192.6.0.0

!

router rip

redistribute eigrp 1

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.4.2

ip route 0.0.0.0 0.0.0.0 10.10.4.4 91

ip route 10.6.0.0 255.255.255.0 10.10.4.2

ip route 10.6.0.0 255.255.255.0 10.10.4.4 91

ip route 192.6.1.0 255.255.255.0 10.10.4.2

ip route 192.6.1.0 255.255.255.0 10.10.4.4 91

!

bridge 1 protocol dec

-Scott
*** Please rate helpful posts ***

Re: How do I configure failover on a 2948-L3

Yes you can do that,

The link between the two buildings (primary - gigabit and secondary - wireless) doesnt really matter, what ipx network we give on them, because, both of them are transit networks.

Hall of Fame Super Silver

Re: How do I configure failover on a 2948-L3

Thanks a lot again. By the way, I do I really need to create a static route, Because the primary is gigabit and the secondary is 100Mbps and because eigrp would learn the route (backup) .... right? .... just wondering.

-Scott
*** Please rate helpful posts ***

Re: How do I configure failover on a 2948-L3

If you see my previous postings, i had suggested either using EIGRP alone, or using static routes. EIGRP would automatically switch over to the back up route(feasible successor).

Hall of Fame Super Silver

Re: How do I configure failover on a 2948-L3

Yeah... must of forgot. Well thanks for your input.

-Scott
*** Please rate helpful posts ***
103
Views
0
Helpful
13
Replies
CreatePlease to create content