Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

how do I upgrade cisco 2509 using PC ?

Hello Cisco Gurus,

Here is my problem...

I am using old 2509 router for my ccna practice, connected my router using consol cable with usb adapter and using SecureCRT for CLI.

All are just fine and I cqn play around within router.

Now I need to upgrade IOS. I installed SolarWinds TFTP server.

I added ip address to the Int E0. (10.0.0.1 255.255.255.0) and turn up interface and it shows up/down.

Added 10.0.0.2 255.255.255.0 and gateway 10.0.0.0.1 to my Local Area Connection in my PC, it seems pretty easy but I wasted 3 hours figuring out but no luck at all, neither interface shows up/up nor LAN connection shows connected.

I turned off windows firewall and disable my McAfee Antivirus as well but still no avail..

Can anyone help me out and tell me what am I doing wrong?

I know my RJ45 port is empty in my PC and that's why LAN connection shows not connected, but then how am I connect my router to my PC for this upgrade purpose?

Any help would be highly appreciated.

  • Other Network Infrastructure Subjects
13 REPLIES
New Member

1. connect your cisco to the

1. connect your cisco to the PC (tftp server)

2. try ping from cisco to PC, if all right then...

3. type copy tftp: bootflash:

then you should chose correct ip address of tftp server and name of soft

4. after downloading you should type

boot system flash bootflash:name_of_soft

wr

reload

New Member

You have no network

You have no network connection, that's the problem, i.e. plug it in.

You are on the right track in other respects, the commands you need have been mentioned here.

Martin

New Member

Hi,Follow these steps:1.

Hi,

Follow these steps:

1. Place Upgrade file in your PC.

2. Install TFTP in your PC.

3. Connect your PC with Router.

4. Use same IP address for both PC and Router.

5. Now give these commands on Router.

copy tftp:flash

6. Then follow the procedure on router

 

If you any problem then comment back.

New Member

Well, I guess I explained all

Well, I guess I explained all the solutions you guys giving.

 

* I have IOS file on the root TFTP folder

* My Router is connected to my PC through consol cable, since there is no serial interface in my laptop so I got Serial to USB adapter and using SecureCRT for CLI.

* I can successfully play around with the router through the setup above mentioned.

* I setup ip address to the ineterface Ethernet0 and turn it on, but its keep showing up/down, while the same thing on the LAN connection "not connected"

* what I think is since I am not connected through LAN port from my PC thats why LAN connection showing not connected. And no connection made between router and PC.

This is the solution I am looking. How do I make connection between PC and Router using USB to serial cable to consol router.

New Member

You can't upgrade via the

You can't upgrade via the serial connection, that is what I explained earlier.

You need to plug a network cable in between your PC and router, this is the reason the respective interfaces are reporting 'down'.

Martin

New Member

I have the same issue & i got

I have the same issue & i got its solution later. So i can help you.

New Member

Can you please explain? how

Can you please explain? how did you do that?

New Member

sachinforum ...... When you

"added ip address to the Int


"added ip address to the Int E0. (10.0.0.1 255.255.255.0) and turn up interface and it shows up/down."

If the interface is Up - Down that means the Interface is down, by all purposes of network traffic.

I would highly recommend getting a Crosover Cable (Ethernet) or use the old tried method of XModem , which will allow you to upload the IOS over the Console cable but it is very very very slow.

 

Here are the steps to use xmodem to upload the IOS.

 

http://www.cisco.com/c/en/us/support/docs/routers/2600-series-multiservice-platforms/15085-xmodem-generic.html

 

If you dont have a Cross over cable, then adding a simple Hub/Switch on to the network would also solve the issue

 

HTH

 

177
Views
0
Helpful
13
Replies