cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
206
Views
0
Helpful
1
Replies

how do you configure voice and data over frame-relay with separate dlci's

admin_2
Level 3
Level 3

I have 2620 at the remote site with two pvc's. At the head end, I have a 7206 router connected to a 4006 switch with a rsp card with separate vlans. The Call Manager is on vlan 20. How do I configure the routers to have voice only on one pvc and data only on the other?

1 Reply 1

Not applicable

Since the call- manager would have to call signalling directly

over ip to the remote side, you'll have to use policy routing

to send voip traffic over one dlci and data over the other.

_ also make sure you have the right QOS on the frame-relay pvc's

_ you're doing fast switching for policy routed packets.

here is a sample config for input interface from call manager on the c7206.

!

int fastethernet 1/1/0

ip address 1.1.1.1 255.255.255.0

ip policy route-map traffic-warden

ip route-cache policy

!

int serial 2/1/0

no ip address

encapsulation frame-relay

frame-relay traffic-shaping

!

int serial 2/1/0.1 point-to-point

ip address 2.2.2.1 255.255.255.252

frame-relay interface-dlci 100

class Voice

!

int serial 2/1/0.2 point-to-point

ip address 3.3.3.1 255.255.255.252

frame-relay interface-dlci 200

class data

!

access-list 101 permit tcp any any eq 1720

access-list 101 permit tcp any any eq 2000

access-list 101 permit udp any any range 16384 32726

!

route-map traffic-warden permit 10

match ip address 101

set ip next-hop 2.2.2.2 3.3.3.1

!

route-map traffic-warden permit 20

set ip next-hop 3.3.3.1 2.2.2.1

!

map-class frame-relay Voice

frame-relay CIR 64000

frame-relay bc 640

frame-relay fair-queue

frame-relay ip rtp priority 16384 16383 48

frame-relay fragement 80

no frame-relay adptive-shaping

!

map-class frame-relay data

frame-relay CIR 64000

frame-relay bc 640

frame-relay fair-queue

frame-relay ip rtp priority 16384 16383 48

frame-relay fragement 80

no frame-relay adptive-shaping

the data map-class is setup similar to the voice because this would be a redundant link for

all traffic too if the voice pvc fails. the QOS as been put inplace just in case. Also the

data packet need to be fragmented regardless and data can use all bandwidth as long as no

voice flow throuhg the data pvc.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: