Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

how to enable routing on 2514

Hello,

I have an old 2514 running Version 11.0(10c). I have a couple problems. 1) The router does not seem to be routing between the two ethernet interfaces. And 2), how to I reset my passwords so that they are blank? Output from show running-config is below. Thanks in advance!

Rich

cisco-2514#show running-config

Building configuration...

Current configuration:

!

! Last configuration change at 15:10:37 UTC Tue Oct 18 2005

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname cisco-2514

!

enable secret xxx.

enable password xxx

!

!

interface Ethernet0

ip address 192.168.1.1 255.

!

interface Ethernet1

ip address 192.168.2.1 255.255.255.0

!

interface Serial0

no ip address

shutdown

!

interface Serial1

no ip address

shutdown

!

no ip classless

ip route 192.168.1.0 255.255.255.0 Ethernet0

ip route 192.168.1.0 255.255.255.0 Ethernet1

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

end

2 REPLIES

Re: how to enable routing on 2514

Hi Friend,

Few things to be checked...I do not see "ip routing" enabled. Can you please run this command on global config mode and check "sh ip route"

Also I see 2 static routes which I think you do not need because the 2 ethernet interfaces are directly connected and routing will take place automatically.

Please enable ip routing nd also remove the static routes and check, it should work.

ALso to remove both the passwords run this command

no enable secret

no enable password

both on global config mode.

HTH

Ankur

Hall of Fame Super Silver

Re: how to enable routing on 2514

Ankur

The ip routing command is on by default and does not show up in show running-config. We can verify whether ip routing is enabled with show protocol and show ip protocol.

I agree that the static routes are not needed and just confuse the issue. In fact I think it is a bit worse since both static routes are for the same network (which is the connected network of ethernet 0) and point to both ethernet 0 and ethernet 1 as ways to get there. The static routes are centainly not helping and should be removed.

I note that ethernet 0 does not have a valid mask in the configuration. I do not know whether this is just something wrong in cut and paste or if there is a real problem with the interface. I think it might be quite helpful if Rich who sent the original post could post the output of show ip protcol and of show ip interface.

It would also be interesting to know a bit more about how the router is set up. What is connected on ethernet 0 and what is connected on ethernet 1. Can the router ping (standard ping) to any device on ethernet1? If so can the router also do an extended ping to the device on ethernet 1 and specify the source is the address of ethernet 0? I am wondering if there might be issues with the default gateway definitions of the end stations.

HTH

Rick

435
Views
0
Helpful
2
Replies