Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to NAT 2 interfaces

Hi,

I am doing DDR for 2 subnets. 2 dialer interfaces were created and each of them has the same configuration except the dialer string.

My question is, how do I overload 2 dialer interfaces? As you can see below, each dialer profile is dialing a different number to access different location, so I have to NAT these 2 interfaces.

Do you think that overloading the BRI0 will cover both dialer interfaces and will it work?

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type xxxxx

ppp authentication chap

!

interface FastEthernet0

ip address 200.x.x.x x.x.x.x

ip nat inside

speed auto

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 600

dialer fast-idle 5

dialer string xxx

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname xxx

ppp chap password xxx

!

interface Dialer2

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 600

dialer fast-idle 5

dialer string xxx

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname xxx

ppp chap password xxx

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route a.a.a.a x.x.x.x Dialer1

ip route b.b.b.b x.x.x.x Dialer2

!

access-list 1 permit 10.x.x.x x.x.x

dialer-list 1 protocol ip permit

Please advice.

1 REPLY
New Member

Re: How to NAT 2 interfaces

If you wan't to use different transation for those dialers I sugest you use route-maps

route-map RM1

match interface Dialer1

match ip address 1

route-map RM2

match interface Dialer2

match ip address 1

!

ip nat inside source route-map RM1 interface Dialer1

ip nat inside source route-map RM2 interface Dialer2

106
Views
5
Helpful
1
Replies