Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to pass SAP type 8202?

The problem is that Novell public printer agent is not visible across router.

Novell TID said to allow ipx router to pass SAP type 8202. I have tried to add the SAP 8202 service name into a access list then enabling the access list but it is not working.

What is the proper syntax or method to allow the SAP 8202 to pass?

Thank you

15 REPLIES

Re: How to pass SAP type 8202?

Try giving a static sap entry on your sap table.

ipx sap 7 8202

Are you refering to sap type 8202 or printer service sap type 7 with a Novel socket of 8202 ??

New Member

Re: How to pass SAP type 8202?

I am refering to the printer service sap with novell socket 8202.

I have tried creating static map of the sap service, but this is not suitable or my environment since the service name will change very often.

Re: How to pass SAP type 8202?

Are you running IPX rip or IPX eigrp as the routing protocol. You should disable IPX eigrp on the lan segment which has your ipx nodes, as they wont understand, ipx eigrp sap updates. They will understand only ipx sap updates propagated by ipx rip.

New Member

Re: How to pass SAP type 8202?

IP and IPX are routing using RIP.

Re: How to pass SAP type 8202?

Do you see the SAP entry in your router. Is it a cisco router ??

show ipx servers

New Member

Re: How to pass SAP type 8202?

Yes, can see. Yes, cisco 2600 series router.

Re: How to pass SAP type 8202?

Do you have any ipx sap filters configured on any of the interfaces ??

Please paste relevant configs.

New Member

Re: How to pass SAP type 8202?

No ipx sap filter on any interface.

========= config=============

router3620#sh running-config

Building configuration...

Current configuration : 1994 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router3620

!

logging rate-limit console 10 except errors

enable secret

enable password

!

ip subnet-zero

!

!

no ip finger

!

ipx routing 00d0.58f2.6581

!

!

--More-- !

interface FastEthernet0/0

ip address 172.16.1.1 255.255.0.0

speed auto

half-duplex

ipx network 510

ipx network 520 encapsulation SAP secondary

ipx network 530 encapsulation ARPA secondary

ipx network 540 encapsulation SNAP secondary

no mop enabled

!

interface FastEthernet0/1

description connection from Router3620 to FastEthernet2/0 Router3640

ip address 172.19.1.2 255.255.0.0

speed auto

half-duplex

ipx network 910

ipx network 920 encapsulation SAP secondary

ipx network 930 encapsulation ARPA secondary

ipx network 940 encapsulation SNAP secondary

!

interface BRI1/0

no ip address

--More-- shutdown

!

interface FastEthernet1/0

ip address 172.17.1.1 255.255.0.0

speed auto

half-duplex

ipx network 610

ipx network 620 encapsulation SAP secondary

ipx network 630 encapsulation ARPA secondary

ipx network 640 encapsulation SNAP secondary

no mop enabled

!

interface FastEthernet1/1

description connection from f1/1 router3620 to f0/1 router2651rps

ip address 172.18.1.1 255.255.0.0

speed auto

half-duplex

ipx network 710

ipx network 720 encapsulation SAP secondary

ipx network 730 encapsulation ARPA secondary

ipx network 740 encapsulation SNAP secondary

no mop enabled

!

--More-- router rip

redistribute connected

network 172.16.0.0

network 172.17.0.0

network 172.18.0.0

network 172.19.0.0

network 172.30.0.0

network 172.31.0.0

network 192.168.1.0

!

ip classless

ip forward-protocol udp netbios-ss

no ip http server

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

!

!

snmp-server community public RO

!

line con 0

transport input none

--More-- line aux 0

line vty 0 4

password

login

!

end

router3620#sh ipx inter

router3620#sh ipx interface

FastEthernet0/0 is up, line protocol is up

IPX address is 510.00d0.58f2.6581, NOVELL-ETHER [up]

Delay of this IPX network, in ticks is 1 throughput 0 link delay 0

IPXWAN processing not enabled on this interface.

Secondary address is 520.00d0.58f2.6581, SAP [up]

Delay of this IPX network, in ticks is 1

Secondary address is 530.00d0.58f2.6581, ARPA [up]

Delay of this IPX network, in ticks is 1

Secondary address is 540.00d0.58f2.6581, SNAP [up]

Delay of this IPX network, in ticks is 1

IPX SAP update interval is 60 seconds

IPX type 20 propagation packet forwarding is disabled

Incoming access list is not set

Outgoing access list is not set

IPX helper access list is not set

SAP GGS output filter list is not set

SAP GNS processing enabled, delay 0 ms, output filter list is not set

SAP Input filter list is not set

SAP Output filter list is not set

SAP Router filter list is not set

Input filter list is not set

Output filter list is not set

Router filter list is not set

--More-- Netbios Input host access list is not set

Netbios Input bytes access list is not set

Netbios Output host access list is not set

Netbios Output bytes access list is not set

Updates each 60 seconds aging multiples RIP: 3 SAP: 3

SAP interpacket delay is 55 ms, maximum size is 480 bytes

RIP interpacket delay is 55 ms, maximum size is 432 bytes

RIP response delay is not set

IPX accounting is disabled

IPX fast switching is configured (enabled)

RIP packets received 710, RIP packets sent 397, 0 Throttled

RIP specific requests received 62, RIP specific replies sent 62

RIP general requests received 0, 0 ignored, RIP general replies sent 0

SAP packets received 3001, SAP packets sent 7181, 0 Throttled

SAP GNS packets received 93, SAP GNS replies sent 92

SAP GGS packets received 0, 0 ignored, SAP GGS replies sent 0

FastEthernet0/1 is up, line protocol is up

IPX address is 910.00d0.58f2.6582, NOVELL-ETHER [up]

Delay of this IPX network, in ticks is 1 throughput 0 link delay 0

IPXWAN processing not enabled on this interface.

Secondary address is 920.00d0.58f2.6582, SAP [up]

Delay of this IPX network, in ticks is 1

Secondary address is 930.00d0.58f2.6582, ARPA [up]

--More-- Delay of this IPX network, in ticks is 1

Secondary address is 940.00d0.58f2.6582, SNAP [up]

Delay of this IPX network, in ticks is 1

IPX SAP update interval is 60 seconds

IPX type 20 propagation packet forwarding is disabled

Incoming access list is not set

Outgoing access list is not set

IPX helper access list is not set

SAP GGS output filter list is not set

SAP GNS processing enabled, delay 0 ms, output filter list is not set

SAP Input filter list is not set

SAP Output filter list is not set

SAP Router filter list is not set

Input filter list is not set

Output filter list is not set

Router filter list is not set

Netbios Input host access list is not set

Netbios Input bytes access list is not set

Netbios Output host access list is not set

Netbios Output bytes access list is not set

Updates each 60 seconds aging multiples RIP: 3 SAP: 3

SAP interpacket delay is 55 ms, maximum size is 480 bytes

RIP interpacket delay is 55 ms, maximum size is 432 bytes

--More-- RIP response delay is not set

IPX accounting is disabled

IPX fast switching is configured (enabled)

RIP packets received 334, RIP packets sent 336, 0 Throttled

RIP specific requests received 0, RIP specific replies sent 0

RIP general requests received 0, 0 ignored, RIP general replies sent 0

SAP packets received 6754, SAP packets sent 6195, 0 Throttled

SAP GNS packets received 0, SAP GNS replies sent 0

SAP GGS packets received 0, 0 ignored, SAP GGS replies sent 0

FastEthernet1/0 is up, line protocol is up

IPX address is 610.00d0.58f2.6591, NOVELL-ETHER [up]

Delay of this IPX network, in ticks is 1 throughput 0 link delay 0

IPXWAN processing not enabled on this interface.

Secondary address is 620.00d0.58f2.6591, SAP [up]

Delay of this IPX network, in ticks is 1

Secondary address is 630.00d0.58f2.6591, ARPA [up]

Delay of this IPX network, in ticks is 1

Secondary address is 640.00d0.58f2.6591, SNAP [up]

Delay of this IPX network, in ticks is 1

IPX SAP update interval is 60 seconds

IPX type 20 propagation packet forwarding is disabled

Incoming access list is not set

Outgoing access list is not set

--More-- IPX helper access list is not set

SAP GGS output filter list is not set

SAP GNS processing enabled, delay 0 ms, output filter list is not set

SAP Input filter list is not set

SAP Output filter list is not set

SAP Router filter list is not set

Input filter list is not set

Output filter list is not set

Router filter list is not set

Netbios Input host access list is not set

Netbios Input bytes access list is not set

Netbios Output host access list is not set

Netbios Output bytes access list is not set

Updates each 60 seconds aging multiples RIP: 3 SAP: 3

SAP interpacket delay is 55 ms, maximum size is 480 bytes

RIP interpacket delay is 55 ms, maximum size is 432 bytes

RIP response delay is not set

IPX accounting is disabled

IPX fast switching is configured (enabled)

RIP packets received 501, RIP packets sent 369, 0 Throttled

RIP specific requests received 29, RIP specific replies sent 29

RIP general requests received 4, 0 ignored, RIP general replies sent 4

SAP packets received 1320, SAP packets sent 7314, 0 Throttled

--More-- SAP GNS packets received 9, SAP GNS replies sent 3

SAP GGS packets received 4, 0 ignored, SAP GGS replies sent 87

FastEthernet1/1 is up, line protocol is up

IPX address is 710.00d0.58f2.6592, NOVELL-ETHER [up]

Delay of this IPX network, in ticks is 1 throughput 0 link delay 0

IPXWAN processing not enabled on this interface.

Secondary address is 720.00d0.58f2.6592, SAP [up]

Delay of this IPX network, in ticks is 1

Secondary address is 730.00d0.58f2.6592, ARPA [up]

Delay of this IPX network, in ticks is 1

Secondary address is 740.00d0.58f2.6592, SNAP [up]

Delay of this IPX network, in ticks is 1

IPX SAP update interval is 60 seconds

IPX type 20 propagation packet forwarding is disabled

Incoming access list is not set

Outgoing access list is not set

IPX helper access list is not set

SAP GGS output filter list is not set

SAP GNS processing enabled, delay 0 ms, output filter list is not set

SAP Input filter list is not set

SAP Output filter list is not set

SAP Router filter list is not set

Input filter list is not set

--More-- Output filter list is not set

Router filter list is not set

Netbios Input host access list is not set

Netbios Input bytes access list is not set

Netbios Output host access list is not set

Netbios Output bytes access list is not set

Updates each 60 seconds aging multiples RIP: 3 SAP: 3

SAP interpacket delay is 55 ms, maximum size is 480 bytes

RIP interpacket delay is 55 ms, maximum size is 432 bytes

RIP response delay is not set

IPX accounting is disabled

IPX fast switching is configured (enabled)

RIP packets received 324, RIP packets sent 337, 0 Throttled

RIP specific requests received 0, RIP specific replies sent 0

RIP general requests received 0, 0 ignored, RIP general replies sent 0

SAP packets received 5543, SAP packets sent 7406, 0 Throttled

SAP GNS packets received 0, SAP GNS replies sent 0

SAP GGS packets received 0, 0 ignored, SAP GGS replies sent 0

router3620#

router3620#

router3620#exit

Re: How to pass SAP type 8202?

Try giving a "debug ipx sap activity" and see if the particular SAP entry for 8202 in your router's SAP table is being advertised on the segment where IPX nodes are present. (fa0/0 or fa0/1 i dont know which).

the show ipx interface command does say that both interfaces are advertising 3 ipx networks, as well as 3 SAP entries on both interfaces fa0/0 and fa0/1. I dont know which all services are there in the SAP table. How many entries do you see in your SAP table (show ipx servers). Is it 3 ??

New Member

Re: How to pass SAP type 8202?

Thank you for keeping up with me.

I know we are all eager to resolve the issue ASAP, unfortunately, I have some weekly task to complete at this time. I won't be able to get back on this until next week (I do not have access over the weekend).

But from my earlier notes, 'show ipx servers' displayed a very long list since this (~100 names). But the last 3 entries are the SAP 8202. The entry looks somewhat like this:

8202 RINC_BROKER xxxx.0000.0000.0001:90B4 ...

There are ipx nodes as well as sap service advertising presents on fe0/0 and fe0/1.

If you need more details please post.

New Member

Re: How to pass SAP type 8202?

Hi,

I just have some more information.

I need to go back and answer your first question more clearly.

Q: Are you refering to sap type 8202 or printer service sap type 7 with a Novel socket of 8202 ??

A: "debug ipx sap activity" shows that the service is Tpye "0x8202".

When running the "debug ipx sap activity", I do see the service being broadcast, it shows the following entry from the debug output:

"Type 0x8202, RINC9_BROKER, 4D5D919.0000.0000.0001(90B4), 3 Hops"

Do you have any update as to why client across router can not see the printer name advertised by the service name above?

Thank you.

Re: How to pass SAP type 8202?

The problem neednt be with the Cisco router. Does the ipx clients need any software drivers specific to the printer to see these SAPs ??

New Member

Re: How to pass SAP type 8202?

The required novell client and ndps service are installed on the client.

More info:

Novell TID 10050327

http://support.novell.com/cgi-bin/search/searchtid.cgi?/10050327.htm

Re: How to pass SAP type 8202?

Are there other services (SAP) that clients do see on your network ??

Is there a way on your Novell client, to see the available services (SAPs) on your network ?? If yes, can you check to see whether the nodes, do see this SAP type.

New Member

Re: How to pass SAP type 8202?

I believe that there other SAP services can be see by the novell client.

From the "debug ipx sap activity" there others sap type (eg: 0x414, 0x47, 0x4...).

I think one of the service running on socket "0x4b" , the netware server name, can be seen and accessible by the client across the router.

I guess I just need to know or verify whether "Type 0x8202" is filter out by the router or not? How can I do this? Is there a command to check this?

And if it is filter or not, what would be the appropriate way to allow the router to forward (or pass and not filter) socket 0x8202 besides adding a static route?

221
Views
2
Helpful
15
Replies