cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
543
Views
0
Helpful
2
Replies

How to prioritize FTP as lowest priority.

jkeeffe
Level 2
Level 2

I have a policy-map on both ends of a 100MB link in order to prioritize voice traffice. The policy-map looks like this:

class-map match-any Voice-Control

match ip dscp af31

class-map match-any Voice

match ip dscp ef

!

interface FastEthernet0/0

description 100MB XO Link to Spokane

ip address xxx.xxx.xxx.xxx

service-policy output Voice-Policy

!

policy-map Voice-Policy

class Voice

priority 10000

class Voice-Control

bandwidth 500

class class-default

fair-queue

!

Someone is going to FTP many 600+MB files over the next couple of days and I want to make FTP the lowest priority to insure these file transfers don't cause any congestion grief on the link.

What is the best way to add to, or change, this policy-map to make FTP the lowest priority?

2 Replies 2

Hello,

with the current configuration, the default class covers your FTP traffic. If you want to have FTP traffic as the lowest priority, I would add two more classes to the existing policy, one that allows FTP traffic and one that denies FTP traffic:

class match-all NO_FTP

match ip address 101

class match-all FTP

match ip address 102

!

access-list 101 deny tcp any any eq ftp

access-list 101 permit ip any any

!

access-list 102 permit tcp any any eq ftp

access-list 102 deny ip any any

!

policy-map Voice-Policy

class NO_FTP

set precedence 5

class FTP

set precedence 4

This way, all traffic gets precedence over FTP traffic.

Regards,

Georg

Config is right but one more important thing:

101 and 102 ACLs cover only FTP control channel (TCP 21). But FTP data flow will be from FTP data channel (TCP 20) and therefore for 101 ACL should be:

access-list 101 deny tcp any any eq ftp

access-list 101 deny tcp any any eq ftp-data

access-list 101 deny tcp any eq ftp-data any

access-list 101 permit ip any any.

I've added to and from TCP 20 thinking that FTP data flow may be sourced from both sides. And 102 ACL should be modified this way.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: