Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to "trunk" VLANs between Switches in a Gigastack

I got 3 catalyst 3548XL daisy chained by CX_GIGASTACK modules (half duplex). The 1. switch is connected to a L3 swicth via a trunk. On the 2. and 3. switch connected to the first vis gigastack modules, is it possible 2 have 2 VLANs passing the gigastack links to the 1. Switch?

4 REPLIES
Cisco Employee

Re: How to "trunk" VLANs between Switches in a Gigastack

Sure.. Just make the gigabit interfaces connecting switches using gigastack GBICs to be trunks.

http://www.cisco.com/univercd/cc/td/doc/product/lan/c2900xl/gbic/ig_gbic/mamoins.htm#45629

New Member

Re: How to "trunk" VLANs between Switches in a Gigastack

Hello,

You are right. My concern was half-duplex, see my answer to GP.

THANKS

Simon

VIP Purple

Re: How to "trunk" VLANs between Switches in a Gigastack

Hello,

not sure if I fully understand your question, but if you configure the Gigastack modules, which show up as GigabitEthernet interfaces in your configuration, as trunks, both your VLANs will pass between your switches. So, the config for the Gigastacks should look like this:

For ISL:

interface GigabitEthernet0/1

switchport trunk encapsulation isl

switchport mode trunk

For 802.1Q:

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

Does that answer your question ?

Regards,

GP

New Member

Re: How to "trunk" VLANs between Switches in a Gigastack

Hello,

Thanks for your answer. Yes it answers my question - which I admit was not very clear, I was in a hurry. My concern was when the Gigastack module was in half duplex mode, then I was uncertain if it could be configured as trunk. As you se I managed to do that,

Floor1#sh int status | incl Gi0/1

Gi0/1 connected trunk a-half a-1000 1000BaseCX Gigastack

In fact, I was'nt successful until I configured "switchport nonegotiate"

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

Once again THANKS.

Simon

322
Views
5
Helpful
4
Replies