Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How to test Qos is working or not

Hi,

I have a c2950 switch and have configured QoS for VoIP.

Basically:

1. fa0/17 set to default cos 5

2. fa0/18 have input service policy.

How can I test using 2 XP clients connecting to these 2 ports to test out QoS policy. The show commands seem to show what policy have been configured and is not what I wanted to see. I want to see counters showing QoS is working or appications running to XP to show QoS is working

I have attached a simple configuration of c2950 below.

Thanks and rgds.

Switch#show run

Building configuration...

Current configuration : 3694 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4

wrr-queue cos-map 4 5 6 7

!

class-map match-all VoiceControl

match access-group name VoiceControllist

class-map match-all Voice

match access-group name Voicelist

!

!

policy-map 2950-LAN-Edge-In

class VoiceControl

set ip dscp 26

class Voice

set ip dscp 46

!

mls qos map cos-dscp 0 8 16 26 34 46 48 56

ip subnet-zero

!

spanning-tree extend system-id

!

!

!

interface FastEthernet0/17

description To XP/IP phone

switchport access vlan 29

switchport mode access

no ip address

mls qos cos 5

spanning-tree portfast

!

interface FastEthernet0/18

description To XP/Gatekeeper

switchport access vlan 29

switchport mode access

no ip address

service-policy input 2950-LAN-Edge-In

spanning-tree portfast

!

!

interface Vlan1

ip address 140.231.117.1 255.255.255.0

ip helper-address 140.231.117.15

no ip route-cache

!

ip http server

!

ip access-list extended VoiceControllist

permit tcp any any

ip access-list extended Voicelist

permit udp any any

!

!

line con 0

line vty 5 15

!

end

1 REPLY
Bronze

Re: How to test Qos is working or not

Here are a couple links that are helpful in determining if QoS is working:

click on "Verify and Troubleshoot"

http://www.cisco.com/warp/public/788/voice-qos/voip-ov-fr-qos.html#veri

The quickest way to verify QoS, is this command:

show policy-map interface serial interface#

Here is an explanation of this command:

http://www.cisco.com/warp/public/105/showpolicy.html

NOTE: remember that the values will ALL be zero in your policy map until you saturate the link. (the link must be saturated in order for QoS to engage).

595
Views
0
Helpful
1
Replies
CreatePlease login to create content