Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

howto add another IP/Subnet on an interface

Im trying to add a third ip/subnet on my cisco 2600 router, I didnt actually

add the second one, Im just curious can i add 1 more to make it three?

here's the current config on the router

-------

interface FastEthernet0/0

ip address 201.100.32.99 255.255.255.248 secondary

ip address 201.100.37.157 255.255.255.240

-------

8 REPLIES
Cisco Employee

Re: howto add another IP/Subnet on an interface

You sure can add. Make sure you have the secondary keyword on the third ip address as well

New Member

Re: howto add another IP/Subnet on an interface

Great!! can i know what keyword is it? thnx! just new on routing..

ado
New Member

Re: howto add another IP/Subnet on an interface

secondary :)

New Member

Re: howto add another IP/Subnet on an interface

hm, im confused even as a third subnet/ip ?

New Member

Re: howto add another IP/Subnet on an interface

Yes, you can have multiple secondary addresses on a single interface. I have had as many as 4. I am not sure what the max is, but I would think it dpends on how much traffic you are trying to push through...

Cisco Employee

Re: howto add another IP/Subnet on an interface

yes even with the third ip subet you use the word secondary. there is only the concept of primary ip addresss and the rest of the them are just secondary

like

int e0

ip address 172.18.118.1 255.255.255.0

ip address 10.1.1.1 255.255.255.0 secondary

ip address 10.1.2.1 255.255.255.0 secondary

hope this clears the confusion

New Member

Re: howto add another IP/Subnet on an interface

You could also use subinterfaces to add more subnets to the same interface. This would be easier to understand because the keyword secondary wouldn't have to be used. You could do something like the following:

interface e0.0

ip address 192.168.1.1 255.255.255.0

no shut

interface e0.1

ip address 192.168.2.1 255.255.255.0

no shut

inteface e0.2

ip address 192.168.3.1 255.255.255.0

no shut

interface e0.4

ip address 192.168.4.1 255.255.255.0

no shut

255.255.255.0 is the default subnet mask for class C networks because in this example I have used a class C network address which is also a private address which imho is what you should use for intranets. You should use the appropriate subnet mask on your network.

New Member

Re: howto add another IP/Subnet on an interface

Always keep in mind thata bunch of secondary addresses shows a bad IP design ! Usually this is not TCP/IP standard and a goodie for migration purposes. You force a router to process switching with secondary addresses which means high CPU load ! Also ICMP messages got send by the primary address only and this can cause other problems in certain scenarios !

777
Views
7
Helpful
8
Replies