Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HSRP and Load Balancing

I have one remote office with two T1's connected via a 4-port serial card off of one router. I have another 7206 which is connected to my network-with no circuits attached, and would like to utilize it in a load-balanced configuration.

My current config has ip-unnumbered for both serial links. I use EIGRP for routing updates between this router and my other WAN Routers.

I guess my main question is, what is the best design for multiple circuits on multiple core routers? I need to use HSRP for a virtual IP address and EIGRP for routing updates.

I would like to get use out of that second router, and I have a couple other offices that may get multiple circuits in the future.

Thanks

3 REPLIES

Re: HSRP and Load Balancing

Hello,

HSRP is for providing hosts/devices on a LAN segment a redundant default-gateway/first-hop router incase their default-gateway/first-hop router fails. It doesn't really have anything to do the WAN interfaces or routing protocols. HSRP can track/watch a Serial interface and adjust priorities if a interface goes down.

So, in your scenario you could put 1 T1 on each router and run EIGRP for routing, HSRP on the LAN providing the users with a Virtual IP address for their default gw. To load balance, you would use 2 HSRP groups (MHSRP) and 2 Virtual IP addresses. One group would be active on one router and the other group active on the 2nd router. You would then assign half the users to the 1st Virtual IP and the other half to the 2nd Virtual IP.

New Member

Re: HSRP and Load Balancing

ebergquist is correct . . . the config could look like:

ROUTER A ---------------------------------

interface FastEthernet0/0

ip address 192.168.231.251 255.255.255.0

standby 1 priority 95 preempt

standby 1 ip 192.168.231.254

standby 1 track Se0/0

standby 2 preempt

standby 2 ip 192.168.231.253

standby 2 track Se0/0

ROUTER B ---------------------------------

interface FastEthernet0/0

ip address 192.168.231.250 255.255.255.0

standby 1 preempt

standby 1 ip 192.168.231.254

standby 1 track Se0/0

standby 2 priority 95 preempt

standby 2 ip 192.168.231.253

standby 2 track Se0/0

Good luck

Steve

New Member

Re: HSRP and Load Balancing

In this case, if a heart-beep line is needed between router A and router B? what if the 2 router are set in 2 different sites? other user site connect them though 2 DDN lines.

226
Views
0
Helpful
3
Replies