Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

HSRP and Spanningtree

I have configured HSRP on two Cat4006 and when I activate the redundant link I get a Dupaddress error. I know this is a spanningtree issue. I have made my active switch the bridge root and the second switch the secondary but I still get loop errors. Should I place everyting except the bridge root in blocking state?

4 REPLIES
Community Member

Re: HSRP and Spanningtree

how many connections do you have between the two switches. If you have more than one then you have to trunk the connections. Or you will create a layer two loop. And that is what you are experiencing

Community Member

Re: HSRP and Spanningtree

I do not have a physical connection between the two switches. Do I need a connection between them?

Community Member

Re: HSRP and Spanningtree

as long as they can see each other.

but mainly they have a link between them, all really depends on your design

Community Member

Re: HSRP and Spanningtree

I have a similiar situation between a 6509 and 4006, however there is a trunk riding over dual gig connections.

The config for the 6509, acting as primary is:

interface Vlan215

description

ip address 172.xxx.xxx.254 255.255.255.0

ip ospf priority 10

no cdp enable

standby 215 priority 105 preempt

standby 215 ip 172.xxx.xxx.1

The config for the 4006, acting as fail-over is:

interface Port-channel1.215

description IDX Vlan

encapsulation dot1Q 215

ip address 172.xxx.xxx.253 255.255.255.0

no ip redirects

no ip directed-broadcast

ip ospf cost 10

ip ospf priority 5

standby 215 ip 172.xxx.xxx.1

You need some linkage between the two routers, otherwise Standby will not see the status of the primary and assume it.

160
Views
0
Helpful
4
Replies
CreatePlease to create content