Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

HSRP Crashes 2621

Hi,

Has anyone ever an issue when you have two routers running HSRP and try and remove the HSRP config from the standby router it reboots?

It seems to happen on the "standby <grp> ip" command.

Anyone see this before?

Thanks in advance.

6 REPLIES
Cisco Employee

Re: HSRP Crashes 2621

Can you paste the show version&show run showing the interface and HSRP portions of the config. Then show us the actual CLI session that crashes, please

Bronze

Re: HSRP Crashes 2621

Here is the router config that is having the issue. The command that seems to crash the router is....

no standby 1 ip 192.168.1.161

and

no standby 2 ip 192.168.1.254

interface FastEthernet0/0

description LAN INTERFACE One

ip address 192.168.1.163 255.255.255.240

speed 100

full-duplex

standby use-bia

standby 1 priority 95 preempt

standby 1 ip 192.168.1.161

!

interface FastEthernet0/1

description LAN INTERFACE Two

ip address 192.168.1.242 255.255.255.240

speed 100

full-duplex

standby use-bia

standby 2 priority 95 preempt

standby 2 ip 192.168.1.254

RT-Backup-1#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.1(5)T9, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Sun 24-Jun-01 03:16 by cmong

Image text-base: 0x80008088, data-base: 0x8101A744

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

RT-Backup-1 uptime is 4 hours, 19 minutes

System returned to ROM by error - a SIGTRAP exception, PC 0x803C4FD8 at 10:44:30 CST Mon Feb 2 2004 <------Could this be something?

System restarted at 08:55:13 CST Mon Feb 9 2004

System image file is "flash:c2600-is-mz.121-5.T9.bin"

cisco 2621 (MPC860) processor (revision 0x600) with 34816K/6144K bytes of memory.

Processor board ID JAD05490XYC (1786226560)

M860 processor: part number 0, mask 49

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

Primary Rate ISDN software, Version 1.1.

2 FastEthernet/IEEE 802.3 interface(s)

31 Serial network interface(s)

1 Channelized E1/PRI port(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Thanks for your help.

Cisco Employee

Re: HSRP Crashes 2621

No known bugs and I recreated and did not crash.

If this is a issue for you, please open TAC case to look at more detailed.

New Member

Re: HSRP Crashes 2621

I thing it is not problem with hsrp. did u check the reg value is 0x2102 by command sh version. Ip address which you are using for standby is being used by another machine.or insufficient RAM.

Bronze

Re: HSRP Crashes 2621

Thanks for the help!!!

What is this line saying in the sh ver...

System returned to ROM by error - a SIGTRAP exception, PC 0x803C4FD8 at 10:44:30 CST Mon Feb 2 2004

Thanks,

mg

Cisco Employee

Re: HSRP Crashes 2621

In general, a SIGTRAP is going to reference a SIGNAL. For instance, in UNIX, when do a kill -9 , you are sending a signal number 9 to the process or 15 is the number for a regular process terminate. So, when you are doing the command, the software is sending a signal to some component. Probably what is going on is that the software is sending a signal to the hardware and it is crashing. It needs to be looked at in more detail than what we can offer here. Try to replicate this issue on another 2621 and more than likely it is happening on just this one router.

158
Views
0
Helpful
6
Replies
CreatePlease login to create content