Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

HSRP FOR 20 Vlan's

Hi!

I'll implement HSRP Between 2 6509-Sup1.i have more than 20 interface vlan.to each vlan should i assign virtual ip address?have a look to simple config:

interface vlan 2

ip address 1.0.0.2 255.0 0.0

standby 1 ip 1.0.0.2

standby 1 preempt

standby 1 priority 110

.............................

interface vlan 11

ip address 1.1.0.2 255.0 0.0

standby 1 ip 1.1.0.11

standby 1 preempt

standby 1 priority 110

.................................

interface vlan 12

ip address 1.3.0.2 255.0 0.0

standby 1 ip 1.3.0.12

standby 1 preempt

standby 1 priority 110

..........................

interface vlan 13

ip address 1.4.0.2 255.0 0.0

standby 1 ip 1.1.0.13

standby 1 preempt

standby 1 priority 110

...............................

and so obn for the remaining vlans.this config for remaining Vlans should be the same.?or i have problem in the above config?i have mistake.TRY TO CORRECT AND Advise me to the optimum config for my situation.

waiting ur help

10xs

14 REPLIES
New Member

Re: HSRP FOR 20 Vlan's

sorry like this the config:PS correct and advise!

interface vlan 2

ip address 1.0.0.2 255.0 0.0

standby 1 ip 1.0.0.2

standby 1 preempt

standby 1 priority 110

.............................

interface vlan 11

ip address 1.1.0.2 255.0 0.0

standby 2 ip 1.1.0.11

standby 2 preempt

standby 2 priority 110

.................................

interface vlan 12

ip address 1.3.0.2 255.0 0.0

standby 3 ip 1.3.0.12

standby 3 preempt

standby 3 priority 110

..........................

interface vlan 13

ip address 1.4.0.2 255.0 0.0

standby 4 ip 1.4.0.13

standby 4 preempt

standby 4 priority 110

...............................

New Member

Re: HSRP FOR 20 Vlan's

Hi

sorry/i'm forgot to add this:standby 2 timers 5 15 on all Vlan's.what ur sugestion now?where my mistake now.PS Advice

10xs

Ali

Re: HSRP FOR 20 Vlan's

Hi

Ali

HSRP implementation requires 3 IP's.U r using 2 IPs

the config should be like this.

interface vlan 2

ip address 1.1.1.1 255.255.255.0

standby 1 ip 1.1.1.3

standby 1 preempt

standby 1 priority 110

on the other switch

interface vlan 2

ip address 1.1.1.2 255.255.255.0

standby 1 ip 1.1.1.3

standby 1 preempt

standby 1 priority 100

Thanks

Mahmood

New Member

Re: HSRP FOR 20 Vlan's

Hi Mahmood!

ofcourse i have on the 2nd switch like this config.but the question is the config that i have listed correct.meet my 20 Vlan's.or more.Have a look:

6509 1(ACTIVE)

interface vlan 2

ip address 1.0.0.2 255.0 0.0

standby 1 ip 1.0.0.3

standby 1 timers 5 15

standby 1 preempt

standby 1 priority 110

.............................

interface vlan 11

ip address 1.1.0.2 255.0 0.0

standby 2 timers 5 15

standby 2 ip 1.1.0.11

standby 2 preempt

standby 2 priority 110

.................................

interface vlan 12

ip address 1.3.0.2 255.0 0.0

standby 3timers 5 15

standby 3 ip 1.3.0.12

standby 3 preempt

standby 3 priority 110

..........................

interface vlan 13

ip address 1.4.0.2 255.0 0.0

standby 4 timers 5 15

standby 4 ip 1.4.0.13

standby 4 preempt

standby 4 priority 110

.....................................

6509 2(STANDBY)

interface vlan 2

ip address 1.0.0.3 255.0 0.0

standby 1 ip 1.0.0.3

standby 1 timers 5 15

standby 1 preempt

standby 1 priority 100

.............................

interface vlan 11

ip address 1.1.0.4 255.0 0.0

standby 2 timers 5 15

standby 2 ip 1.1.0.11

standby 2 preempt

standby 2 priority 100

.................................

interface vlan 12

ip address 1.3.0.5 255.0 0.0

standby 3timers 5 15

standby 3 ip 1.3.0.12

standby 3 preempt

standby 3 priority 100

..........................

interface vlan 13

ip address 1.4.0.5 255.0 0.0

standby 4 timers 5 15

standby 4 ip 1.4.0.13

standby 4 preempt

standby 4 priority 100

.HAVE A LOOK TO THIS CONFIG WAHT IS UR ADVISE?

10XS

Blue

Re: HSRP FOR 20 Vlan's

your config is incorrect. try the following:

6509 1(ACTIVE)

interface vlan 2

ip address 1.0.0.2 255.0 0.0

standby 1 ip 1.0.0.1

standby 1 timers 5 15

standby 1 preempt

standby 1 priority 110

.............................

6509 2(STANDBY)

interface vlan 2

ip address 1.0.0.3 255.0 0.0

standby 1 ip 1.0.0.1

standby 1 timers 5 15

standby 1 preempt

standby 1 priority 100

.............................

Re: HSRP FOR 20 Vlan's

ali your vlan2 ip address and virtual ip is same so just correct it... otherthan that is okay...

regards

Devang

Re: HSRP FOR 20 Vlan's

You will want to specify a unique hsrp group id per interface group - see below. NoteL the standby group # does not have to correlate with the interface, I just did that out of habit to simplify administration.

nterface vlan 2

ip address 1.0.0.2 255.0 0.0

standby 2 ip 1.0.0.2

standby 2 preempt

standby 2 priority 110

.............................

interface vlan 11

ip address 1.1.0.2 255.0 0.0

standby 11 ip 1.1.0.11

standby 11 preempt

standby 11 priority 110

.................................

interface vlan 12

ip address 1.3.0.2 255.0 0.0

standby 12 ip 1.3.0.12

standby 12 preempt

standby 12 priority 110

and the other hsrp devices in the same group(s) should be numbered the same way per interface in that particular group, be sure to use a different priority though

Hall of Fame Super Silver

Re: HSRP FOR 20 Vlan's

There is an issue that Greg corrected but did not comment on and which Eric missed. In vlan 2 the ip address used on the interface is the same as the address specified for the virtual address:

nterface vlan 2

ip address 1.0.0.2 255.0 0.0

standby 2 ip 1.0.0.2

That will not work. The virtual address needs to be different from the physical address.

There is another issue in this example: all of the vlans are assigning addresses in network 1.0.0.0/8. This will not work. Either each vlan needs to be in a unique major network or the mask needs to be something like 255.255.255.0 rather than 255.0.0.0

In the original post there was this:

interface vlan 13

ip address 1.4.0.2 255.0 0.0

standby 1 ip 1.1.0.13

assuming that the mask issue gets fixed this would not work since the virtual address needs to be in the same subnet as the physical address.

HTH

Rick

Re: HSRP FOR 20 Vlan's

Good catch. I saw the hsrp group numbers and was focused on that...

New Member

Re: HSRP FOR 20 Vlan's

Hi all!

10xs for all ur reply;I'll Rate all the posts.

New Member

Re: HSRP FOR 20 Vlan's

A lot of CCIE's including myself have adopted a common practice of re-using the same hsrp group # on multiple vlans.

It simplifies configuration, administration, troubleshooting, etc. plus on various platforms you may be limited to as few as 16 groups or 256, neither of which proves sufficient depending on how many vlans you have in a given environment so whats the point of naming a unique hsrp group after the vlan # when it won't scale anyway and isn't needed?

http://www.cisco.com/warp/public/473/168.html#q1

Q. What is the implication of using the same HSRP group ID on multiple interfaces?

A. When you define the same HSRP group ID on multiple interfaces, they share the same HSRP virtual MAC address. In most modern LAN switches, there are no issues because they maintain a per-VLAN MAC address table. However, if your network contains any third-party switches, which maintain a system wide MAC address table regardless of VLAN, you can experience problems.

Other advice I'd give you is:

-do use hsrp authentication

-do set the primary hsrp with a higher priority

-do set the primary hsrp with preempt

-do consider glbp (gateway load balancing protocol) instead of hsrp if you need outbound load balancing on your first hop; return traffic is normally load balanced via your dynamic routing protocols

-do use igmp/cgmp since hsrp is multicast

-don't mess with hsrp timers (as a general rule)

Enjoy.

Re: HSRP FOR 20 Vlan's

One thing that nobody has mentioned so far is all your interface IP addresses overlap.... You are using class A network 1.0.0.0 with it's natural class A mask on each interface, this is not a valid configuration. This may be a typo on your part though in hiding your original IP addresses. If it isn't then I suggest re-doing your IP addressing.

HTH

Andy

Hall of Fame Super Silver

Re: HSRP FOR 20 Vlan's

Andy

Did you not read the middle paragraph in my post which made this point?

HTH

Rick

Re: HSRP FOR 20 Vlan's

[quote]Did you not read the middle paragraph in my post which made this point? [/quote]

Obviously not Rick, my mistake :o)

Andy

292
Views
28
Helpful
14
Replies