Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

HSRP Group number mismatch

We have two routers in an HSRP config. The primary failed but the second didn't take over, they seem to be participating just fine from a show standby, and the only thing I can see is that the standby group number doesn't match on the two routers. Is it necessary that they match? Is there a but related to that? The code is 12.2

Thanks

5 REPLIES

Re: HSRP Group number mismatch

Yes, the standby group # and standby IP address need to be the same.

One will be ACTIVE and the other will be STANDBY.

Bronze

Re: HSRP Group number mismatch

Yes they should, and the router with the higher priority should be the active

router for that group. You might also have different group numbers if you are

using multiple standby groups. Try reading the release notes for your IOS version for some caveats (if there are) that might have an effect on your HSRP.

You can also post the config if you want so that other members of this

forum might be able to give you an input.

Goodluck!

New Member

Re: HSRP Group number mismatch

Thanks a lot. here are the configs of the two routers along with a sh stand. You can reply directly to me at wegert@berbee.com if it's more convenient.

Thanks again

webstergw2#Show standby

FastEthernet1/0 - Group 100

Local state is Active, priority 110, may preempt

Hellotime 3 sec, holdtime 10 sec

Next hello sent in 00:00:01.128

Virtual IP address is 10.7.32.1 configured

Active router is local

Standby router is 10.7.32.3 expires in 00:00:09.608

Virtual mac address is 0000.0c07.ac64

8 state changes, last state change 1w0d

Tracking interface states for 1 interface, 1 up:

Up FastEthernet0/0

webstergw2#show running-conf

Building configuration...

Current configuration : 1651 bytes

!

! No configuration change since last restart

!

version 12.2

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname webstergw2

!

logging buffered 4096 warnings

enable secret 5 $1$pJrm$fkuqzNvkRlaZxeWyjxoGM0

!

!

!

clock timezone CST -6

clock summer-time CDT recurring

ip subnet-zero

ip cef

!

!

!

ipx routing 0007.507f.fc81

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description Primary Interface VLAN A

ip address 10.10.224.2 255.255.240.0

speed 100

full-duplex

ipx network AAAAAAAA

!

interface FastEthernet0/1

description Secondary Interface VLAN B

ip address 10.13.224.22 255.255.240.0

speed 100

full-duplex

ipx network BBBBBBBB

!

interface FastEthernet1/0

description Webster LAN

ip address 10.7.32.2 255.255.240.0

ip helper-address 10.7.16.230

ip helper-address 10.7.80.206

speed 100

full-duplex

ipx network 107

standby 100 ip 10.7.32.1

standby 100 priority 110

standby 100 preempt

standby 100 track FastEthernet0/0

!

router eigrp 100

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

ip forward-protocol udp 5405

ip route 0.0.0.0 0.0.0.0 10.10.224.1

no ip http server

ip pim bidir-enable

!

access-list 1 permit 10.7.16.32

access-list 1 permit 10.7.16.217

!

snmp-server community Morpheus RO 1

!

!

!

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

line con 0

password 7 0204085E0E02062F4B

line aux 0

line vty 0 4

password 7 094E420C1C011E1C0C

login

!

ntp clock-period 17180037

ntp server 10.10.224.1

!

end

webstergw3#show standby

FastEthernet1/0 - Group 100

Local state is Standby, priority 100

Hellotime 3 sec, holdtime 10 sec

Next hello sent in 00:00:00.764

Virtual IP address is 10.7.32.1 configured

Active router is 10.7.32.2 expires in 00:00:09.600, priority 110

Standby router is local

10 state changes, last state change 1w0d

Tracking interface states for 1 interface, 1 up:

Up FastEthernet0/1

webstergw3#show running-conf

Building configuration...

Current configuration : 1553 bytes

!

! No configuration change since last restart

!

version 12.2

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname webstergw3

!

logging buffered 4096 warnings

enable secret 5 $1$bm2Z$PqaoUnJ9Im3ShfUqityqb.

!

!

!

clock timezone CST -6

clock summer-time CDT recurring

ip subnet-zero

ip cef

!

!

!

ipx routing 0007.507f.fc41

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description Secondary Interface VLAN A

ip address 10.10.224.22 255.255.240.0

speed 100

full-duplex

ipx network AAAAAAAA

!

interface FastEthernet0/1

description Primary Interface VLAN B

ip address 10.13.224.2 255.255.240.0

speed 100

full-duplex

ipx network BBBBBBBB

!

interface FastEthernet1/0

description Webster LAN

ip address 10.7.32.3 255.255.240.0

ip helper-address 10.7.16.230

ip helper-address 10.7.80.206

speed 100

full-duplex

ipx network 107

standby 100 ip 10.7.32.1

standby 100 priority 100

standby 100 track FastEthernet0/1

!

router eigrp 100

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip forward-protocol udp 5405

ip route 0.0.0.0 0.0.0.0 10.13.224.1

no ip http server

ip pim bidir-enable

!

access-list 1 permit 10.7.16.32

access-list 1 permit 10.7.16.217

!

snmp-server community Morpheus RO 1

!

!

!

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

line con 0

password 7 0204085E0E02062F4B

line aux 0

line vty 0 4

password 7 06040324494A001702

login

!

ntp clock-period 17180199

ntp server 10.13.224.1

!

end

webstergw3#

Bronze

Re: HSRP Group number mismatch

Hi, the config looks fine. You have the same standby group

and the difference that you have seen is the priority value.

This only means that webstergw2 will be the active router.

You mentioned in your first post that the standby didn't took

over. May I ask what is your baseline (or expected behavior)

once the active router goes down? One difference that I have

noticed is the default route for each router.

Thanks.

Re: HSRP Group number mismatch

How long did you wait for the second to become active when the fail occurred?

The second cfg has a priority of 100 but isn't configured to preempt so will wait until the holdtime expires to take over. Default holdtime is 10 seconds.

427
Views
0
Helpful
5
Replies
CreatePlease to create content