Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP groups limitation.

We have two 6509 switches with cisco Cat6k-MSFC2 (R7000) processor with 491520K/32768K bytes of memory with HSRP configuration.

We planned to use HSRP standby group number same as VLAN name. Below is sample configuration for reference.

interface Vlan26

ip address xxx.xxx.26.xxx 255.255.254.0

ip helper-address xxx.xxx.xxx.xxx

no ip redirects

ip pim sparse-dense-mode

no ip route-cache cef

standby 26 ip xxx.xxx.26.xxx

standby 26 priority 200

standby 26 preempt

But, Once we reached to the limit of 16 HSRP groups. We are no more able to create any new group. Below is the error message

router4#config t

Enter configuration commands, one per line. End with CNTL/Z.

router4(config)#interface Vlan12

router4(config-if)#standby 12 ip xxx.xxx.12.xxx

More than 16 standby groups not supported in this platform.

router4(config-if)#standby 12 priority 100

More than 16 standby groups not supported in this platform.

Conceptually we should able to create up to 254 HSRP groups.

1 REPLY

Re: HSRP groups limitation.

From http://www.cisco.com/en/US/products/hw/switches/ps700/products_configuration_guide_chapter09186a008007f477.html#xtocid10 :

"Follow these guidelines and restrictions when configuring hardware Layer 3 switching:

The PFC2 supports a maximum of 16 unique Hot Standby Routing Protocol (HSRP) group numbers. You can use the same HSRP group numbers in different VLANs. If you configure more than 16 HSRP groups, this restriction prevents use of the VLAN number as the HSRP group number.

Note Identically numbered HSRP groups use the same virtual MAC address, which might cause errors if you configure bridge groups."

So use the same 16 HSRP group numbers over again, just in different vlans.

Hope it helps.

Steve

259
Views
5
Helpful
1
Replies
CreatePlease login to create content