Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HSRP Help

I have 2 switches connected to a Layer 3 switch router.

Switch1 is connected to Router1 via trunk port 28

Switch2 is connected to Router1 via trunk port 27

Both switches are in the same Vlan

2 Routers

192.168.1.1 and 192.168.1.2

Vlan 10 IP 192.168.1.0 255.255.255.0

Help me out with the configuration:

conf t

int g2/0/28.10

encap 1dotq 10

ip address 192.168.1.1 255.255.255.0

standby 100 ip 192.168.0.1

standby 100 priority 110

standby 100 preempt

int g2/0/27.10

encap 1dotq 10

ip address 192.168.1.1 255.255.255.0

standby 100 ip 192.168.0.1

standby 100 priority 110

standby 100 preempt

Where do I put the physical address (192.168.1.2)for the port?

Also what do I assign the 192.168.0.1 address to on the router, is it for Vlan 1 ?

9 REPLIES
Silver

Re: HSRP Help

On the Layer 3 switch just use VLANs instead (not to use no switchport mode).

To do HSRP you need at least two L3 devices, you can do HSRP on L3 device.

On the first L3 device:

interface vlan 10

ip address 192.168.1.2 255.255.255.0

standby 100 ip 192.168.1.1

standby 100 priority 110

standby 100 preempt

On the other L3 device:

interface vlan 10

ip address 192.168.1.3 255.255.255.0

standby 100 ip 192.168.1.1

standby 100 priority 100

standby 100 preempt

And assign VLAN 10 to the proper interface with

switchport access vlan 10

I hope I am correct.

Anyway not clear for me what kind of equipments you have...

http://www.cisco.com/en/US/products/hw/switches/ps5528/products_configuration_guide_chapter09186a00801e85d0.html

Bye,

FCS

New Member

Re: HSRP Help

Your saying the Standby ip is the Gateway IP for vlan 10?

New Member

Re: HSRP Help

Your saying the Standby ip is the Gateway IP for vlan 10?

Re: HSRP Help

Hi Noobie,

the working configurations as follow for the follows switchez.

for HSRP, u need to have minimum of 2 Nos.of Layer 3 switches,

Layer 3 Switch-1(eg.assuming 3550-12T)

interface vlan 2

description ***Switch VLAN***

ip address 192.168.1.2 255.255.255.0

standby 2 ip 192.168.1.1

standby 2 timers 5 15

standby 2 priority 110

standby 2 preempt

interface gi 0/1

description ***switch-A***

switchport trunk encapsulation dot1q

switchport mode trunk

interface gi 0/2

description ***switch-B***

switchport trunk encapsulation dot1q

switchport mode trunk

interface gi 0/3

description ***Layer3-switch-B***

switchport mode trunk encapsulation dot1q

switchport mode trunk

----------------------------------------------

Layer 3 Switch-2

interface vlan 2

description ***Switch VLAN***

ip address 192.168.1.3 255.255.255.0

standby 2 ip 192.168.1.1

standby 2 timers 5 15

standby 2 priority 109

standby 2 preempt

interface gi 0/1

description ***switch-A***

switchport trunk encapsulation dot1q

switchport mode trunk

interface gi 0/2

description ***switch-B***

switchport trunk encapsulation dot1q

switchport mode trunk

interface gi 0/3

description ***Layer3-switch-A***

switchport mode trunk encapsulation dot1q

switchport mode trunk

-----------------------------------------------

on the layer switches(assuming 2950T-24),

switch-A

interface gi 0/1

description ***Layer3-switch-A***

switchport mode trunk

interface gi 0/2

description ***Layer3-switch-B***

switchport mode trunk

switch-B

interface gi 0/1

description ***Layer3-switch-A***

switchport mode trunk

interface gi 0/2

description ***Layer3-switch-A***

switchport mode trunk

-----------------------------------------------

Note: what ever vlans you create in layer 3 swith A, you should also create in layer 3 switch B, on the server/client pc, the gateway should be the standby IP, which means eg.the standby ip address will act as 192.168.1.2 if 192.168.1.1 fails & vice versa.

hope this helps.

rate this post

Re: HSRP Help

sorry noobie,

in my previous response, finally i mentioned "eg.the standby ip address will act as 192.168.1.2 if 192.168.1.1 fails & vice versa. " actually it is if 192.168.1.2 fails 192.168.1.1 will act as 192.168.1.3 & vice versa.

New Member

Re: HSRP Help

Perfect!

Next question...

What if SwitchB connects to Router B via switchC that connects to Router B

RouterA ---------RouterB

' ' '

' ' '

' ' '

' SwitchB-------SwitchC

'

'

SwitchA

Would it still be

int Gi 0/2

description ****Layer 3 Switch B ****

switchport mode trunk

or is there anyother configuration needed on SwitchB?

Silver

Re: HSRP Help

Hi,

In your topology, when Router A fail there will be no connectivity between the swithes and Router B. So in this case you can't enjoy the advantage of HSRP. Router A is a weak point of your infrastructure.

Connect all your L2 switches to the routers with trunk connection. You just set the uplink ports (to the routers and if you have link between the swithces also set trunk - STP will block the ports, so no loop occur) trunk mode with the comand "switchport mode trunk".

If you can please redesign your environment.

Bye

FCS

Please rate me if I helped.

New Member

Re: HSRP Help

Actually all switches are connected to the routers but in this textbox the format is messed up. This is what I actually meant.

Perfect!

Next question...

What if SwitchB connects to Router B via switchC that connects to Router B

RouterA ----------RouterB

|....|.......................|...........|

|....|.......................|...........|

|....|.......................|...........|

| SwitchB-------SwitchC..|

| .......................................|

|........................................|

SwitchA--------------------|

Would it still be

int Gi 0/2

description ****Layer 3 Switch B ****

switchport mode trunk

or is there anyother configuration needed on SwitchB?

Silver

Re: HSRP Help

You don't need extra configuration on Switch B and C, since HSRP are on Router A and B. For Switch B, C and also for A the real GW is not significant they don't need to know which Router is active in HSRP (which is the current GW - they will use just the standby IP as GW). On the swithes set the default gateway as usually with ip default-gateway global configuration command and also set the connection between the switches and routers to trunk.

Go ahead, you can do it...

Bye

FCS

Rate me if I helped.

213
Views
0
Helpful
9
Replies
CreatePlease login to create content